summaryrefslogtreecommitdiffstats
path: root/Source/WebCore/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/WebCore/CMakeLists.txt')
-rw-r--r--Source/WebCore/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Source/WebCore/CMakeLists.txt b/Source/WebCore/CMakeLists.txt
index ff9e12889..58fc73285 100644
--- a/Source/WebCore/CMakeLists.txt
+++ b/Source/WebCore/CMakeLists.txt
@@ -3807,6 +3807,11 @@ if (SHARED_CORE)
install(TARGETS WebCore DESTINATION "${LIB_INSTALL_DIR}")
endif ()
+QT_ADD_EXTRA_WEBKIT_TARGET_EXPORT(WebCore)
+if (ENABLE_TEST_SUPPORT)
+ QT_ADD_EXTRA_WEBKIT_TARGET_EXPORT(WebCoreTestSupport)
+endif ()
+
# [ARM] Build SVGPathElement.cpp with -O2 due to a GCC bug
# https://bugs.webkit.org/show_bug.cgi?id=145377
if ((CMAKE_CXX_COMPILER_ID STREQUAL "GNU") AND WTF_CPU_ARM AND (CMAKE_CXX_COMPILER_VERSION VERSION_GREATER "4.9") AND (CMAKE_CXX_COMPILER_VERSION VERSION_LESS "4.9.3"))