summaryrefslogtreecommitdiffstats
path: root/Source/WebCore/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/WebCore/CMakeLists.txt')
-rw-r--r--Source/WebCore/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/Source/WebCore/CMakeLists.txt b/Source/WebCore/CMakeLists.txt
index e9fc4e54e..56b32563a 100644
--- a/Source/WebCore/CMakeLists.txt
+++ b/Source/WebCore/CMakeLists.txt
@@ -3354,8 +3354,13 @@ if (ENABLE_USER_MESSAGE_HANDLERS)
endif ()
if (USE_WOFF2)
- list(APPEND WebCore_INCLUDE_DIRECTORIES "${THIRDPARTY_DIR}/woff2/include")
- list(APPEND WebCore_LIBRARIES woff2)
+ if (WOFF2DEC_FOUND)
+ list(APPEND WebCore_INCLUDE_DIRECTORIES "${WOFF2DEC_INCLUDE_DIRS}")
+ list(APPEND WebCore_LIBRARIES "${WOFF2DEC_LIBRARIES}")
+ else ()
+ list(APPEND WebCore_INCLUDE_DIRECTORIES "${THIRDPARTY_DIR}/woff2/include")
+ list(APPEND WebCore_LIBRARIES woff2)
+ endif ()
endif ()
set(WebCoreTestSupport_INCLUDE_DIRECTORIES