summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2022-02-04 18:46:06 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2022-02-05 01:36:57 +0100
commit02149a40a4c5e2556cd48395f4461a08f007c6b9 (patch)
treec4e6771548b2952d1b9d300bdef32990da333e19 /examples/CMakeLists.txt
parent69525249e10fbbb49503b9b39cc01cf3c263eb60 (diff)
Switch examples to build as isolated sub-builds part 2
qt_examples_build_begin needs the EXTERNAL_BUILD flag to know that it's safe to build examples as ExternalProjects. It still won't do it in CI until we enable building examples as ExternalProjects for prefix builds. This is preparation for that. Pick-to: 6.2 6.3 Task-number: QTBUG-90820 Change-Id: I756b89a36542114cbf17ed2d16cd2df004f351f3 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 6d02dd0..5aa5adf 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,3 +1,3 @@
-qt_examples_build_begin()
+qt_examples_build_begin(EXTERNAL_BUILD)
add_subdirectory(webview)
qt_examples_build_end()