aboutsummaryrefslogtreecommitdiffstats
path: root/examples/winextras/iconextractor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/winextras/iconextractor/CMakeLists.txt')
-rw-r--r--examples/winextras/iconextractor/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/examples/winextras/iconextractor/CMakeLists.txt b/examples/winextras/iconextractor/CMakeLists.txt
new file mode 100644
index 0000000..e0fc195
--- /dev/null
+++ b/examples/winextras/iconextractor/CMakeLists.txt
@@ -0,0 +1,33 @@
+# Generated from iconextractor.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(iconextractor LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS WinExtras)
+
+add_executable(iconextractor
+ main.cpp
+)
+target_link_libraries(iconextractor PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::WinExtras
+ shell32
+ user32
+)
+
+install(TARGETS iconextractor
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)