summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJani Suonpera <jani.suonpera@qt.io>2021-05-21 10:42:06 +0300
committerJani Suonpera <jani.suonpera@qt.io>2021-05-25 08:43:09 +0000
commit180071873bfe9ba37d60a3106764daf194a2c391 (patch)
tree3c19bc21c1da3928b6b94cdb194706ccc6a9ce05
parent0715b8a005a9053940f0ddddd0a58e93b576df24 (diff)
Remove workaround patch
Workaround patch cannot compile with newer qtwebengine and chromium. Many changes have been done to Reneses and chromium drivers. Removed patch is not directly compatible. There is shown again issue QTBUG-68912, which should solve first. If issue with eglGetProcAddress is shown again then new workaround is required later. Task-number: QTBUG-93022 Change-Id: I2d30c32d2ec4f56d2e85e645e4b62f06a2f0634b Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-Workaround-missing-eglGetProcAddress.patch42
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bbappend32
2 files changed, 0 insertions, 74 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0001-Workaround-missing-eglGetProcAddress.patch b/recipes-qt/qt5/qtwebengine/0001-Workaround-missing-eglGetProcAddress.patch
deleted file mode 100644
index e33446e..0000000
--- a/recipes-qt/qt5/qtwebengine/0001-Workaround-missing-eglGetProcAddress.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From f99110bf64fa81d207771d96abfd850b168794fc Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Tue, 16 Oct 2018 13:43:43 +0300
-Subject: [PATCH] Workaround missing eglGetProcAddress
-
-Renesas boards are unable to find address for the eglGetProcAddress
-symbol at runtime, instead do it already at link time.
-
-Task-number: QTBUG-71152
-Change-Id: Ibc4251c0ab7e878a65d8c6e7b4da3952807cbc91
----
- src/core/core_module.pro | 2 ++
- src/core/ozone/gl_ozone_egl_qt.cpp | 3 +++
- 2 files changed, 5 insertions(+)
-
-diff --git a/src/core/core_module.pro b/src/core/core_module.pro
-index 520b452f..e3cef8a9 100644
---- a/src/core/core_module.pro
-+++ b/src/core/core_module.pro
-@@ -41,6 +41,8 @@ QMAKE_INFO_PLIST = Info_mac.plist
- # and doesn't let Chromium get access to libc symbols through dlsym.
- CONFIG -= bsymbolic_functions
-
-+qtConfig(egl): CONFIG += egl
-+
- linux {
- !ccache:!use_gold_linker:!use_lld_linker {
- QMAKE_LINK="ulimit -n 4096 && $$QMAKE_LINK"
-diff --git a/src/core/ozone/gl_ozone_egl_qt.cpp b/src/core/ozone/gl_ozone_egl_qt.cpp
-index 04b33699..d57c2be4 100644
---- a/src/core/ozone/gl_ozone_egl_qt.cpp
-+++ b/src/core/ozone/gl_ozone_egl_qt.cpp
-@@ -87,6 +87,9 @@ bool GLOzoneEGLQt::LoadGLES2Bindings(gl::GLImplementation /*implementation*/)
- }
- #endif
-
-+ if (!get_proc_address)
-+ get_proc_address = &eglGetProcAddress;
-+
- if (!get_proc_address) {
- LOG(ERROR) << "eglGetProcAddress not found.";
- base::UnloadNativeLibrary(eglgles2Library);
diff --git a/recipes-qt/qt5/qtwebengine_git.bbappend b/recipes-qt/qt5/qtwebengine_git.bbappend
deleted file mode 100644
index cc13b74..0000000
--- a/recipes-qt/qt5/qtwebengine_git.bbappend
+++ /dev/null
@@ -1,32 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2018 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://0001-Workaround-missing-eglGetProcAddress.patch"