summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAri Parkkila <ari.parkkila@qt.io>2022-06-27 12:58:56 +0300
committerAri Parkkila <ari.parkkila@qt.io>2022-06-30 08:37:34 +0000
commitc373c91c4e8a5b10a70c09739b49febbe8fe6d42 (patch)
treea4ac7762b8a41db43dfefa1a8ed55fb9fdca4d55
parent9b5cb977fd111fef648e950e6607c37b06616272 (diff)
Update to support kirkstone
Change-Id: I773df338b2e06e001a1e066d776a0d519d85359e Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--README2
-rw-r--r--conf/bblayers.conf.sample1
-rw-r--r--conf/distro/include/b2qt.inc20
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-graphics/gles-module/gles-user-module.bbappend2
5 files changed, 18 insertions, 9 deletions
diff --git a/README b/README
index 857a723..01eabcb 100644
--- a/README
+++ b/README
@@ -45,7 +45,7 @@ it from package manager (apt install repo) or download with:
After installing the repo tool, run following commands to initialize the build environment.
- repo init -u git://code.qt.io/yocto/boot2qt-manifest -b renesas -m zeus.xml
+ repo init -u git://code.qt.io/yocto/boot2qt-manifest -b renesas -m dev.xml
repo sync
export MACHINE=h3ulcb
diff --git a/conf/bblayers.conf.sample b/conf/bblayers.conf.sample
index 5979cb7..b0bd0b7 100644
--- a/conf/bblayers.conf.sample
+++ b/conf/bblayers.conf.sample
@@ -45,7 +45,6 @@ BBLAYERS ?= " \
${BSPDIR}/sources/meta-openembedded/meta-networking \
${BSPDIR}/sources/meta-openembedded/meta-initramfs \
${BSPDIR}/sources/meta-openembedded/meta-multimedia \
- ${BSPDIR}/sources/meta-python2 \
${BSPDIR}/sources/meta-boot2qt/meta-boot2qt \
${BSPDIR}/sources/meta-boot2qt/meta-boot2qt-distro \
${BSPDIR}/sources/meta-boot2qt-renesas \
diff --git a/conf/distro/include/b2qt.inc b/conf/distro/include/b2qt.inc
index 5b4f6e2..4376039 100644
--- a/conf/distro/include/b2qt.inc
+++ b/conf/distro/include/b2qt.inc
@@ -57,14 +57,11 @@ QBSP_IMAGE_CONTENT = "\
BOOT_SPACE = "32768"
-# uncomment following if using the evaluation drivers
-#DISTRO_FEATURES:append = " use_eva_pkg"
-
MACHINE_FEATURES:append = " gsx multimedia"
DISTRO_FEATURES:remove = "ld-is-gold"
-MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2 virtual/libgbm"
+BB_MULTI_PROVIDER_ALLOWED += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2 virtual/libgbm"
#DISTRO_FEATURES:append = " pam"
PREFERRED_PROVIDER_virtual/libgles1 = ""
@@ -77,9 +74,24 @@ PREFERRED_PROVIDER_libgbm-dev = "libgbm"
PREFERRED_PROVIDER_virtual/libgbm = "libgbm"
BBMASK += "mesa-gl"
+# remove vulkan to dismiss depends on mesa and its conflicts with gles-user-module
+DISTRO_FEATURES:remove = "vulkan"
+
# internal copy of R-Car_Series_Evaluation_Software_Packages used for CI
FILESEXTRAPATHS:append = "${BSPDIR}/sources/renesas-rcar3/${PN}:"
+# If need cogl, add layer meta-openembedded/meta-gnome
+# If need gstreamer, see meta-renesas/meta-rcar-gen3/docs/sample/conf/
BBMASK += "\
meta-rcar-gen3/recipes-core/packagegroups \
+ meta-rcar-gen3/recipes-graphics/cogl/cogl-1.0_1.%.bbappend \
+ meta-rcar-gen3/recipes-multimedia/gstreamer \
+ "
+
+# From meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston.inc,
+# in particular to get wayland-wsegl.so in the image
+IMAGE_INSTALL:append = " \
+ packagegroup-wayland-community \
+ packagegroup-graphics-renesas-proprietary \
+ packagegroup-graphics-renesas-wayland \
"
diff --git a/conf/layer.conf b/conf/layer.conf
index eca24d5..9a13b2d 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -39,5 +39,5 @@ BBFILE_COLLECTIONS += "b2qt_renesas"
BBFILE_PATTERN_b2qt_renesas := "^${LAYERDIR}/"
BBFILE_PRIORITY_b2qt_renesas = "20"
-LAYERSERIES_COMPAT_b2qt_renesas = "hardknott"
+LAYERSERIES_COMPAT_b2qt_renesas = "hardknott kirkstone"
diff --git a/recipes-graphics/gles-module/gles-user-module.bbappend b/recipes-graphics/gles-module/gles-user-module.bbappend
index c5fcd20..550b6e6 100644
--- a/recipes-graphics/gles-module/gles-user-module.bbappend
+++ b/recipes-graphics/gles-module/gles-user-module.bbappend
@@ -31,8 +31,6 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI:append = " file://gl3ext.h"
-DEPENDS = "mesa"
-
do_install:append() {
install -m 644 ${WORKDIR}/gl3ext.h ${D}/${includedir}/GLES3/
}