summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-09-12 11:08:07 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-09-13 12:06:06 +0000
commitf1a384dac21643ef1d25f30cbc7b36a76c6a33be (patch)
tree735eb23c1964c1047478007732a1c1f3cc91f235
parent3d864e39d4a5510c2b2e11cd1a494106d6ccc4f1 (diff)
Add support for using layer as boot2qt bsp layer
Add manifest.xml with needed meta layers for building Renesas boards againt meta-boot2qt, and README for how to use the layer. Combine the device specific config files from meta-boot2qt into a single include file. Change-Id: Id51723c21464239777a2cb471b87a3c51019fd5b Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--README53
-rw-r--r--conf/bblayers.conf.sample54
-rw-r--r--conf/distro/include/b2qt.inc89
-rw-r--r--conf/distro/include/salvator-x.pre.inc1
-rw-r--r--conf/manifest.xml35
5 files changed, 232 insertions, 0 deletions
diff --git a/README b/README
new file mode 100644
index 0000000..b376504
--- /dev/null
+++ b/README
@@ -0,0 +1,53 @@
+############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+Boot2Qt BSP layer for Renesas boards
+==========================================
+
+This layer provides additional configuration and recipe appends to support
+Boot2Qt on Renesas Boards.
+
+How to use this layer
+---------------------
+
+Using this layer requires Google's repo tool to be installed, you can install
+it from package manager (apt install repo) or download with:
+
+ curl https://storage.googleapis.com/git-repo-downloads/repo -o repo
+ chmod a+x repo
+
+
+After installing the repo tool, run following commands to initialize the build environment.
+
+ repo init -u git://code.qt.io/yocto/meta-boot2qt-renesas -m conf/manifest.xml -b <branch>
+ repo sync
+ ./b2qt-init-build-env init --group renesas --bsp meta-boot2qt-renesas
+
+ export MACHINE=h3ulcb
+ . ./setup-environment.sh --bsp meta-boot2qt-renesas
diff --git a/conf/bblayers.conf.sample b/conf/bblayers.conf.sample
new file mode 100644
index 0000000..0d235b1
--- /dev/null
+++ b/conf/bblayers.conf.sample
@@ -0,0 +1,54 @@
+############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+# POKY_BBLAYERS_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+POKY_BBLAYERS_CONF_VERSION = "2"
+
+BBPATH = "${TOPDIR}"
+BBFILES ?= ""
+BSPDIR := "${@os.path.abspath(os.path.dirname(d.getVar('FILE')) + '/../..')}"
+
+BBLAYERS ?= " \
+ ${BSPDIR}/sources/poky/meta \
+ ${BSPDIR}/sources/poky/meta-poky \
+ ${BSPDIR}/sources/meta-renesas/meta-rcar-gen3 \
+ ${BSPDIR}/sources/meta-linaro/meta-optee \
+ ${BSPDIR}/sources/meta-openembedded/meta-oe \
+ ${BSPDIR}/sources/meta-openembedded/meta-python \
+ ${BSPDIR}/sources/meta-openembedded/meta-networking \
+ ${BSPDIR}/sources/meta-openembedded/meta-initramfs \
+ ${BSPDIR}/sources/meta-openembedded/meta-multimedia \
+ ${BSPDIR}/sources/meta-boot2qt/meta-boot2qt \
+ ${BSPDIR}/sources/meta-boot2qt/meta-boot2qt-distro \
+ ${BSPDIR}/sources/meta-boot2qt-renesas \
+ ${BSPDIR}/sources/meta-mingw \
+ ${BSPDIR}/sources/meta-qt5 \
+ "
+
diff --git a/conf/distro/include/b2qt.inc b/conf/distro/include/b2qt.inc
new file mode 100644
index 0000000..d94f389
--- /dev/null
+++ b/conf/distro/include/b2qt.inc
@@ -0,0 +1,89 @@
+############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+DEPLOY_CONF_NAME_ebisu = "Renesas R-Car-E3 Ebisu 4D"
+DEPLOY_CONF_NAME_m3ulcb = "Renesas R-Car-M3 Starter Kit Pro"
+DEPLOY_CONF_NAME_h3ulcb = "Renesas R-Car-H3 Starter Kit Premier"
+DEPLOY_CONF_NAME_salvator-x = "Renesas R-Car H3 M3 Salvator-X(S)"
+
+IMAGE_FSTYPES += "wic"
+WKS_FILE = "sdimage-bootpart.wks"
+WIC_CREATE_EXTRA_ARGS = "--no-fstab-update"
+WKS_FILE_DEPENDS += "u-boot optee-os"
+
+IMAGE_BOOT_FILES = "\
+ Image \
+ r*.dtb \
+ "
+
+QBSP_IMAGE_CONTENT = "\
+ ${IMAGE_LINK_NAME}.img \
+ ${IMAGE_LINK_NAME}.conf \
+ bl2-${MACHINE}.srec \
+ bl31-${MACHINE}.srec \
+ tee-${MACHINE}.srec \
+ bootparam_sa0.srec \
+ cert_header_sa6.srec \
+ u-boot-elf-${MACHINE}.srec \
+ "
+
+BOOT_SPACE = "32768"
+
+# uncomment following if using the evaluation drivers
+#DISTRO_FEATURES_append = " use_eva_pkg"
+
+MACHINE_FEATURES_append = " gsx multimedia"
+
+MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2 virtual/libgbm"
+
+#DISTRO_FEATURES_append = " pam"
+PREFERRED_PROVIDER_virtual/libgles1 = ""
+PREFERRED_PROVIDER_virtual/libgles2 = "gles-user-module"
+PREFERRED_PROVIDER_virtual/egl = "libegl"
+PREFERRED_PROVIDER_virtual/libgl = ""
+PREFERRED_PROVIDER_virtual/mesa = ""
+PREFERRED_PROVIDER_libgbm = "libgbm"
+PREFERRED_PROVIDER_libgbm-dev = "libgbm"
+PREFERRED_PROVIDER_virtual/libgbm = "libgbm"
+BBMASK += "mesa-gl"
+
+# internal copy of R-Car_Series_Evaluation_Software_Packages used for CI
+FILESEXTRAPATHS_append = "${BSPDIR}/sources/renesas-rcar3/${PN}:"
+
+BBMASK += "\
+ meta-linaro/meta-optee/recipes-security/optee \
+ meta-rcar-gen3/recipes-core/packagegroups \
+ meta-rcar-gen3/recipes-devtools/perl \
+ meta-rcar-gen3/recipes-graphics/wayland/weston \
+ meta-rcar-gen3/recipes-graphics/xorg-xserver \
+ meta-rcar-gen3/recipes-multimedia/alsa \
+ meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.12.4.bbappend \
+ meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.12.4.bbappend \
+ meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.12.4.bbappend \
+ "
diff --git a/conf/distro/include/salvator-x.pre.inc b/conf/distro/include/salvator-x.pre.inc
new file mode 100644
index 0000000..e87933c
--- /dev/null
+++ b/conf/distro/include/salvator-x.pre.inc
@@ -0,0 +1 @@
+SOC_FAMILY ?= "r8a7795"
diff --git a/conf/manifest.xml b/conf/manifest.xml
new file mode 100644
index 0000000..96f0485
--- /dev/null
+++ b/conf/manifest.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<manifest>
+ <remote fetch="git://code.qt.io/yocto" name="qt"/>
+ <remote fetch="ssh://codereview.qt-project.org/yocto" name="gerrit"/>
+ <remote fetch="ssh://git@git.qt.io/boot2qt" name="playground"/>
+ <remote fetch="git://github.com/renesas-rcar" name="renesas"/>
+ <remote fetch="git://git.linaro.org/openembedded" name="linaro"/>
+
+ <project name="meta-boot2qt"
+ remote="qt"
+ revision="warrior"
+ path="sources/meta-boot2qt">
+ <!-- link init script to the build dir -->
+ <linkfile dest="b2qt-init-build-env" src="b2qt-init-build-env"/>
+ <!-- add boot2qt's manifest file as a local manifest -->
+ <linkfile dest=".repo/local_manifests/boot2qt.xml" src="scripts/manifest.xml"/>
+ </project>
+
+ <!-- add device specific layers -->
+ <project name="meta-renesas"
+ remote="renesas"
+ revision="1b33df50c1f0c3848deb65b636d5134ed0d0d328"
+ path="sources/meta-renesas"/>
+ <project name="meta-linaro"
+ remote="linaro"
+ revision="853e8e05e55e1bce7cef94ad7515e37e9485f745"
+ path="sources/meta-linaro"/>
+
+ <!-- internal layer for the proprietary device drivers -->
+ <project name="renesas-rcar3"
+ remote="playground"
+ revision="abc38c02585edd300e842f4e649a9f491e40187a"
+ path="sources/renesas-rcar3"
+ groups="notdefault,internal"/>
+</manifest>