summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Bu <alex.bu@qt.io>2023-10-24 13:27:05 +0300
committerAlex Bu <alex.bu@qt.io>2023-10-30 10:50:31 +0300
commitf783e1f5d69e248f89bb26a7eabca7ed265ffb6f (patch)
tree44a87a35249a8167806d2c91d46e98a6375d0472
parent163bd92b1adfe99a5aaf3b5ef4c1c12a7a52f2c8 (diff)
Add support for RCar M3N with salvator-xs carrier board
Merge h3ulcb and salvator-x together in u-boot config. Set the default display output to HDMI. Enable USB3.0 function for salvator-x. Task-number: QTBUG-114461 Change-Id: I639f2937705353a5229874340fc96e15292910b0 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--conf/distro/include/b2qt.inc1
-rw-r--r--recipes-bsp/u-boot/u-boot/0001-Change-two-boards-to-boot-from-sd-card.patch (renamed from recipes-bsp/u-boot/u-boot/0001-Change-rcar3_ulcb-to-boot-from-sd-card.patch)34
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend4
-rw-r--r--recipes-qt/boot2qt-addons/default-qt-envs/kms.conf14
4 files changed, 46 insertions, 7 deletions
diff --git a/conf/distro/include/b2qt.inc b/conf/distro/include/b2qt.inc
index c278480..27de475 100644
--- a/conf/distro/include/b2qt.inc
+++ b/conf/distro/include/b2qt.inc
@@ -97,3 +97,4 @@ IMAGE_INSTALL:append = " \
packagegroup-graphics-renesas-proprietary \
packagegroup-graphics-renesas-wayland \
"
+MACHINE_FEATURES:append:salvator-x = " usb3"
diff --git a/recipes-bsp/u-boot/u-boot/0001-Change-rcar3_ulcb-to-boot-from-sd-card.patch b/recipes-bsp/u-boot/u-boot/0001-Change-two-boards-to-boot-from-sd-card.patch
index 0e9287a..3ded6a3 100644
--- a/recipes-bsp/u-boot/u-boot/0001-Change-rcar3_ulcb-to-boot-from-sd-card.patch
+++ b/recipes-bsp/u-boot/u-boot/0001-Change-two-boards-to-boot-from-sd-card.patch
@@ -1,13 +1,34 @@
-From da24b99fa161fc3736f8e62b6ec469c39a06f206 Mon Sep 17 00:00:00 2001
-From: Ari Parkkila <ari.parkkila@qt.io>
-Date: Mon, 6 Mar 2023 14:07:17 +0200
-Subject: [PATCH] Change rcar3_ulcb to boot from sd card
+From 5f865043597268145312016fc158ca665c565b0b Mon Sep 17 00:00:00 2001
+From: Alex Bu <alex.bu@qt.io>
+Date: Fri, 13 Oct 2023 13:33:28 +0300
+Subject: [PATCH] Change two boards to boot from sd card
+Change rcar3_ulcb to boot from sd card
+Change M3N salvator-xs board to boot from SDHI0
+
+Upstream-Status: Inappropriate (for two boards only)
---
+ configs/rcar3_salvator-x_defconfig | 4 ++--
configs/rcar3_ulcb_defconfig | 4 ++--
include/configs/rcar-gen3-common.h | 4 ++--
- 2 files changed, 4 insertions(+), 4 deletions(-)
+ 3 files changed, 6 insertions(+), 6 deletions(-)
+diff --git a/configs/rcar3_salvator-x_defconfig b/configs/rcar3_salvator-x_defconfig
+index fc6788adbb..9705fa7584 100644
+--- a/configs/rcar3_salvator-x_defconfig
++++ b/configs/rcar3_salvator-x_defconfig
+@@ -12,9 +12,9 @@ CONFIG_DEFAULT_DEVICE_TREE="r8a77951-salvator-x-u-boot"
+ CONFIG_SMBIOS_PRODUCT_NAME=""
+ CONFIG_FIT=y
+ CONFIG_USE_BOOTARGS=y
+-CONFIG_BOOTARGS="root=/dev/nfs rw nfsroot=192.168.0.1:/export/rfs ip=192.168.0.20"
++CONFIG_BOOTARGS="rw root=/dev/mmcblk1p2 rootwait"
+ CONFIG_SUPPORT_RAW_INITRD=y
+-CONFIG_DEFAULT_FDT_FILE="r8a77951-salvator-x.dtb"
++CONFIG_DEFAULT_FDT_FILE="r8a77965-salvator-xs.dtb"
+ CONFIG_VERSION_VARIABLE=y
+ CONFIG_HUSH_PARSER=y
+ CONFIG_CMD_BOOTZ=y
diff --git a/configs/rcar3_ulcb_defconfig b/configs/rcar3_ulcb_defconfig
index 97fae236dc..b4f996c5cf 100644
--- a/configs/rcar3_ulcb_defconfig
@@ -39,3 +60,6 @@ index 21b8f858cc..1634ecc89b 100644
"booti 0x48080000 - 0x48000000"
/* SPL support */
+--
+2.25.1
+
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
index 84d0af6..e7883b5 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -28,6 +28,6 @@
############################################################################
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI:append:h3ulcb = "\
- file://0001-Change-rcar3_ulcb-to-boot-from-sd-card.patch \
+SRC_URI:append = "\
+ file://0001-Change-two-boards-to-boot-from-sd-card.patch \
"
diff --git a/recipes-qt/boot2qt-addons/default-qt-envs/kms.conf b/recipes-qt/boot2qt-addons/default-qt-envs/kms.conf
index db7a503..cd1bab3 100644
--- a/recipes-qt/boot2qt-addons/default-qt-envs/kms.conf
+++ b/recipes-qt/boot2qt-addons/default-qt-envs/kms.conf
@@ -1,4 +1,18 @@
{
"device": "/dev/dri/card0",
+ "outputs": [
+ {
+ "name": "VGA1",
+ "mode": "off"
+ },
+ {
+ "name": "LVDS1",
+ "mode": "off"
+ },
+ {
+ "name": "HDMI1",
+ "mode": "on"
+ }
+ ],
"hwcursor": false
}