summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/bblayers.conf.sample1
-rw-r--r--conf/distro/include/b2qt.inc5
-rw-r--r--conf/layer.conf2
-rw-r--r--conf/manifest.xml8
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend30
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.%.bbappend38
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend27
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.%.bbappend32
8 files changed, 101 insertions, 42 deletions
diff --git a/conf/bblayers.conf.sample b/conf/bblayers.conf.sample
index 0d235b1..7832a45 100644
--- a/conf/bblayers.conf.sample
+++ b/conf/bblayers.conf.sample
@@ -39,7 +39,6 @@ BBLAYERS ?= " \
${BSPDIR}/sources/poky/meta \
${BSPDIR}/sources/poky/meta-poky \
${BSPDIR}/sources/meta-renesas/meta-rcar-gen3 \
- ${BSPDIR}/sources/meta-linaro/meta-optee \
${BSPDIR}/sources/meta-openembedded/meta-oe \
${BSPDIR}/sources/meta-openembedded/meta-python \
${BSPDIR}/sources/meta-openembedded/meta-networking \
diff --git a/conf/distro/include/b2qt.inc b/conf/distro/include/b2qt.inc
index 9e103b7..92f80ba 100644
--- a/conf/distro/include/b2qt.inc
+++ b/conf/distro/include/b2qt.inc
@@ -77,7 +77,8 @@ BBMASK += "mesa-gl"
FILESEXTRAPATHS_append = "${BSPDIR}/sources/renesas-rcar3/${PN}:"
BBMASK += "\
- meta-linaro/meta-optee/recipes-security/optee \
meta-rcar-gen3/recipes-core/packagegroups \
- meta-rcar-gen3/recipes-graphics/wayland/weston \
+ meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.0.bbappend \
+ meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.0.bbappend \
+ meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.0.bbappend \
"
diff --git a/conf/layer.conf b/conf/layer.conf
index b96c01b..89bd415 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -41,5 +41,3 @@ BBFILE_PRIORITY_b2qt_renesas = "20"
LAYERSERIES_COMPAT_b2qt_renesas = "zeus"
-# override meta-renesas layer COMPATs
-LAYERSERIES_COMPAT_rcar-gen3 = "zeus"
diff --git a/conf/manifest.xml b/conf/manifest.xml
index 27e9354..1ddca91 100644
--- a/conf/manifest.xml
+++ b/conf/manifest.xml
@@ -21,14 +21,8 @@
fetch="git://github.com/renesas-rcar"/>
<project name="meta-renesas"
remote="renesas"
- revision="e1a44724144e599f538b2573949ac08ad68e9d6f"
+ revision="9a58b78a5c2960332b6ed4b02a6d8d5c606fa3e5"
path="sources/meta-renesas"/>
- <remote name="linaro"
- fetch="git://git.linaro.org/openembedded"/>
- <project name="meta-linaro"
- remote="linaro"
- revision="674ce19e685233994052c8f6e4c133377076ea40"
- path="sources/meta-linaro"/>
<!-- internal layer for the proprietary device drivers -->
<remote name="playground"
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
deleted file mode 100644
index 0e3a2a5..0000000
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ /dev/null
@@ -1,30 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2019 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-EXTRA_OEMESON += "-Dsimple-dmabuf-drm=auto"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.%.bbappend
new file mode 100644
index 0000000..ab87897
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.%.bbappend
@@ -0,0 +1,38 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
+
+SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz"
+SRC_URI_append = " \
+ git://github.com/renesas-rcar/gst-omx.git;branch=RCAR-GEN3/1.16.0 \
+ file://gstomx.conf \
+"
+
+require include/rcar-gen3-path-common.inc
+
+DEPENDS += "omx-user-module mmngrbuf-user-module"
+
+SRCREV = "e9a197cdb078f36d37fcb8ada868d5352ade2f77"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
+ file://omx/gstomx.h;beginline=1;endline=22;md5=e2c6664eda77dc22095adbed9cb6c6e4 \
+"
+
+S = "${WORKDIR}/git"
+
+GSTREAMER_1_0_OMX_TARGET = "rcar"
+GSTREAMER_1_0_OMX_CORE_NAME = "${libdir}/libomxr_core.so"
+EXTRA_OECONF_append = " --enable-experimental"
+
+do_configure_prepend() {
+ export http_proxy=${http_proxy}
+ export https_proxy=${https_proxy}
+ export HTTP_PROXY=${HTTP_PROXY}
+ export HTTPS_PROXY=${HTTPS_PROXY}
+ cd ${S}
+ install -m 0644 ${WORKDIR}/gstomx.conf ${S}/config/rcar/
+ sed -i 's,@RENESAS_DATADIR@,${RENESAS_DATADIR},g' ${S}/config/rcar/gstomx.conf
+ ./autogen.sh --noconfigure
+ cd ${B}
+}
+
+RDEPENDS_${PN}_append = " omx-user-module"
+RDEPENDS_${PN}_remove = "libomxil"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend
new file mode 100644
index 0000000..1b42fd1
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend
@@ -0,0 +1,27 @@
+SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-${PV}.tar.xz"
+SRC_URI_append = " git://github.com/renesas-rcar/gst-plugins-bad.git;branch=RCAR-GEN3/1.16.0"
+
+SRCREV = "7f334f733534a3a64d848df110da12af9650eaed"
+
+DEPENDS += "weston"
+
+S = "${WORKDIR}/git"
+
+# submodule is extracted before do_populate_lic
+addtask do_init_submodule after do_unpack before do_patch
+
+do_init_submodule() {
+ export http_proxy=${http_proxy}
+ export https_proxy=${https_proxy}
+ export HTTP_PROXY=${HTTP_PROXY}
+ export HTTPS_PROXY=${HTTPS_PROXY}
+ cd ${S}
+ git submodule init
+ git submodule update
+}
+
+do_configure_prepend() {
+ cd ${S}
+ ./autogen.sh --noconfigure
+ cd ${B}
+}
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.%.bbappend
new file mode 100644
index 0000000..402afa5
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.%.bbappend
@@ -0,0 +1,32 @@
+SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz"
+SRC_URI_append = " git://github.com/renesas-rcar/gst-plugins-good.git;branch=RCAR-GEN3/1.16.0"
+
+SRCREV = "8e4b5c16a9197219b66e167dd03d0a8800a95ed4"
+
+DEPENDS += "mmngrbuf-user-module"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF_append = " \
+ --enable-cont-frame-capture \
+ --enable-ignore-fps-of-video-standard \
+"
+
+# submodule is extracted before do_populate_lic
+addtask do_init_submodule after do_unpack before do_patch
+
+do_init_submodule() {
+ export http_proxy=${http_proxy}
+ export https_proxy=${https_proxy}
+ export HTTP_PROXY=${HTTP_PROXY}
+ export HTTPS_PROXY=${HTTPS_PROXY}
+ cd ${S}
+ git submodule init
+ git submodule update
+}
+
+do_configure_prepend() {
+ cd ${S}
+ ./autogen.sh --noconfigure
+ cd ${B}
+}