summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf')
-rw-r--r--conf/bblayers.conf.sample1
-rw-r--r--conf/distro/include/b2qt.inc20
-rw-r--r--conf/layer.conf2
3 files changed, 17 insertions, 6 deletions
diff --git a/conf/bblayers.conf.sample b/conf/bblayers.conf.sample
index 5979cb7..b0bd0b7 100644
--- a/conf/bblayers.conf.sample
+++ b/conf/bblayers.conf.sample
@@ -45,7 +45,6 @@ BBLAYERS ?= " \
${BSPDIR}/sources/meta-openembedded/meta-networking \
${BSPDIR}/sources/meta-openembedded/meta-initramfs \
${BSPDIR}/sources/meta-openembedded/meta-multimedia \
- ${BSPDIR}/sources/meta-python2 \
${BSPDIR}/sources/meta-boot2qt/meta-boot2qt \
${BSPDIR}/sources/meta-boot2qt/meta-boot2qt-distro \
${BSPDIR}/sources/meta-boot2qt-renesas \
diff --git a/conf/distro/include/b2qt.inc b/conf/distro/include/b2qt.inc
index 5b4f6e2..4376039 100644
--- a/conf/distro/include/b2qt.inc
+++ b/conf/distro/include/b2qt.inc
@@ -57,14 +57,11 @@ QBSP_IMAGE_CONTENT = "\
BOOT_SPACE = "32768"
-# uncomment following if using the evaluation drivers
-#DISTRO_FEATURES:append = " use_eva_pkg"
-
MACHINE_FEATURES:append = " gsx multimedia"
DISTRO_FEATURES:remove = "ld-is-gold"
-MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2 virtual/libgbm"
+BB_MULTI_PROVIDER_ALLOWED += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2 virtual/libgbm"
#DISTRO_FEATURES:append = " pam"
PREFERRED_PROVIDER_virtual/libgles1 = ""
@@ -77,9 +74,24 @@ PREFERRED_PROVIDER_libgbm-dev = "libgbm"
PREFERRED_PROVIDER_virtual/libgbm = "libgbm"
BBMASK += "mesa-gl"
+# remove vulkan to dismiss depends on mesa and its conflicts with gles-user-module
+DISTRO_FEATURES:remove = "vulkan"
+
# internal copy of R-Car_Series_Evaluation_Software_Packages used for CI
FILESEXTRAPATHS:append = "${BSPDIR}/sources/renesas-rcar3/${PN}:"
+# If need cogl, add layer meta-openembedded/meta-gnome
+# If need gstreamer, see meta-renesas/meta-rcar-gen3/docs/sample/conf/
BBMASK += "\
meta-rcar-gen3/recipes-core/packagegroups \
+ meta-rcar-gen3/recipes-graphics/cogl/cogl-1.0_1.%.bbappend \
+ meta-rcar-gen3/recipes-multimedia/gstreamer \
+ "
+
+# From meta-renesas/meta-rcar-gen3/recipes-graphics/images/core-image-weston.inc,
+# in particular to get wayland-wsegl.so in the image
+IMAGE_INSTALL:append = " \
+ packagegroup-wayland-community \
+ packagegroup-graphics-renesas-proprietary \
+ packagegroup-graphics-renesas-wayland \
"
diff --git a/conf/layer.conf b/conf/layer.conf
index eca24d5..9a13b2d 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -39,5 +39,5 @@ BBFILE_COLLECTIONS += "b2qt_renesas"
BBFILE_PATTERN_b2qt_renesas := "^${LAYERDIR}/"
BBFILE_PRIORITY_b2qt_renesas = "20"
-LAYERSERIES_COMPAT_b2qt_renesas = "hardknott"
+LAYERSERIES_COMPAT_b2qt_renesas = "hardknott kirkstone"