summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2023-06-02 11:58:45 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2023-06-05 07:44:02 +0000
commit7dd5874f01aeeb1cc0d065b0e20f377a0dc7bc03 (patch)
tree144f1139cd899d7fc5ea3dcfb3cb4b528cfaceec
parent1335205804b2b94142e7ecfe4ebecac2b05742ce (diff)
mesa: add bbappends from meta-ti
meta-ti has bbappend for different mesa version than oe-core is using. Add copies without the version number and BBMASK the original ones. Change-Id: I73027255a1f2afa8fbd1bdffd47a88ab5ad09cfa Reviewed-by: Ari Parkkila <ari.parkkila@qt.io> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--conf/distro/include/b2qt.inc2
-rw-r--r--recipes-graphics/mesa/mesa-gl_%.bbappend1
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend1
3 files changed, 4 insertions, 0 deletions
diff --git a/conf/distro/include/b2qt.inc b/conf/distro/include/b2qt.inc
index 14171af..056efb6 100644
--- a/conf/distro/include/b2qt.inc
+++ b/conf/distro/include/b2qt.inc
@@ -49,3 +49,5 @@ PREFERRED_PROVIDER_virtual/libgbm_am62xx = "ti-img-rogue-umlibs"
EFI_PROVIDER:am62xx = ""
MACHINE_FEATURE:remove:am62xx = "efi"
WKS_FILE:am62xx = "sdimage-2part.wks"
+
+BBMASK += "meta-ti-bsp/recipes-graphics/mesa"
diff --git a/recipes-graphics/mesa/mesa-gl_%.bbappend b/recipes-graphics/mesa/mesa-gl_%.bbappend
new file mode 100644
index 0000000..ba0f8c8
--- /dev/null
+++ b/recipes-graphics/mesa/mesa-gl_%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains_any('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-img-rogue-driver ti-sgx-ddk-km', 'recipes-graphics/mesa/pvr-mesa.inc', '', d)}
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
new file mode 100644
index 0000000..ba0f8c8
--- /dev/null
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains_any('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-img-rogue-driver ti-sgx-ddk-km', 'recipes-graphics/mesa/pvr-mesa.inc', '', d)}