summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAri Parkkila <ari.parkkila@qt.io>2022-08-25 13:24:07 +0300
committerAri Parkkila <ari.parkkila@qt.io>2022-08-30 11:13:37 +0000
commitf43ee714823388a81d05b2d690b3842b0c55cf8b (patch)
treed977a147c0f62d8870d072a40d330c562d926ba1
parenta7ccff1eadb72ec5137445e3e6578497bec284ab (diff)
Add support for Kirkstone and Qt6
QBSP tested with Qt Creator 8 on AM62xx-evm: * Disbled EFI boot * Weston support not working yet Task-number: QTBUG-103918 Change-Id: I2a47e38388900f9eaa310660d7e5e247bde7c2c0 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--conf/bblayers.conf.sample15
-rw-r--r--conf/distro/include/b2qt.inc5
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bbappend11
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend2
-rw-r--r--recipes-qt/qt/qtbase_git.bbappend (renamed from recipes-qt/qt5/qtbase_git.bbappend)0
6 files changed, 31 insertions, 4 deletions
diff --git a/conf/bblayers.conf.sample b/conf/bblayers.conf.sample
index d742bbd..ffcc52c 100644
--- a/conf/bblayers.conf.sample
+++ b/conf/bblayers.conf.sample
@@ -43,13 +43,22 @@ BBLAYERS ?= " \
${BSPDIR}/sources/meta-openembedded/meta-networking \
${BSPDIR}/sources/meta-openembedded/meta-initramfs \
${BSPDIR}/sources/meta-openembedded/meta-multimedia \
- ${BSPDIR}/sources/meta-python2 \
${BSPDIR}/sources/meta-boot2qt/meta-boot2qt \
${BSPDIR}/sources/meta-boot2qt/meta-boot2qt-distro \
${BSPDIR}/sources/meta-boot2qt-ti \
${BSPDIR}/sources/meta-mingw \
- ${BSPDIR}/sources/meta-qt5 \
${BSPDIR}/sources/meta-arm/meta-arm-toolchain \
${BSPDIR}/sources/meta-arm/meta-arm \
- ${BSPDIR}/sources/meta-ti \
"
+
+METAPYTHON2 = "${BSPDIR}/sources/meta-python2"
+BBLAYERS += "${@d.getVar('METAPYTHON2') if os.path.exists(d.getVar('METAPYTHON2')) else ''}"
+
+METAQT5 = "${BSPDIR}/sources/meta-qt5"
+METAQT6 = "${BSPDIR}/sources/meta-qt6"
+BBLAYERS += "${@d.getVar('METAQT6') if os.path.exists(d.getVar('METAQT6')) else d.getVar('METAQT5')}"
+
+METATI = "${BSPDIR}/sources/meta-ti"
+METATIBSP = "${METATI}/meta-ti-bsp"
+METATIALL = "${METATIBSP} ${METATI}/meta-ti-extras"
+BBLAYERS += "${@d.getVar('METATIALL') if os.path.exists(d.getVar('METATIBSP')) else d.getVar('METATI')}"
diff --git a/conf/distro/include/b2qt.inc b/conf/distro/include/b2qt.inc
index 34e9436..23a8a53 100644
--- a/conf/distro/include/b2qt.inc
+++ b/conf/distro/include/b2qt.inc
@@ -44,3 +44,8 @@ PREFERRED_PROVIDER_virtual/libgles1_am62xx = "ti-img-rogue-umlibs"
PREFERRED_PROVIDER_virtual/libgles2_am62xx = "ti-img-rogue-umlibs"
PREFERRED_PROVIDER_virtual/libgbm_am62xx = "ti-img-rogue-umlibs"
PREFERRED_PROVIDER_virtual/gpudriver_am62xx = "ti-img-rogue-driver"
+
+# Disable EFI boot for now
+EFI_PROVIDER:am62xx = ""
+MACHINE_FEATURE:remove:am62xx = "efi"
+WKS_FILE:am62xx = "sdimage-2part.wks"
diff --git a/conf/layer.conf b/conf/layer.conf
index d8465e9..fd78d40 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -39,4 +39,4 @@ BBFILE_COLLECTIONS += "b2qt-ti"
BBFILE_PATTERN_b2qt-ti := "^${LAYERDIR}/"
BBFILE_PRIORITY_b2qt-ti = "20"
-LAYERSERIES_COMPAT_b2qt-ti = "dunfell"
+LAYERSERIES_COMPAT_b2qt-ti = "dunfell kirkstone"
diff --git a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bbappend b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bbappend
new file mode 100644
index 0000000..0fab175
--- /dev/null
+++ b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bbappend
@@ -0,0 +1,11 @@
+# Remove when ti-img-rogue-umlibs supports Yocto/Kirkstone
+TIIMGROGUELIBS = "${libdir}/libgbm.so ${libdir}/libglapi.so \
+ ${libdir}/libGLESv1_CM_PVR_MESA.so \
+ ${libdir}/libGLESv2_PVR_MESA.so \
+ ${libdir}/libglslcompiler.so \
+ ${libdir}/libpvr_dri_support.so \
+ ${libdir}/libPVRScopeServices.so \
+ ${libdir}/libsrv_um.so \
+ ${libdir}/libsutu_display.so \
+ ${libdir}/libusc.so"
+FILES:${PN}-plugins += "${@d.getVar('TIIMGROGUELIBS') if d.getVar('DISTRO_CODENAME') == 'kirkstone' else ''}"
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644
index 0000000..c396924
--- /dev/null
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -0,0 +1,2 @@
+# To remove 'dmabuf-feedback' due to gbm 21.1.1 dependency
+SIMPLECLIENTS = "damage,im,egl,shm,touch,dmabuf-v4l,dmabuf-egl"
diff --git a/recipes-qt/qt5/qtbase_git.bbappend b/recipes-qt/qt/qtbase_git.bbappend
index ea4b18c..ea4b18c 100644
--- a/recipes-qt/qt5/qtbase_git.bbappend
+++ b/recipes-qt/qt/qtbase_git.bbappend