summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorAri Parkkila <ari.parkkila@qt.io>2022-08-15 10:06:46 +0300
committerAri Parkkila <ari.parkkila@qt.io>2022-08-16 09:55:55 +0000
commita7ccff1eadb72ec5137445e3e6578497bec284ab (patch)
treed7c41172e8d8082ba4dba89536d07f1a843503dd /recipes-qt
parent7296e773a268d9433b3cdd5c63ba063f64befaa8 (diff)
Add support for am62xx-evm
Task-number: QTBUG-103918 Change-Id: I08d60bda37b592278cf76058cbfcfe72dc4ba536 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/boot2qt-addons/default-qt-envs.bbappend41
-rw-r--r--recipes-qt/boot2qt-addons/default-qt-envs/kms.conf5
-rw-r--r--recipes-qt/qt5/qtbase_git.bbappend30
3 files changed, 76 insertions, 0 deletions
diff --git a/recipes-qt/boot2qt-addons/default-qt-envs.bbappend b/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
new file mode 100644
index 0000000..05a7f15
--- /dev/null
+++ b/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
@@ -0,0 +1,41 @@
+############################################################################
+##
+## Copyright (C) 2022 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://kms.conf"
+
+do_configure:append() {
+ echo "QT_QPA_EGLFS_KMS_CONFIG=/etc/kms.conf" >> ${WORKDIR}/defaults
+ echo "QSG_RENDER_LOOP=basic" >> ${WORKDIR}/defaults
+}
+
+do_install:append() {
+ install -m 0644 ${WORKDIR}/kms.conf ${D}${sysconfdir}/
+}
diff --git a/recipes-qt/boot2qt-addons/default-qt-envs/kms.conf b/recipes-qt/boot2qt-addons/default-qt-envs/kms.conf
new file mode 100644
index 0000000..25b34be
--- /dev/null
+++ b/recipes-qt/boot2qt-addons/default-qt-envs/kms.conf
@@ -0,0 +1,5 @@
+{
+ "device": "/dev/dri/card0",
+ "hwcursor": false
+}
+
diff --git a/recipes-qt/qt5/qtbase_git.bbappend b/recipes-qt/qt5/qtbase_git.bbappend
new file mode 100644
index 0000000..ea4b18c
--- /dev/null
+++ b/recipes-qt/qt5/qtbase_git.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2022 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+PACKAGECONFIG += "gbm kms"