summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-toradex_5.%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-toradex_5.%.bbappend')
-rw-r--r--recipes-kernel/linux/linux-toradex_5.%.bbappend15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex_5.%.bbappend b/recipes-kernel/linux/linux-toradex_5.%.bbappend
new file mode 100644
index 0000000..603a11f
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex_5.%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
+
+RDEPENDS:${KERNEL_PACKAGE_NAME}-base = "${KERNEL_PACKAGE_NAME}-image ${KERNEL_PACKAGE_NAME}-devicetree"
+
+do_preconfigure:prepend () {
+ # FunctionFS for qdbd
+ echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
+
+ # disable all console messages from framebuffers
+ echo "CONFIG_FRAMEBUFFER_CONSOLE=n" >> ${WORKDIR}/defconfig
+
+ # Enable uprobe for profiling
+ echo "CONFIG_UPROBE_EVENT=y" >> ${WORKDIR}/defconfig
+ echo "CONFIG_FTRACE=y" >> ${WORKDIR}/defconfig
+}