aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-06-06 15:44:53 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-06-06 15:55:54 +0300
commit06234d14c1b6925f635e4c6642169d4b91472f28 (patch)
treeafcc514c755efb87af86bd892c37ea22788f8ba5
parente458b249b3dee4bd0d45addf66971e2bff1840ad (diff)
jetson: Use default KERNEL_ROOTSPEC for jetson boards
Upstream meta layer has support for specifying different partition to boot. This relies on environment variable that the default bootloader doesn't have, which meant that SD card boot would not work unless image is first flashes to the device. Revert back to the default value, so that sd card boots work again. Fixes: QTBUG-75091 Change-Id: I8c519d65bd6201246dc2ca1e4db663bc21f773b8 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-tegra-extras/recipes-kernel/linux/linux-tegra_%.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-tegra-extras/recipes-kernel/linux/linux-tegra_%.bbappend b/meta-tegra-extras/recipes-kernel/linux/linux-tegra_%.bbappend
index 14506228..4f12d960 100644
--- a/meta-tegra-extras/recipes-kernel/linux/linux-tegra_%.bbappend
+++ b/meta-tegra-extras/recipes-kernel/linux/linux-tegra_%.bbappend
@@ -31,3 +31,5 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "\
file://0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch \
"
+
+KERNEL_ROOTSPEC = "root=/dev/mmcblk\${devnum}p1 rw rootwait"