aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-05-19 09:51:02 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2022-05-24 13:32:42 +0000
commit1feed6eb2e41e613f59cc5bfa569cacaf1fe2752 (patch)
tree1851c7e888d5c121cd785f0ff1398e763618c275
parent33101b877c6c12a02f3239fa561cbedfc9c16cfb (diff)
qtvncserver: add support for libtomcrypt
Add recipe for libtomcrypt and build QtVNCServer with it. Task-number: QTBUG-102979 Change-Id: Ib2e832e5d991ab5d482429a1ea2f21d12355306a Reviewed-by: Pasi Petäjäjärvi <pasi.petajajarvi@qt.io>
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt6/qtvncserver_git.bbappend30
-rw-r--r--meta-boot2qt/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb21
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/qt6/qtvncserver_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt6/qtvncserver_git.bbappend
new file mode 100644
index 00000000..a483dbe9
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/qt6/qtvncserver_git.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2022 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+DEPENDS += "libtomcrypt"
diff --git a/meta-boot2qt/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb b/meta-boot2qt/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb
new file mode 100644
index 00000000..de98163f
--- /dev/null
+++ b/meta-boot2qt/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb
@@ -0,0 +1,21 @@
+SUMMARY = "LibTomCrypt is a fairly comprehensive, modular and portable cryptographic toolkit"
+HOMEPAGE = "https://www.libtom.net/LibTomCrypt"
+SECTION = "libs/crypt"
+LICENSE = "Unlicense"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=71baacc459522324ef3e2b9e052e8180"
+
+DEPENDS += "libtool-cross"
+
+SRC_URI = "git://github.com/libtom/libtomcrypt.git;protocol=https;branch=master"
+
+SRCREV = "7e7eb695d581782f04b24dc444cbfde86af59853"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake -f makefile.shared
+}
+
+do_install() {
+ oe_runmake -f makefile.shared 'PREFIX=${prefix}' 'DESTDIR=${D}' install
+}