aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-02-07 15:27:18 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2019-02-07 15:27:55 +0200
commit28748d7e7b4b113a43997aef9e20f8b3ee8b22da (patch)
tree8ef8d358ce295a962eb447c676923c482d8e322a
parentf32773e4c9e2ef685b335a18cf5bb0ebe8dbee87 (diff)
parente1f20329102f9f973744eea4750df390b9d4112a (diff)
Merge remote-tracking branch 'origin/sumo' into thud
* origin/sumo: e1f2032 meta-qt5: update layer b469160 gcc-cross-canadian: Do not create symlink to real-ld 7e819da Enable boot2qt launcher automatic demo mode fdefea4 Implement NFS mounting for Intel NUCs 526c468 meta-qt5: update layer be15ea8 meta-qt5: update layer a0e0bd8 meta-qt5: update layer 5e98190 Update GammaRay for 5.12.1 cbb12da meta-qt5: update layer Conflicts: meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-demos_git.bb meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-launcher_git.bb meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb scripts/manifest.xml Change-Id: If57bb34b7b8547933f6d39c7f588eb42c68a4cb7
-rw-r--r--meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend (renamed from meta-fsl-extras/recipes/qt5/qtbase_git.bbappend)10
-rw-r--r--meta-boot2qt/recipes-qt/automotive/gammaray_git.bb2
-rw-r--r--meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch57
-rw-r--r--meta-intel-extras/recipes/images/core-image-minimal-initramfs.bbappend10
-rw-r--r--meta-intel-extras/recipes/initrdscripts/initramfs-framework/network47
-rwxr-xr-xmeta-intel-extras/recipes/initrdscripts/initramfs-framework/rootfs79
-rw-r--r--meta-intel-extras/recipes/initrdscripts/initramfs-framework_1.0.bbappend17
7 files changed, 154 insertions, 68 deletions
diff --git a/meta-fsl-extras/recipes/qt5/qtbase_git.bbappend b/meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend
index 373e6140..66e79ec1 100644
--- a/meta-fsl-extras/recipes/qt5/qtbase_git.bbappend
+++ b/meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2018 The Qt Company Ltd.
+## Copyright (C) 2019 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -27,7 +27,7 @@
##
############################################################################
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI += " \
- file://0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch \
- "
+do_install_append () {
+ # remove real-ld symlink
+ rm ${D}${libexecdir}/gcc/${TARGET_SYS}/${BINV}/real-ld${EXEEXT}
+}
diff --git a/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb b/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
index 0a84a7c6..e92f00c5 100644
--- a/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/gammaray_git.bb
@@ -9,7 +9,7 @@ inherit cmake_qt5
SRC_URI = "git://github.com/KDAB/GammaRay;branch=${BRANCH}"
BRANCH = "5.12"
-SRCREV = "cd00ba76ea9399131d28e275432c7d101e634951"
+SRCREV = "6279cbaa86c2a66e15a5d1cc9df071912b44090c"
PV = "${BRANCH}+git${SRCPV}"
DEPENDS = "qtdeclarative qtlocation qtsvg qttools qtconnectivity qt3d qtivi qtscxml qtscxml-native \
diff --git a/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch b/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch
deleted file mode 100644
index dc56cfc5..00000000
--- a/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 40e76307c1ee1ebe4e0142d623071d0f768f2450 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Wed, 9 Jan 2019 13:01:01 +0000
-Subject: [PATCH] egl_viv: cast EGLNative types from vivante functions
-
-All vivante functions return void* even when the actual native type
-(EGLNativeDisplayType, EGLNativeWindowType, etc.) might be typedef'ed
-as something else, as they do when the CFLAGS from egl.pc are now used.
----
- .../deviceintegration/eglfs_viv/qeglfsvivintegration.cpp | 4 ++--
- .../deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp | 4 ++--
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp
-index 763a4a462b..2fc076ad0c 100644
---- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp
-+++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp
-@@ -65,7 +65,7 @@ void QEglFSVivIntegration::platformInit()
- VivanteInit();
- mNativeDisplay = fbGetDisplay();
- #else
-- mNativeDisplay = fbGetDisplayByIndex(framebufferIndex());
-+ mNativeDisplay = static_cast<EGLNativeDisplayType>(fbGetDisplayByIndex(framebufferIndex()));
- #endif
-
- fbGetDisplayGeometry(mNativeDisplay, &width, &height);
-@@ -88,7 +88,7 @@ EGLNativeWindowType QEglFSVivIntegration::createNativeWindow(QPlatformWindow *wi
- Q_UNUSED(window)
- Q_UNUSED(format)
-
-- EGLNativeWindowType eglWindow = fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height());
-+ EGLNativeWindowType eglWindow = static_cast<EGLNativeWindowType>(fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height()));
- return eglWindow;
- }
-
-diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp
-index 61e2f17766..3bdae239cd 100644
---- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp
-+++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp
-@@ -60,7 +60,7 @@ void QEglFSVivWaylandIntegration::platformInit()
- }
-
- mWaylandDisplay = wl_display_create();
-- mNativeDisplay = fbGetDisplay(mWaylandDisplay);
-+ mNativeDisplay = static_cast<EGLNativeDisplayType>(fbGetDisplay(mWaylandDisplay));
- fbGetDisplayGeometry(mNativeDisplay, &width, &height);
- mScreenSize.setHeight(height);
- mScreenSize.setWidth(width);
-@@ -81,7 +81,7 @@ EGLNativeWindowType QEglFSVivWaylandIntegration::createNativeWindow(QPlatformWin
- Q_UNUSED(window)
- Q_UNUSED(format)
-
-- EGLNativeWindowType eglWindow = fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height());
-+ EGLNativeWindowType eglWindow = static_cast<EGLNativeWindowType>(fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height()));
- return eglWindow;
- }
-
diff --git a/meta-intel-extras/recipes/images/core-image-minimal-initramfs.bbappend b/meta-intel-extras/recipes/images/core-image-minimal-initramfs.bbappend
index c1918ba2..fd7559ab 100644
--- a/meta-intel-extras/recipes/images/core-image-minimal-initramfs.bbappend
+++ b/meta-intel-extras/recipes/images/core-image-minimal-initramfs.bbappend
@@ -27,5 +27,11 @@
##
############################################################################
-INITRAMFS_SCRIPTS += "initramfs-module-rtsx-pci-sdmmc"
-PACKAGE_INSTALL += "kernel-module-rtsx-pci-sdmmc"
+INITRAMFS_SCRIPTS += "\
+ initramfs-module-rtsx-pci-sdmmc \
+ initramfs-module-r8169 \
+ "
+PACKAGE_INSTALL += "\
+ kernel-module-rtsx-pci-sdmmc \
+ kernel-module-r8169 \
+ "
diff --git a/meta-intel-extras/recipes/initrdscripts/initramfs-framework/network b/meta-intel-extras/recipes/initrdscripts/initramfs-framework/network
new file mode 100644
index 00000000..134a70a6
--- /dev/null
+++ b/meta-intel-extras/recipes/initrdscripts/initramfs-framework/network
@@ -0,0 +1,47 @@
+#!/bin/sh
+
+############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+network_enabled() {
+ return 0
+}
+
+network_run() {
+ if [ -n "$bootparam_ip" ]; then
+ load_kernel_module r8169
+ if [ "${bootparam_ip}" -ne "dhcp" ]; then
+ echo "WARN: DHCP only supported at this time."
+ fi
+ ip link set dev eth0 up
+ udhcpc
+ fi
+}
+
+
diff --git a/meta-intel-extras/recipes/initrdscripts/initramfs-framework/rootfs b/meta-intel-extras/recipes/initrdscripts/initramfs-framework/rootfs
new file mode 100755
index 00000000..c93c9c20
--- /dev/null
+++ b/meta-intel-extras/recipes/initrdscripts/initramfs-framework/rootfs
@@ -0,0 +1,79 @@
+#!/bin/sh
+# Copyright (C) 2011 O.S. Systems Software LTDA.
+# Licensed on MIT
+
+rootfs_enabled() {
+ return 0
+}
+
+rootfs_run() {
+ if [ -z "$ROOTFS_DIR" ]; then
+ return
+ fi
+ C=0
+ delay=${bootparam_rootdelay:-1}
+ timeout=${bootparam_roottimeout:-5}
+ while [ ! -d $ROOTFS_DIR/dev ]; do
+ if [ $(( $C * $delay )) -gt $timeout ]; then
+ fatal "root '$bootparam_root' doesn't exist or does not contain a /dev."
+ fi
+
+ if [ -n "$bootparam_root" ]; then
+ debug "No e2fs compatible filesystem has been mounted, mounting $bootparam_root..."
+
+ if [ "`echo ${bootparam_root} | cut -c1-5`" = "UUID=" ]; then
+ root_uuid=`echo $bootparam_root | cut -c6-`
+ bootparam_root="/dev/disk/by-uuid/$root_uuid"
+ fi
+
+ if [ "`echo ${bootparam_root} | cut -c1-9`" = "PARTUUID=" ]; then
+ root_uuid=`echo $bootparam_root | cut -c10-`
+ bootparam_root="/dev/disk/by-partuuid/$root_uuid"
+ fi
+
+ if [ "`echo ${bootparam_root} | cut -c1-6`" = "LABEL=" ]; then
+ root_label=`echo $bootparam_root | cut -c7-`
+ bootparam_root="/dev/disk/by-label/$root_label"
+ fi
+
+ if [ "${bootparam_root}" = "/dev/nfs" ]; then
+ bootparam_rootfstype="nfs"
+ bootparam_root=`echo $bootparam_nfsroot | cut -f1 -d","`
+ bootparam_nfsopts=`echo $bootparam_nfsroot | cut -f2- -d","`
+ fi
+
+ if [ -e "$bootparam_root" ] || [ "${bootparam_rootfstype}" = "nfs" ]; then
+ flags=""
+ if [ -n "$bootparam_ro" ] && ! echo "$bootparam_rootflags" | grep -w -q "ro"; then
+ if [ -n "$bootparam_rootflags" ]; then
+ bootparam_rootflags="$bootparam_rootflags,"
+ fi
+ bootparam_rootflags="${bootparam_rootflags}ro"
+ fi
+ if [ -n "$bootparam_nfsopts" ]; then
+ if [ -n "$bootparam_rootflags" ]; then
+ bootparam_rootflags="$bootparam_rootflags,"
+ fi
+ bootparam_rootflags="${bootparam_rootflags}${bootparam_nfsopts}"
+ fi
+ if [ -n "$bootparam_rootflags" ]; then
+ flags="$flags -o$bootparam_rootflags"
+ fi
+ if [ -n "$bootparam_rootfstype" ]; then
+ flags="$flags -t$bootparam_rootfstype"
+ fi
+ mount $flags $bootparam_root $ROOTFS_DIR
+ if [ -d $ROOTFS_DIR/dev ]; then
+ break
+ else
+ # It is unlikely to change, but keep trying anyway.
+ # Perhaps we pick a different device next time.
+ umount $ROOTFS_DIR
+ fi
+ fi
+ fi
+ debug "Sleeping for $delay second(s) to wait root to settle..."
+ sleep $delay
+ C=$(( $C + 1 ))
+ done
+}
diff --git a/meta-intel-extras/recipes/initrdscripts/initramfs-framework_1.0.bbappend b/meta-intel-extras/recipes/initrdscripts/initramfs-framework_1.0.bbappend
index cfd05cd3..2a8ac895 100644
--- a/meta-intel-extras/recipes/initrdscripts/initramfs-framework_1.0.bbappend
+++ b/meta-intel-extras/recipes/initrdscripts/initramfs-framework_1.0.bbappend
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2018 The Qt Company Ltd.
+## Copyright (C) 2019 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -29,14 +29,25 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://rtsx_pci_sdmmc"
+SRC_URI += "\
+ file://rtsx_pci_sdmmc \
+ file://network \
+ "
do_install_append() {
install -m 0755 ${WORKDIR}/rtsx_pci_sdmmc ${D}/init.d/20-rtsx_pci_sdmmc
+ install -m 0755 ${WORKDIR}/network ${D}/init.d/30-network
}
-PACKAGES += "initramfs-module-rtsx-pci-sdmmc"
+PACKAGES += "\
+ initramfs-module-rtsx-pci-sdmmc \
+ initramfs-module-r8169 \
+ "
SUMMARY_initramfs-module-rtsx-pci-sdmmc = "initramfs support for rtsx_pci_sdmmc"
RDEPENDS_initramfs-module-rtsx-pci-sdmmc = "${PN}-base"
FILES_initramfs-module-rtsx-pci-sdmmc = "/init.d/20-rtsx_pci_sdmmc"
+
+SUMMARY_initramfs-module-r8169 = "initramfs support for Realtek LAN driver"
+RDEPENDS_initramfs-module-r8169 = "${PN}-base"
+FILES_initramfs-module-r8169 = "/init.d/30-network"