aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Dimich <chris.dimich@boundarydevices.com>2019-06-03 12:24:15 -0700
committerSamuli Piippo <samuli.piippo@qt.io>2019-08-02 15:57:47 +0300
commit3152be3fed633326146f696c48f896944649181b (patch)
tree089b71022394ed693418a44a93a3ab7f53b45df5
parentc6e07ee06c10c39cfcd8bb5144e0a0d45f18fbbc (diff)
Add Boundary Devices Nitrogen8M and Nitrogen8M Mini boards
Change-Id: Iabca33b4814201885842bae60f903173e9e203f9 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rwxr-xr-xb2qt-init-build-env2
-rw-r--r--meta-boot2qt-distro/conf/distro/include/boundary.inc1
-rw-r--r--meta-boot2qt-distro/conf/distro/include/nitrogen8m.conf34
-rw-r--r--meta-boot2qt-distro/conf/distro/include/nitrogen8mm.conf33
-rw-r--r--meta-fsl-extras/recipes-bsp/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch38
-rw-r--r--meta-fsl-extras/recipes-bsp/u-boot/u-boot-boundary_%.bbappend1
-rw-r--r--meta-fsl-extras/recipes-kernel/linux/linux-boundary/0001-Add-support-for-koe-tx31d200vm0baa-display.patch10
-rw-r--r--scripts/manifest.xml6
-rwxr-xr-xscripts/setup-environment.sh2
9 files changed, 78 insertions, 49 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env
index bec9db92..a4b8dd32 100755
--- a/b2qt-init-build-env
+++ b/b2qt-init-build-env
@@ -124,7 +124,7 @@ get_groups() {
apalis-imx6|colibri-imx6|colibri-imx6ull|colibri-vf|colibri-imx7|colibri-imx7-emmc)
PROJECT_GROUPS="toradex"
;;
- nitrogen6x|nitrogen7)
+ nitrogen6x|nitrogen7|nitrogen8m|nitrogen8mm)
PROJECT_GROUPS="boundary"
;;
imx6qdlsabresd|imx7dsabresd|imx7s-warp)
diff --git a/meta-boot2qt-distro/conf/distro/include/boundary.inc b/meta-boot2qt-distro/conf/distro/include/boundary.inc
index 8dcf16ba..a36776f2 100644
--- a/meta-boot2qt-distro/conf/distro/include/boundary.inc
+++ b/meta-boot2qt-distro/conf/distro/include/boundary.inc
@@ -31,6 +31,7 @@ include conf/distro/include/fsl.inc
BBMASK += " \
meta-boundary/recipes-core/init-ifupdown \
+ meta-boundary/recipes-boundary/images \
"
MACHINE_EXTRA_INSTALL += "\
diff --git a/meta-boot2qt-distro/conf/distro/include/nitrogen8m.conf b/meta-boot2qt-distro/conf/distro/include/nitrogen8m.conf
new file mode 100644
index 00000000..0aea897a
--- /dev/null
+++ b/meta-boot2qt-distro/conf/distro/include/nitrogen8m.conf
@@ -0,0 +1,34 @@
+############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+include conf/distro/include/boundary.inc
+
+DEPLOY_CONF_NAME = "Boundary Devices i.MX8MQ"
+
+KERNEL_DEFCONFIG = "boundary_defconfig"
diff --git a/meta-boot2qt-distro/conf/distro/include/nitrogen8mm.conf b/meta-boot2qt-distro/conf/distro/include/nitrogen8mm.conf
new file mode 100644
index 00000000..5ba89bc0
--- /dev/null
+++ b/meta-boot2qt-distro/conf/distro/include/nitrogen8mm.conf
@@ -0,0 +1,33 @@
+############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+include conf/distro/include/boundary.inc
+
+DEPLOY_CONF_NAME = "Boundary Devices i.MX8MM"
+
diff --git a/meta-fsl-extras/recipes-bsp/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch b/meta-fsl-extras/recipes-bsp/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch
deleted file mode 100644
index 49af5e54..00000000
--- a/meta-fsl-extras/recipes-bsp/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From baed831959ba41b8d1cebfb5d960ddfa847ae915 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Tue, 25 Sep 2018 16:05:17 +0300
-Subject: [PATCH] Disable build for tools and use mkimage from sysroot
-
-fails when trying to compile with host gcc: unable to execute
-'x86_64-linux-gnu-gcc': No such file or directory
----
- Makefile | 2 +-
- scripts/Makefile.lib | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 7d5f801eea..d5d44c5def 100644
---- a/Makefile
-+++ b/Makefile
-@@ -730,7 +730,7 @@ libs-y += $(if $(BOARDDIR),board/$(BOARDDIR)/)
-
- libs-y := $(sort $(libs-y))
-
--u-boot-dirs := $(patsubst %/,%,$(filter %/, $(libs-y))) tools examples
-+u-boot-dirs := $(patsubst %/,%,$(filter %/, $(libs-y)))
-
- u-boot-alldirs := $(sort $(u-boot-dirs) $(patsubst %/,%,$(filter %/, $(libs-))))
-
-diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
-index f8c3fff1d1..f24ea9cc25 100644
---- a/scripts/Makefile.lib
-+++ b/scripts/Makefile.lib
-@@ -508,7 +508,7 @@ cmd_xzmisc = (cat $(filter-out FORCE,$^) | \
- # ---------------------------------------------------------------------------
- MKIMAGEOUTPUT ?= /dev/null
- quiet_cmd_mkimage = MKIMAGE $@
--cmd_mkimage = $(objtree)/tools/mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \
-+cmd_mkimage = mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \
- >$(MKIMAGEOUTPUT) $(if $(KBUILD_VERBOSE:0=), && cat $(MKIMAGEOUTPUT))
-
- # fdtgrep
diff --git a/meta-fsl-extras/recipes-bsp/u-boot/u-boot-boundary_%.bbappend b/meta-fsl-extras/recipes-bsp/u-boot/u-boot-boundary_%.bbappend
index 3b5235f9..b3894d56 100644
--- a/meta-fsl-extras/recipes-bsp/u-boot/u-boot-boundary_%.bbappend
+++ b/meta-fsl-extras/recipes-bsp/u-boot/u-boot-boundary_%.bbappend
@@ -31,7 +31,6 @@ FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
SRC_URI += " \
file://0001-Add-support-for-KOE-tx31d200vm0baa-display.patch \
file://0002-set-CMA-reserved-size-to-384MB.patch \
- file://0003-Disable-build-for-tools.patch \
"
DEPENDS += "u-boot-mkimage-native"
diff --git a/meta-fsl-extras/recipes-kernel/linux/linux-boundary/0001-Add-support-for-koe-tx31d200vm0baa-display.patch b/meta-fsl-extras/recipes-kernel/linux/linux-boundary/0001-Add-support-for-koe-tx31d200vm0baa-display.patch
index 7851ca43..05de5cf9 100644
--- a/meta-fsl-extras/recipes-kernel/linux/linux-boundary/0001-Add-support-for-koe-tx31d200vm0baa-display.patch
+++ b/meta-fsl-extras/recipes-kernel/linux/linux-boundary/0001-Add-support-for-koe-tx31d200vm0baa-display.patch
@@ -1,4 +1,4 @@
-From c1099dfa376de7bf16763dee364698078f015848 Mon Sep 17 00:00:00 2001
+From d1f999566c5f346104d78568b51e96dec42b60c7 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@theqtcompany.com>
Date: Wed, 27 Jan 2016 13:07:39 +0200
Subject: [PATCH] Add support for koe tx31d200vm0baa display
@@ -8,18 +8,18 @@ Subject: [PATCH] Add support for koe tx31d200vm0baa display
1 file changed, 12 insertions(+)
diff --git a/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi b/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi
-index efbe51d..3704e14 100644
+index 7b4c3d9bb8e6..9be478d89745 100644
--- a/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi
+++ b/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi
-@@ -498,6 +498,7 @@
+@@ -493,6 +493,7 @@
pwm_lvds = &pwm4;
rtc1 = &snvs_rtc;
t_lvds = &t_lvds;
+ koe = &koe;
};
- backlight_lcd: backlight_lcd {
-@@ -1075,6 +1076,17 @@
+ backlight_lcd: backlight-lcd {
+@@ -1058,6 +1059,17 @@
hsync-len = <32>;
vsync-len = <6>;
};
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 2d56ff4b..f3799658 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -36,12 +36,12 @@
<project name="meta-freescale"
remote="freescale"
- revision="9d1463c9af81edadf8c5a343a030555b6156f8cf"
+ revision="b73854c078b0a174613135b60da3377a1055f477"
path="sources/meta-freescale"
groups="notdefault,external,fsl,toradex,smx6,boundary,fsl-imx8,toradex-imx8"/>
<project name="meta-freescale-3rdparty"
remote="freescale"
- revision="47848bff9478999019947f69a719b3d2c2a6b558"
+ revision="c4b5ac6b20e4245ce0630e9197313aaef999a331"
path="sources/meta-freescale-3rdparty"
groups="notdefault,external,fsl,toradex,smx6,boundary,fsl-imx8,toradex-imx8"/>
<project name="meta-raspberrypi"
@@ -86,7 +86,7 @@
groups="notdefault,external,toradex"/>
<project name="meta-boundary"
remote="boundary"
- revision="0533dbf42abee6e07be572eacc3d965772aad7a4"
+ revision="d1a51cff1d295f60aa84be99adafb6fbab26e6d6"
path="sources/meta-boundary"
groups="notdefault,external,boundary"/>
<project name="meta-fsl-bsp-release"
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh
index c4f6a3d7..4b54146c 100755
--- a/scripts/setup-environment.sh
+++ b/scripts/setup-environment.sh
@@ -65,7 +65,7 @@ if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then
apalis-imx6|colibri-imx6|colibri-imx6ull|colibri-vf|colibri-imx7|colibri-imx7-emmc)
LAYERSCONF="bblayers.conf.toradex.sample"
;;
- nitrogen6x|nitrogen7)
+ nitrogen6x|nitrogen7|nitrogen8m|nitrogen8mm)
LAYERSCONF="bblayers.conf.boundary.sample"
;;
imx6qdlsabresd|imx7dsabresd|imx7s-warp)