aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAssam Boudjelthia <assam.boudjelthia@qt.io>2019-10-01 13:31:07 +0300
committerAssam Boudjelthia <assam.boudjelthia@qt.io>2019-10-04 09:28:58 +0300
commit528accf3a22b869acc20b62a27ab8c8ea680988b (patch)
treec71a15342f73064af980ee5b614524291a83c833
parent258855105491b51e57cd1273710972c251fab7e0 (diff)
Drop wpa_supplicant related configs
This changed is done because wpa_supplicant is being dropped from qtdeviceutilities. Fixes: QTBUG-78442 Change-Id: I99505e9931468a0cb8cd3e0b33eda1d88bd70b5d Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.%.bbappend47
-rw-r--r--meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb3
2 files changed, 1 insertions, 49 deletions
diff --git a/meta-boot2qt-distro/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.%.bbappend b/meta-boot2qt-distro/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.%.bbappend
deleted file mode 100644
index e8808977..00000000
--- a/meta-boot2qt-distro/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.%.bbappend
+++ /dev/null
@@ -1,47 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2016 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-do_install_append () {
- install -d ${D}${includedir}/wpa-supplicant
-
- install -m 0644 ${S}/src/common/wpa_ctrl.c ${D}${includedir}/wpa-supplicant/
- install -m 0644 ${S}/src/common/wpa_ctrl.h ${D}${includedir}/wpa-supplicant/
-
- install -m 0644 ${S}/src/utils/build_config.h ${D}${includedir}/wpa-supplicant/
- install -m 0644 ${S}/src/utils/common.h ${D}${includedir}/wpa-supplicant/
- install -m 0644 ${S}/src/utils/includes.h ${D}${includedir}/wpa-supplicant/
- install -m 0644 ${S}/src/utils/os.h ${D}${includedir}/wpa-supplicant/
- install -m 0644 ${S}/src/utils/os_unix.c ${D}${includedir}/wpa-supplicant/
- install -m 0644 ${S}/src/utils/trace.h ${D}${includedir}/wpa-supplicant/
- install -m 0644 ${S}/src/utils/wpa_debug.h ${D}${includedir}/wpa-supplicant/
- install -m 0644 ${S}/src/utils/wpabuf.h ${D}${includedir}/wpa-supplicant/
-}
-
-FILES_${PN}-dev += "${includedir}/wpa-supplicant/*"
-
diff --git a/meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb b/meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb
index aa12b27d..76b31267 100644
--- a/meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb
+++ b/meta-boot2qt/recipes-qt/qt5/qtdeviceutilities_git.bb
@@ -35,11 +35,10 @@ inherit qt5-module
require recipes-qt/qt5/qt5-git.inc
PACKAGECONFIG ??= ""
-PACKAGECONFIG[wpasupplicant] = "CONFIG+=wpasupplicant,,wpa-supplicant"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "51cd8493b5d3d7d4e74d3733df6d8ad12f1866fe"
+SRCREV = "330b6f000ea0e2120a14e43a11dd1d0b68d369a3"
DEPENDS = "\
qtbase qtdeclarative qtconnectivity qtdeclarative-native \