aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2015-06-04 12:19:57 +0300
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-06-08 12:28:14 +0300
commit583341f6ea2439f58ffcbf4e06070aeb9472ec08 (patch)
tree8872290b2a6f6dd4c63376e54dec20dcb0fcb93d
parent6169682e3706a203538ce7d6d781d87a40b05dfb (diff)
Get rid of some of the host tools in toolchain
pkg-config got installed to toolchain, which made qtwebengine build fail, as it tries to use it for host libs. perl and bison are not working correctly from toolchain, they have problems with sdk relocation. Change-Id: I7755f4599ad7c87b60d5bfc66e0a2cf13fec9330 Reviewed-by: Eirik Aavitsland <eirik.aavitsland@theqtcompany.com>
-rw-r--r--recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb2
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb3
2 files changed, 1 insertions, 4 deletions
diff --git a/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb b/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb
index 0c0214f1..3f13aef5 100644
--- a/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb
+++ b/recipes/meta/meta-toolchain-b2qt-embedded-sdk.bb
@@ -26,7 +26,7 @@ LICENSE = "CLOSED"
inherit populate_sdk
-TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-toolchain-host"
+TOOLCHAIN_HOST_TASK = "nativesdk-packagegroup-b2qt-embedded-toolchain-host packagegroup-cross-canadian-${MACHINE}"
TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-toolchain-target"
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
index 971cc016..f64c0ac5 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
@@ -27,11 +27,8 @@ LICENSE = "CLOSED"
inherit nativesdk packagegroup
RDEPENDS_${PN} = "\
- nativesdk-packagegroup-sdk-host \
nativesdk-python-modules \
nativesdk-python-misc \
- nativesdk-perl-modules \
- nativesdk-bison \
nativesdk-gperf \
${@base_contains("DISTRO_FEATURES", "wayland", "nativesdk-wayland", "", d)} \
${MACHINE_EXTRA_INSTALL_SDK_HOST} \