aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2020-03-25 16:46:58 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2020-03-26 15:37:29 +0200
commit58fc5895a076c6d23cb17b64a81f27f2b47de907 (patch)
tree85e3015ffcf838eadfb6853820c31cc19e458c58
parent4e465caecb4b0adf39e22a6733846ca2ad446cd0 (diff)
boundary: cleanup BoundaryDevice recipes
Remove old unneeded items from boundary recipes. Change-Id: I32741f1f063fc0e4078f0c757dcdac077e94af5d Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/conf/distro/include/boundary.inc4
-rw-r--r--meta-boot2qt-distro/conf/distro/include/nitrogen8mm.conf3
-rw-r--r--meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch91
-rw-r--r--meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-boundary_%.bbappend3
-rw-r--r--meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch26
-rw-r--r--meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-script-boundary_%.bbappend33
-rw-r--r--meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-core/packagegroups/packagegroup-base.bbappend31
-rw-r--r--meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_%.bbappend30
-rw-r--r--meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-kernel/linux/linux-boundary/0001-Add-support-for-koe-tx31d200vm0baa-display.patch39
-rw-r--r--meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-kernel/linux/linux-boundary_4.%.bbappend9
10 files changed, 1 insertions, 268 deletions
diff --git a/meta-boot2qt-distro/conf/distro/include/boundary.inc b/meta-boot2qt-distro/conf/distro/include/boundary.inc
index 397d3840..c7d5830a 100644
--- a/meta-boot2qt-distro/conf/distro/include/boundary.inc
+++ b/meta-boot2qt-distro/conf/distro/include/boundary.inc
@@ -30,12 +30,8 @@
include conf/distro/include/fsl.inc
BBMASK += " \
- meta-boundary/recipes-core/init-ifupdown \
meta-boundary/recipes-boundary/images \
- meta-boundary/recipes-graphics/wayland \
- meta-boundary/recipes-graphics/xorg-xserver \
meta-boundary/recipes-graphics/mesa/mesa_%.bbappend \
- meta-boundary/recipes-kernel/linux-firmware/linux-firmware_git.bbappend \
"
MACHINE_EXTRA_INSTALL += "\
diff --git a/meta-boot2qt-distro/conf/distro/include/nitrogen8mm.conf b/meta-boot2qt-distro/conf/distro/include/nitrogen8mm.conf
index b72fb76b..c5f81368 100644
--- a/meta-boot2qt-distro/conf/distro/include/nitrogen8mm.conf
+++ b/meta-boot2qt-distro/conf/distro/include/nitrogen8mm.conf
@@ -30,6 +30,3 @@
include conf/distro/include/boundary.inc
DEPLOY_CONF_NAME = "Boundary Devices i.MX8MM"
-
-# cortexa53-crypto from meta-freescale is not compatible with oe-core/warrior
-DEFAULTTUNE_mx8mm = "aarch64"
diff --git a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch b/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
deleted file mode 100644
index 4118bad7..00000000
--- a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From be9c74e711876d6c4d830e98bf083ddda7eaecc2 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@theqtcompany.com>
-Date: Thu, 11 Feb 2016 10:17:51 +0200
-Subject: [PATCH] Add support for KOE tx31d200vm0baa display
-
-Used for the cluster demo
----
- arch/arm/include/asm/mach-imx/fbpanel.h | 27 ++++++++++++++++++++
- board/boundary/nitrogen6_max/nitrogen6_max.c | 3 ++-
- board/boundary/nitrogen6sx/nitrogen6sx.c | 3 ++-
- board/boundary/nitrogen6x/nitrogen6x.c | 1 +
- 4 files changed, 32 insertions(+), 2 deletions(-)
-
-diff --git a/arch/arm/include/asm/mach-imx/fbpanel.h b/arch/arm/include/asm/mach-imx/fbpanel.h
-index 9f7714831f..9d1b43df07 100644
---- a/arch/arm/include/asm/mach-imx/fbpanel.h
-+++ b/arch/arm/include/asm/mach-imx/fbpanel.h
-@@ -189,6 +189,33 @@ void fbp_setup_env_cmds(void);
- .fbtype = FB_##_mode,\
- .fbflags = _flags
-
-+/* tx31d200vm0baa == koe */
-+#define IMX_VD_KOE(_mode, _detect, _bus) \
-+{\
-+ .bus = _bus,\
-+ .addr = 0,\
-+ .pixfmt = IPU_PIX_FMT_RGB666,\
-+ .detect = NULL,\
-+ .enable = fbp_enable_fb,\
-+ .fbtype = FB_##_mode,\
-+ .fbflags = 0,\
-+ .mode = {\
-+ .name = "koe",\
-+ .refresh = 60,\
-+ .xres = 1280,\
-+ .yres = 480,\
-+ .pixclock = 1000000000000ULL/((1280+80+48+32)*(480+15+2+6)*60),\
-+ .left_margin = 80,\
-+ .right_margin = 48,\
-+ .upper_margin = 15,\
-+ .lower_margin = 2,\
-+ .hsync_len = 32,\
-+ .vsync_len = 6,\
-+ .sync = FB_SYNC_EXT,\
-+ .vmode = FB_VMODE_NONINTERLACED\
-+ }\
-+}
-+
- /* hdmi settings */
- #define VDF_1280_720M_60(_mode, _name, _fmt, _flags, _detect, _bus, _addr) \
- {\
-diff --git a/board/boundary/nitrogen6_max/nitrogen6_max.c b/board/boundary/nitrogen6_max/nitrogen6_max.c
-index 805e7d1f95..a608b9cc1d 100644
---- a/board/boundary/nitrogen6_max/nitrogen6_max.c
-+++ b/board/boundary/nitrogen6_max/nitrogen6_max.c
-@@ -503,7 +503,8 @@ int fbp_detect_serializer(struct display_info_t const *di)
- }
-
- static const struct display_info_t displays[] = {
-- /* hdmi */
-+ IMX_VD_KOE(LVDS, 0, 2),
-+ /* hdmi */
- VD_1280_720M_60(HDMI, fbp_detect_i2c, 1, 0x50),
- VD_1920_1080M_60(HDMI, NULL, 1, 0x50),
- VD_1024_768M_60(HDMI, NULL, 1, 0x50),
-diff --git a/board/boundary/nitrogen6sx/nitrogen6sx.c b/board/boundary/nitrogen6sx/nitrogen6sx.c
-index 4b550c440f..2f090d5208 100644
---- a/board/boundary/nitrogen6sx/nitrogen6sx.c
-+++ b/board/boundary/nitrogen6sx/nitrogen6sx.c
-@@ -435,7 +435,8 @@ void board_enable_lcd(const struct display_info_t *di, int enable)
- }
-
- static const struct display_info_t displays[] = {
-- /* hdmi/lcd via tfp410 */
-+ IMX_VD_KOE(LVDS, 0, 2),
-+ /* hdmi/lcd via tfp410 */
- VDF_1280_720M_60(LCD, "1280x720M@60", RGB24, 0, fbp_detect_i2c, 2, 0x50),
- VDF_1920_1080M_60(LCD, "1920x1080M@60", RGB24, 0, NULL, 2, 0x50),
- VDF_1024_768M_60(LCD, "1024x768M@60", RGB24, 0, NULL, 2, 0x50),
-diff --git a/board/boundary/nitrogen6x/nitrogen6x.c b/board/boundary/nitrogen6x/nitrogen6x.c
-index 5c0f11cdda..873fc0aab0 100644
---- a/board/boundary/nitrogen6x/nitrogen6x.c
-+++ b/board/boundary/nitrogen6x/nitrogen6x.c
-@@ -365,6 +365,7 @@ static const struct display_info_t displays[] = {
- #ifdef CONFIG_DEFAULT_DISPLAY_WXGA
- VD_WXGA(LVDS, NULL, fbp_bus_gp(0, 0, GP_LVDS_BKL_EN, 0), 0x00),
- #endif
-+ IMX_VD_KOE(LVDS, 0, 2),
- /* hdmi */
- VD_1280_720M_60(HDMI, fbp_detect_i2c, 1, 0x50),
- VD_1920_1080M_60(HDMI, NULL, 1, 0x50),
diff --git a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-boundary_%.bbappend b/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-boundary_%.bbappend
index b3894d56..5f8c379c 100644
--- a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-boundary_%.bbappend
+++ b/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-boundary_%.bbappend
@@ -29,8 +29,5 @@
FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
SRC_URI += " \
- file://0001-Add-support-for-KOE-tx31d200vm0baa-display.patch \
file://0002-set-CMA-reserved-size-to-384MB.patch \
"
-
-DEPENDS += "u-boot-mkimage-native"
diff --git a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch b/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch
deleted file mode 100644
index 02a1e33a..00000000
--- a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-script-boundary/0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 3c3c3284727076f4ae751bfc9cadb222423c9a4b Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@theqtcompany.com>
-Date: Wed, 13 Jan 2016 08:55:41 +0200
-Subject: [PATCH] Set screen resolution for ft5x06_ts based on selected display
-
----
- board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt
-index f6bf2f5..427d837 100644
---- a/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt
-+++ b/board/boundary/nitrogen6x/6x_bootscript-yocto-3.14.txt
-@@ -130,6 +130,12 @@ if itest.s "x" != "x${disable_msi}" ; then
- setenv bootargs ${bootargs} pci=nomsi
- fi;
-
-+if test "hannstar" = "${fb_lvds}" || test "hannstar" = "${fb_lvds2}" ; then
-+ setenv bootargs ${bootargs} ft5x06_ts.screenres=1024,600
-+elif test "hannstar7" = "${fb_lvds}" || test "hannstar7" = "${fb_lvds2}" ; then
-+ setenv bootargs ${bootargs} ft5x06_ts.screenres=1280,800
-+fi
-+
- if itest.s "x" != "x${disable_giga}" ; then
- setenv bootargs ${bootargs} fec.disable_giga=1
- fi
diff --git a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-script-boundary_%.bbappend b/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-script-boundary_%.bbappend
deleted file mode 100644
index e4b37308..00000000
--- a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-bsp/u-boot/u-boot-script-boundary_%.bbappend
+++ /dev/null
@@ -1,33 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2018 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
-SRC_URI += " \
- file://0001-Set-screen-resolution-for-ft5x06_ts-based-on-selecte.patch \
- "
diff --git a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-core/packagegroups/packagegroup-base.bbappend b/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-core/packagegroups/packagegroup-base.bbappend
deleted file mode 100644
index 814f8fbc..00000000
--- a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-core/packagegroups/packagegroup-base.bbappend
+++ /dev/null
@@ -1,31 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2019 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-# conflicts with wireless-regdb needed for linux-firmware-bdsdmac -> crda
-RDEPENDS_packagegroup-base-wifi_remove = "wireless-regdb-static"
diff --git a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_%.bbappend b/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_%.bbappend
deleted file mode 100644
index 0348801b..00000000
--- a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_%.bbappend
+++ /dev/null
@@ -1,30 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2019 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-export KCFLAGS = "-Wno-error=missing-attributes"
diff --git a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-kernel/linux/linux-boundary/0001-Add-support-for-koe-tx31d200vm0baa-display.patch b/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-kernel/linux/linux-boundary/0001-Add-support-for-koe-tx31d200vm0baa-display.patch
deleted file mode 100644
index 05de5cf9..00000000
--- a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-kernel/linux/linux-boundary/0001-Add-support-for-koe-tx31d200vm0baa-display.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From d1f999566c5f346104d78568b51e96dec42b60c7 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@theqtcompany.com>
-Date: Wed, 27 Jan 2016 13:07:39 +0200
-Subject: [PATCH] Add support for koe tx31d200vm0baa display
-
----
- arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi | 12 ++++++++++++
- 1 file changed, 12 insertions(+)
-
-diff --git a/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi b/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi
-index 7b4c3d9bb8e6..9be478d89745 100644
---- a/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi
-+++ b/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi
-@@ -493,6 +493,7 @@
- pwm_lvds = &pwm4;
- rtc1 = &snvs_rtc;
- t_lvds = &t_lvds;
-+ koe = &koe;
- };
-
- backlight_lcd: backlight-lcd {
-@@ -1058,6 +1059,17 @@
- hsync-len = <32>;
- vsync-len = <6>;
- };
-+ koe: tx31d200vm0baa {
-+ clock-frequency = <28000000>;
-+ hactive = <1280>;
-+ vactive = <480>;
-+ hback-porch = <200>;
-+ hfront-porch = <120>;
-+ vback-porch = <30>;
-+ vfront-porch = <20>;
-+ hsync-len = <0>;
-+ vsync-len = <0>;
-+ };
- };
- };
- };
diff --git a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-kernel/linux/linux-boundary_4.%.bbappend b/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-kernel/linux/linux-boundary_4.%.bbappend
index 578af251..7e936173 100644
--- a/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-kernel/linux/linux-boundary_4.%.bbappend
+++ b/meta-boot2qt-distro/dynamic-layers/boundary-layer/recipes-kernel/linux/linux-boundary_4.%.bbappend
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2016 The Qt Company Ltd.
+## Copyright (C) 2020 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -27,16 +27,9 @@
##
############################################################################
-FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
-SRC_URI += " \
- file://0001-Add-support-for-koe-tx31d200vm0baa-display.patch \
- "
-
# kernel image files are not needed in the image
RDEPENDS_${KERNEL_PACKAGE_NAME}-base = ""
-export KCFLAGS = "-Wno-error=missing-attributes"
-
do_preconfigure_prepend() {
echo "CONFIG_UPROBE_EVENT=y" >> ${WORKDIR}/defconfig
}