aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2020-09-21 10:05:58 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2020-09-23 19:44:22 +0300
commit5ddb9ab465a009a7a8f2bfbb23083bd03c72bcbf (patch)
treea33817b7c7f4f09349456190431396fe9239ce93
parent7787729ec4145692f9bc3fc68ad0492e686ccfa8 (diff)
toradex: update meta layers
Update meta-toradex-bsp-common & meta-toradex-nxp layers to latest revisions in their corresponding zeus branches. * remove u-boot sdboot patch as updated u-boot defaults to sd boot on apalis & colibri boards. Task-number: QTBUG-86640 Change-Id: I837f3e7a0d5e8e1a968121b8f295f8d856aadf9a Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch68
-rw-r--r--meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex/0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch10
-rw-r--r--meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex_2019%.bbappend1
-rw-r--r--scripts/manifest.xml4
4 files changed, 7 insertions, 76 deletions
diff --git a/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch b/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch
deleted file mode 100644
index fc1f12b3..00000000
--- a/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex/0001-Make-sdboot-default-on-all-boards.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From 1c9c4c4e663c9649e1103a777a3d43c7972b514e Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Mon, 15 May 2017 15:31:36 +0300
-Subject: [PATCH] Make sdboot default on all boards
-
-... and remove console=tty1 from kernel args
----
- include/configs/apalis_imx6.h | 3 ++-
- include/configs/colibri_imx6.h | 3 ++-
- include/configs/colibri_imx7.h | 3 ++-
- include/configs/colibri_vf.h | 2 +-
- 4 files changed, 7 insertions(+), 4 deletions(-)
-
-diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h
-index db37fa7b73..b871e25eb3 100644
---- a/include/configs/apalis_imx6.h
-+++ b/include/configs/apalis_imx6.h
-@@ -205,7 +205,8 @@
- #endif
- #define CONFIG_EXTRA_ENV_SETTINGS \
- BOOTENV \
-- "bootcmd=run emmcboot ; echo ; echo emmcboot failed ; " \
-+ "bootcmd=run sdboot ; echo ; echo sdboot failed ; " \
-+ "run emmcboot ; echo ; echo emmcboot failed ; " \
- "setenv fdtfile ${fdt_file}; run distro_bootcmd ; " \
- "usb start ; " \
- "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \
-diff --git a/include/configs/colibri_imx6.h b/include/configs/colibri_imx6.h
-index 86f3f0d4fa..f6b4295209 100644
---- a/include/configs/colibri_imx6.h
-+++ b/include/configs/colibri_imx6.h
-@@ -187,7 +187,8 @@
- #define FDT_FILE "imx6dl-colibri-eval-v3.dtb"
- #define CONFIG_EXTRA_ENV_SETTINGS \
- BOOTENV \
-- "bootcmd=run emmcboot ; echo ; echo emmcboot failed ; " \
-+ "bootcmd=run sdboot ; echo ; echo sdboot failed ; " \
-+ "run emmcboot ; echo ; echo emmcboot failed ; " \
- "setenv fdtfile ${fdt_file}; run distro_bootcmd ; " \
- "usb start ; " \
- "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \
-diff --git a/include/configs/colibri_imx7.h b/include/configs/colibri_imx7.h
-index 5408577661..d5918d1e2d 100644
---- a/include/configs/colibri_imx7.h
-+++ b/include/configs/colibri_imx7.h
-@@ -115,7 +115,8 @@
- "run fdt_fixup && bootz ${kernel_addr_r} - ${fdt_addr_r}\0" \
-
- #if defined(CONFIG_TARGET_COLIBRI_IMX7_NAND)
--#define CONFIG_BOOTCOMMAND "run ubiboot ; echo ; echo ubiboot failed ; " \
-+#define CONFIG_BOOTCOMMAND "run sdboot ; echo ; echo sdboot failed ; " \
-+ "run ubiboot ; echo ; echo ubiboot failed ; " \
- "setenv fdtfile ${soc}-colibri-${fdt_board}.dtb && run distro_bootcmd;"
- #define MODULE_EXTRA_ENV_SETTINGS \
- "mtdparts=" CONFIG_MTDPARTS_DEFAULT "\0" \
-diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h
-index da9a8426ec..51d29560bf 100644
---- a/include/configs/colibri_vf.h
-+++ b/include/configs/colibri_vf.h
-@@ -93,7 +93,7 @@
- "ubi read ${fdt_addr_r} dtb && " \
- "run fdt_fixup && bootz ${kernel_addr_r} - ${fdt_addr_r}\0" \
-
--#define CONFIG_BOOTCOMMAND "run ubiboot; " \
-+#define CONFIG_BOOTCOMMAND "run sdboot; run ubiboot; " \
- "setenv fdtfile ${soc}-colibri-${fdt_board}.dtb && run distro_bootcmd;"
-
- #define BOOT_TARGET_DEVICES(func) \
diff --git a/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex/0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch b/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex/0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch
index d20f58cb..9e516a2e 100644
--- a/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex/0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch
+++ b/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex/0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch
@@ -1,4 +1,4 @@
-From 37ecb16d9432b6aab050f4d609f268ce7553f85d Mon Sep 17 00:00:00 2001
+From a979b2d404962cbf2cbb8b77352c5739793e4221 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Fri, 19 May 2017 12:41:38 +0300
Subject: [PATCH] apalis-imx6: test for Capacitive Touch Display 7" Parallel
@@ -13,11 +13,11 @@ support for the atmel_mxt_ts touch controller.
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h
-index b871e25eb3..1ad8697c89 100644
+index 51942e0c32..5774e7d858 100644
--- a/include/configs/apalis_imx6.h
+++ b/include/configs/apalis_imx6.h
-@@ -198,7 +198,7 @@
-
+@@ -135,7 +135,7 @@
+ "&& setenv dtbparam \" - ${fdt_addr_r}\" && true\0"
#ifndef CONFIG_TDX_APALIS_IMX6_V1_0
-#define FDT_FILE "imx6q-apalis-eval.dtb"
@@ -25,7 +25,7 @@ index b871e25eb3..1ad8697c89 100644
#define FDT_FILE_V1_0 "imx6q-apalis_v1_0-eval.dtb"
#else
#define FDT_FILE "imx6q-apalis_v1_0-eval.dtb"
-@@ -229,9 +229,14 @@
+@@ -160,9 +160,14 @@
"|| setenv drive 2; mmc rescan; load ${interface} ${drive}:1" \
" ${loadaddr} flash_blk.img && " \
"source ${loadaddr}\0" \
diff --git a/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex_2019%.bbappend b/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex_2019%.bbappend
index 4692a33f..ff25b6fb 100644
--- a/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex_2019%.bbappend
+++ b/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-bsp/u-boot/u-boot-toradex_2019%.bbappend
@@ -29,7 +29,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += " \
- file://0001-Make-sdboot-default-on-all-boards.patch \
file://0002-apalis-imx6-test-for-Capacitive-Touch-Display-7-Para.patch \
file://0004-apalis-imx6-lower-default-resolution-on-HDMI-to-720p.patch \
"
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index d031002c..46889eb6 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -84,11 +84,11 @@
fetch="git://git.toradex.com"/>
<project name="meta-toradex-bsp-common"
remote="toradex"
- revision="7ed9958daea91fa3116132b5788495caa18db51d"
+ revision="a8f298d69fe4cdab6c59a8965fbc5cdba83f3a7e"
path="sources/meta-toradex-bsp-common"/>
<project name="meta-toradex-nxp"
remote="toradex"
- revision="ac5028651745ea2b541dbc0a847ffd737fc5ef76"
+ revision="d7121ef91af1b15f1038cb4cb51e53bab8c53d89"
path="sources/meta-toradex-nxp"/>
<!-- BoundaryDevices -->