aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Zamotaev <nzamotaev@luxoft.com>2019-05-20 17:33:00 +0300
committerNikolay Zamotaev <nzamotaev@luxoft.com>2019-05-27 21:12:46 +0300
commita5bc6361929115b181e9d0c456c559d541e51ebf (patch)
tree64751971132dfb21b1f7f559fcc81a0a9db2f92a
parent57700d767a31559b5db786f07fbd69811bf877ab (diff)
QtIVI is now built with system qfacev5.13.0-beta4
This is a switch from building qtivi with python3-virtualenv to using qface as a part of SDK. Task-number: AUTOSUITE-924 Change-Id: I683d33bd0714c702e668ed404602cce0e5c9715e Reviewed-by: Dominik Holland <dominik.holland@pelagicore.com> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--meta-boot2qt/recipes-devtools/python/antlr4-python3-runtime_4.7.1.bb38
-rw-r--r--meta-boot2qt/recipes-devtools/python/python3-jinja2_%.bbappend2
-rw-r--r--meta-boot2qt/recipes-devtools/python/python3-markupsafe_%.bbappend2
-rw-r--r--meta-boot2qt/recipes-devtools/python/python3-path.py_12.0.1.bb42
-rw-r--r--meta-boot2qt/recipes-devtools/python/python3-pathtools_0.2.1.bb38
-rw-r--r--meta-boot2qt/recipes-devtools/python/python3-setuptools-scm_%.bbappend2
-rw-r--r--meta-boot2qt/recipes-devtools/python/python3-watchdog_0.8.5.bb39
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtivi_git.bb44
-rw-r--r--meta-boot2qt/recipes-qt/qt5/qface_git.bb51
9 files changed, 218 insertions, 40 deletions
diff --git a/meta-boot2qt/recipes-devtools/python/antlr4-python3-runtime_4.7.1.bb b/meta-boot2qt/recipes-devtools/python/antlr4-python3-runtime_4.7.1.bb
new file mode 100644
index 00000000..17640b0b
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/python/antlr4-python3-runtime_4.7.1.bb
@@ -0,0 +1,38 @@
+############################################################################
+##
+## Copyright (C) 2019 Luxoft
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+PYPI_PACKAGE = "antlr4-python3-runtime"
+inherit pypi setuptools3
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=82cf535e84b8bb409a9f58ee1475511a"
+SRC_URI[md5sum] = "9535eeef56e96699106c04c8937c2ef6"
+SRC_URI[sha256sum] = "1b26b72c4492cef310542da10bf6b2ab4aa1775618fc6003f75b55ae9eaa3fd3"
+
+BBCLASSEXTEND = "nativesdk native"
diff --git a/meta-boot2qt/recipes-devtools/python/python3-jinja2_%.bbappend b/meta-boot2qt/recipes-devtools/python/python3-jinja2_%.bbappend
new file mode 100644
index 00000000..454eb39f
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/python/python3-jinja2_%.bbappend
@@ -0,0 +1,2 @@
+BBCLASSEXTEND = "nativesdk native"
+
diff --git a/meta-boot2qt/recipes-devtools/python/python3-markupsafe_%.bbappend b/meta-boot2qt/recipes-devtools/python/python3-markupsafe_%.bbappend
new file mode 100644
index 00000000..454eb39f
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/python/python3-markupsafe_%.bbappend
@@ -0,0 +1,2 @@
+BBCLASSEXTEND = "nativesdk native"
+
diff --git a/meta-boot2qt/recipes-devtools/python/python3-path.py_12.0.1.bb b/meta-boot2qt/recipes-devtools/python/python3-path.py_12.0.1.bb
new file mode 100644
index 00000000..d761263e
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/python/python3-path.py_12.0.1.bb
@@ -0,0 +1,42 @@
+############################################################################
+##
+## Copyright (C) 2019 Luxoft
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+DEPENDS += " python3-setuptools-scm \
+ python3-setuptools-scm-native \
+ "
+
+PYPI_PACKAGE = "path.py"
+inherit pypi setuptools3
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
+SRC_URI[md5sum] = "307098b1827af6031687edb49ce2c39c"
+SRC_URI[sha256sum] = "9f2169633403aa0423f6ec000e8701dd1819526c62465f5043952f92527fea0f"
+
+BBCLASSEXTEND = "nativesdk native"
diff --git a/meta-boot2qt/recipes-devtools/python/python3-pathtools_0.2.1.bb b/meta-boot2qt/recipes-devtools/python/python3-pathtools_0.2.1.bb
new file mode 100644
index 00000000..ac040d5a
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/python/python3-pathtools_0.2.1.bb
@@ -0,0 +1,38 @@
+############################################################################
+##
+## Copyright (C) 2019 Luxoft
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+PYPI_PACKAGE = "pathtools3"
+inherit pypi setuptools3
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=56bd93578433bb99b4fdf7ff481722df"
+SRC_URI[md5sum] = "08bb008161e305909740076c5c422159"
+SRC_URI[sha256sum] = "630c1edc09ef93abea40fc06b10067e5734d8f38cc85867bc61d1a5c9eb7796f"
+
+BBCLASSEXTEND = "nativesdk native"
diff --git a/meta-boot2qt/recipes-devtools/python/python3-setuptools-scm_%.bbappend b/meta-boot2qt/recipes-devtools/python/python3-setuptools-scm_%.bbappend
new file mode 100644
index 00000000..454eb39f
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/python/python3-setuptools-scm_%.bbappend
@@ -0,0 +1,2 @@
+BBCLASSEXTEND = "nativesdk native"
+
diff --git a/meta-boot2qt/recipes-devtools/python/python3-watchdog_0.8.5.bb b/meta-boot2qt/recipes-devtools/python/python3-watchdog_0.8.5.bb
new file mode 100644
index 00000000..9f774df0
--- /dev/null
+++ b/meta-boot2qt/recipes-devtools/python/python3-watchdog_0.8.5.bb
@@ -0,0 +1,39 @@
+############################################################################
+##
+## Copyright (C) 2019 Luxoft
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+PYPI_PACKAGE = "watchdog3"
+DEPENDS = "python3-pathtools"
+inherit pypi setuptools3
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+SRC_URI[md5sum] = "3e13f11f432fec5eb0198d9b1d2a55ab"
+SRC_URI[sha256sum] = "742b1b8836807bca7e28b062b85987ae5fc10aada4274c204b26a195a7ddf2b3"
+
+BBCLASSEXTEND = "nativesdk native"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
index cb8df312..3ed7fce4 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
@@ -1,6 +1,7 @@
############################################################################
##
## Copyright (C) 2019 The Qt Company Ltd.
+## Copyright (C) 2019 Luxoft
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -44,25 +45,20 @@ inherit python3native
require recipes-qt/qt5/qt5-git.inc
QT_MODULE_BRANCH = "5.13"
-QT_MODULE_BRANCH_QFACE = "upstream/master"
SRC_URI += " \
- ${QT_GIT}/qtivi-qface.git;name=qface;branch=${QT_MODULE_BRANCH_QFACE};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/qface \
file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \
"
-SRCREV_qtivi = "6d3baa216200dfec92d8875ed09d83f85b34311a"
-SRCREV_qface = "0a3ae7686e1100be452b8c435bdcd84ec242340e"
-SRCREV = "${SRCREV_qtivi}"
-SRCREV_FORMAT = "qtivi_qface"
+SRCREV = "6d3baa216200dfec92d8875ed09d83f85b34311a"
PACKAGECONFIG ?= "taglib ivigenerator remoteobjects"
PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib"
PACKAGECONFIG[dlt] = "QMAKE_EXTRA_ARGS+=-feature-dlt,QMAKE_EXTRA_ARGS+=-no-feature-dlt,dlt-daemon"
PACKAGECONFIG[geniviextras-only] = "QMAKE_EXTRA_ARGS+=--geniviextras-only"
# For cross-compiling tell qtivi to use the system-ivigenerator, which is installed by the native recipe"
-PACKAGECONFIG[ivigenerator] = "QMAKE_EXTRA_ARGS+=-system-ivigenerator"
-PACKAGECONFIG[ivigenerator-native] = "QMAKE_EXTRA_ARGS+=-qt-ivigenerator,,python3 python3-virtualenv"
+PACKAGECONFIG[ivigenerator] = "QMAKE_EXTRA_ARGS+=-system-qface QMAKE_EXTRA_ARGS+=-system-ivigenerator"
+PACKAGECONFIG[ivigenerator-native] = "QMAKE_EXTRA_ARGS+=-system-qface QMAKE_EXTRA_ARGS+=-qt-ivigenerator,,qface"
PACKAGECONFIG[host-tools-only] = "QMAKE_EXTRA_ARGS+=-host-tools-only"
PACKAGECONFIG[remoteobjects] = "QMAKE_EXTRA_ARGS+=-feature-remoteobjects,,qtremoteobjects qtremoteobjects-native"
PACKAGECONFIG[remoteobjects-native] = "QMAKE_EXTRA_ARGS+=-feature-remoteobjects QMAKE_EXTRA_ARGS+=--force-ivigenerator-qtremoteobjects"
@@ -75,37 +71,5 @@ ALLOW_EMPTY_${PN}-tools = "1"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS} ${@bb.utils.contains_any('PACKAGECONFIG', 'ivigenerator ivigenerator-native', '', 'QMAKE_EXTRA_ARGS+=-no-ivigenerator', d)}"
-set_python_paths() {
- # Otherwise pip might cache or reuse something from our home folder
- export HOME="${STAGING_DATADIR_NATIVE}"
- # This is needed as otherwise the virtualenv tries to use the libs from the host
- export LD_LIBRARY_PATH="${STAGING_LIBDIR_NATIVE}"
- # Let qtivi use the python3-native binaries
- export PYTHON3_PATH="${STAGING_BINDIR_NATIVE}/python3-native"
-}
-do_compile_prepend() {
- set_python_paths
-}
-do_install_prepend() {
- set_python_paths
-}
-
-# This needs a modified python3 recipe which copies the binary into a path where this recipe can pick it up
-# This is needed to provide a proper executable using the correct interpreter in the SDK.
-# See https://bugreports.qt.io/browse/AUTOSUITE-176
-do_install_append_class-nativesdk() {
- export IVIGENERATOR_ENABLED="${@bb.utils.contains("PACKAGECONFIG", "ivigenerator-native", "1", "0", d)}"
-
- if [ "${IVIGENERATOR_ENABLED}" = "1" ]; then
- cp ${STAGING_BINDIR}/qt5/python3* ${D}/${OE_QMAKE_PATH_BINS}/ivigenerator/qtivi_qface_virtualenv/bin/
- rm -f ${D}/${OE_QMAKE_PATH_BINS}/ivigenerator/qtivi_qface_virtualenv/bin/python
- ln -sf python3 ${D}/${OE_QMAKE_PATH_BINS}/ivigenerator/qtivi_qface_virtualenv/bin/python
- fi
-}
-
-
BBCLASSEXTEND += "native nativesdk"
-INSANE_SKIP_${PN}_class-native = "already-stripped"
-INSANE_SKIP_${PN}_class-nativesdk = "already-stripped"
-INSANE_SKIP_${PN}-tools_class-nativesdk = "staticdev file-rdeps libdir build-deps"
diff --git a/meta-boot2qt/recipes-qt/qt5/qface_git.bb b/meta-boot2qt/recipes-qt/qt5/qface_git.bb
new file mode 100644
index 00000000..89d52894
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/qt5/qface_git.bb
@@ -0,0 +1,51 @@
+############################################################################
+##
+## Copyright (C) 2019 Luxoft
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+inherit pypi setuptools3
+
+DEPENDS += " python3-jinja2 \
+ python3-click \
+ python3-pyyaml \
+ python3-pytest \
+ python3-six \
+ python3-path.py \
+ antlr4-python3-runtime \
+ python3-watchdog \
+ python3-markupsafe \
+ "
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=eee61e10a40b0e3045ee5965bcd9a8b5"
+SRC_URI = "git://code.qt.io/qt/qtivi-qface.git;protocol=https;nobranch=1"
+SRCREV = "0a3ae7686e1100be452b8c435bdcd84ec242340e"
+PV = "1.10"
+S = "${WORKDIR}/git"
+CLEANBROKEN = "1"
+
+BBCLASSEXTEND = "nativesdk native"