aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-09-17 13:15:51 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2019-09-18 15:27:28 +0300
commita9f6a6b1d686601b827a8d6085ce131b4e2a6e83 (patch)
treec385f4d012bbc33800bd74b70fc8e9847397b013
parenta073d68be4d54c030903fc5a84a38d45b6eda371 (diff)
parentd113ffe26ed863296d5271ce8bd19af82b99e21a (diff)
Merge remote-tracking branch 'origin/thud' into warrior
* origin/thud: c9aa86c Merge remote-tracking branch 'origin/sumo' into thud eeb8907 Pull lfs files during initialization 9e76b43 Update automotive sha1s for 5.13.1 in thud branch 1635123 Merge remote-tracking branch 'origin/QtAS-5.12.4' into sumo d8a1f66 renesas: use new repo for proprierate binaries 0ab7521 coin: use gcc-7 for CI builds a0b9200 Update automotive sha1s in QtAS-5.12.4 branch 5d275d7 Update automotive sha1s in QtAS-5.12.4 branch 0407488 Update automotive sha1s in QtAS-5.12.4 branch 418de6c Add config for NXP i.MX8QXP Conflicts: b2qt-init-build-env meta-boot2qt-distro/conf/distro/include/rcar-gen3.inc scripts/manifest.xml scripts/setup-environment.sh Change-Id: I0b7970c277c1df7f39af8cb0d0f47b34ad69d4b0
-rwxr-xr-xb2qt-init-build-env2
-rw-r--r--coin/module_config.yaml6
-rw-r--r--meta-boot2qt-distro/conf/distro/include/imx8qxpmek.conf32
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb2
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb2
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtivi_git.bb2
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtsaferenderer_git.bb2
-rwxr-xr-xscripts/setup-environment.sh2
8 files changed, 44 insertions, 6 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env
index 65fbe373..6f2b7a0d 100755
--- a/b2qt-init-build-env
+++ b/b2qt-init-build-env
@@ -148,7 +148,7 @@ get_groups() {
all)
PROJECT_GROUPS="external"
;;
- imx8qmmek|imx8mqevk)
+ imx8*)
PROJECT_GROUPS="fsl-imx8"
;;
apalis-imx8|colibri-imx8qxp)
diff --git a/coin/module_config.yaml b/coin/module_config.yaml
index 531c20c8..103c715c 100644
--- a/coin/module_config.yaml
+++ b/coin/module_config.yaml
@@ -50,6 +50,12 @@ build_instructions:
- type: ChangeDirectory
directory: "{{.BuildDir}}"
- type: ExecuteCommand
+ command: ["sudo", "ln", "-sf", "gcc-7", "/usr/bin/gcc"]
+ userMessageOnFailure: "Could not create link for gcc-7"
+ - type: ExecuteCommand
+ command: ["sudo", "ln", "-sf", "g++-7", "/usr/bin/g++"]
+ userMessageOnFailure: "Could not create link for g++-7"
+ - type: ExecuteCommand
command: ["sudo", "mkdir", "-p", "/mnt/yocto-cache"]
userMessageOnFailure: "Could not create '/mnt/yocto-cache' directory"
- type: ExecuteCommand
diff --git a/meta-boot2qt-distro/conf/distro/include/imx8qxpmek.conf b/meta-boot2qt-distro/conf/distro/include/imx8qxpmek.conf
new file mode 100644
index 00000000..3445d5c2
--- /dev/null
+++ b/meta-boot2qt-distro/conf/distro/include/imx8qxpmek.conf
@@ -0,0 +1,32 @@
+############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+include conf/distro/include/fsl-imx8.inc
+
+DEPLOY_CONF_NAME = "NXP i.MX 8QuadXPlus MEK"
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
index f33b04d9..15d06373 100644
--- a/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
@@ -49,7 +49,7 @@ SRC_URI += " \
SRC_URI_append_mx6 = " file://0001_hardware_variant_low.patch"
SRC_URI_append_rpi = " file://0001_hardware_variant_low.patch"
-SRCREV = "63dce6f69a00ebc7b15230da74b4e24af3fc78a5"
+SRCREV = "cbbfd19ba50ac65d33b72f3d47dfaa1aca74cccd"
QMAKE_PROFILES = "${S}/neptune3-ui.pro"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
index 53207382..7fcc7c6e 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -34,7 +34,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504"
inherit qt5-module
require recipes-qt/qt5/qt5-git.inc
-SRCREV = "0c1dd0be7d106e3e5c5a096f91e3908d19d94d57"
+SRCREV = "ea7811529421975182f3de519da36ea610844eb9"
DEPENDS = "qtbase qtdeclarative libyaml libarchive \
${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland qtwayland-native", "", d)}"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
index 18bdd946..a0fdb29d 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
@@ -54,7 +54,7 @@ SRC_URI += " \
file://ivi-services.target \
"
-SRCREV = "5c1e05d5d1fbd42207128f503805be027036e3ef"
+SRCREV = "51d1472eb3e605c9da7030be1f7ef5ae36975aa6"
PACKAGECONFIG ?= "taglib ivigenerator remoteobjects"
PACKAGECONFIG[taglib] = "QMAKE_EXTRA_ARGS+=-feature-taglib,QMAKE_EXTRA_ARGS+=-no-feature-taglib,taglib"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtsaferenderer_git.bb b/meta-boot2qt/recipes-qt/automotive/qtsaferenderer_git.bb
index a9ff16a7..f10d37c5 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtsaferenderer_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtsaferenderer_git.bb
@@ -52,7 +52,7 @@ SRC_URI = "\
git://codereview.qt-project.org/tqtc-boot2qt/qtsaferenderer;branch=${BRANCH};protocol=ssh;sdk-uri=Src/QtSafeRenderer-1.1.1 \
file://0001-Fix-yocto-build-issues.patch \
"
-SRCREV = "d539df4ddb0f6189b7294e5a67d611ab39b7bf72"
+SRCREV = "3596699dc8927f1112b6a7974fc80d68ab1fd0f6"
DEPENDS = "qtbase qtdeclarative"
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh
index 386e3d30..132c6167 100755
--- a/scripts/setup-environment.sh
+++ b/scripts/setup-environment.sh
@@ -63,7 +63,7 @@ if [ ! -e ${PWD}/${BUILDDIRECTORY} ]; then
LAYERSCONF=${BSPLAYER}/conf/bblayers.conf.sample
else
case ${MACHINE} in
- imx8qmmek|imx8mqevk)
+ imx8*)
LAYERSCONF="bblayers.conf.fsl-imx8.sample"
;;
apalis-imx8|colibri-imx8qxp)