aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2020-10-15 13:48:36 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2020-10-20 08:50:13 +0300
commitad2613c7c1107d17c0ee253f2e784257d7bd3bc8 (patch)
tree8046b956946c054a078ce4374d746895c353f42d
parentf650da0607dccd6ec829f3a23d554252c233aac8 (diff)
Add recipe for Boot to Qt Startup Screenv6.0.0-beta1
Add new demo application that is started when the device boots up, unless the default application has been changed from Qt Creator. Task-number: QTBUG-87027 Change-Id: I144b1e9c52834622055811d95e6572e7b454692a Reviewed-by: Rami Potinkara <rami.potinkara@qt.io>
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb1
-rw-r--r--meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-startupscreen/startupscreen.service11
-rw-r--r--meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-startupscreen_git.bb58
3 files changed, 70 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
index 8db2c27c..b3aae7ca 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
@@ -36,5 +36,6 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
RDEPENDS_${PN} += " \
boot2qt-appcontroller \
+ boot2qt-startupscreen \
qdb \
"
diff --git a/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-startupscreen/startupscreen.service b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-startupscreen/startupscreen.service
new file mode 100644
index 00000000..cdaf69c0
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-startupscreen/startupscreen.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Boot to Qt Startup Screen
+After=systemd-user-sessions.service
+ConditionPathExists=!/usr/bin/b2qt
+
+[Service]
+User=root
+ExecStart=-/usr/bin/appcontroller /usr/bin/statupscreen
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-startupscreen_git.bb b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-startupscreen_git.bb
new file mode 100644
index 00000000..6bbb0463
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/boot2qt-addons/boot2qt-startupscreen_git.bb
@@ -0,0 +1,58 @@
+############################################################################
+##
+## Copyright (C) 2020 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+DESCRIPTION = "Boot to Qt Startup Screen"
+LICENSE = "BSD | The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = "file://${BOOT2QTBASE}/licenses/The-Qt-Company-Commercial;md5=c8b6dd132d52c6e5a545df07a4e3e283"
+
+inherit qt6-cmake systemd
+require recipes-qt/qt6/qt6-git.inc
+
+QT_GIT = "git://codereview.qt-project.org"
+QT_GIT_PROTOCOL = "http"
+QT_GIT_PROJECT = "qt-apps"
+QT_MODULE = "boot2qt-demos"
+
+SRC_URI += "\
+ file://startupscreen.service \
+"
+
+DEPENDS += "qtbase qtdeclarative qtdeclarative-native"
+
+S = "${WORKDIR}/git/startupscreen"
+
+do_install_append() {
+ install -m 0755 -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/startupscreen.service ${D}${systemd_unitdir}/system/
+}
+
+
+SYSTEMD_SERVICE_${PN} = "startupscreen.service"
+
+SRCREV = "84726988dad28ad4b7e77dcda7baddda094b90dd"