aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorihito Tohge <norihito.tohge@qt.io>2020-04-01 12:47:25 +0900
committerNorihito Tohge <norihito.tohge@qt.io>2020-04-01 19:03:35 +0900
commitbebdde47d724537fcf0685a19ea829fbbdf677a4 (patch)
tree2ecd8defdf5a0ce7705eb9b945d195740dcda5f8
parentf093b75609f95cebbd757ee245f7360df8d36160 (diff)
Make it possible to set the EGL_DEFAULT_DISPLAY on Renesas devices
Change-Id: I3711fdf025241c66c203f7f5cb6bbc0e1a7acd34 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--meta-renesas-extras/recipes/qt5/qtbase/0001-Make-it-possible-to-set-the-EGL_DEFAULT_DISPLAY.patch28
-rw-r--r--meta-renesas-extras/recipes/qt5/qtbase_git.bbappend4
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/qt5/qtbase/0001-Make-it-possible-to-set-the-EGL_DEFAULT_DISPLAY.patch b/meta-renesas-extras/recipes/qt5/qtbase/0001-Make-it-possible-to-set-the-EGL_DEFAULT_DISPLAY.patch
new file mode 100644
index 00000000..646ff902
--- /dev/null
+++ b/meta-renesas-extras/recipes/qt5/qtbase/0001-Make-it-possible-to-set-the-EGL_DEFAULT_DISPLAY.patch
@@ -0,0 +1,28 @@
+From c479704a66219157b9666cd6a960dc06b14f1107 Mon Sep 17 00:00:00 2001
+From: Andy Nichols <andy.nichols@qt.io>
+Date: Fri, 14 Feb 2020 17:33:44 +0100
+Subject: [PATCH] Make it possible to set the EGL_DEFAULT_DISPLAY
+
+Change-Id: I564f1ce72501bc12b960c87c953343fd64ee9011
+---
+ src/plugins/platforms/eglfs/api/qeglfsdeviceintegration.cpp | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/plugins/platforms/eglfs/api/qeglfsdeviceintegration.cpp b/src/plugins/platforms/eglfs/api/qeglfsdeviceintegration.cpp
+index e3145aa0b0..b985386a4e 100644
+--- a/src/plugins/platforms/eglfs/api/qeglfsdeviceintegration.cpp
++++ b/src/plugins/platforms/eglfs/api/qeglfsdeviceintegration.cpp
+@@ -185,7 +185,9 @@ void QEglFSDeviceIntegration::platformDestroy()
+
+ EGLNativeDisplayType QEglFSDeviceIntegration::platformDisplay() const
+ {
+- return EGL_DEFAULT_DISPLAY;
++ bool displayOk;
++ const int defaultDisplay = qEnvironmentVariableIntValue("QT_QPA_EGLFS_DEFAULT_DISPLAY", &displayOk);
++ return displayOk ? EGLNativeDisplayType(quintptr(defaultDisplay)) : EGL_DEFAULT_DISPLAY;
+ }
+
+ EGLDisplay QEglFSDeviceIntegration::createDisplay(EGLNativeDisplayType nativeDisplay)
+--
+2.17.1
+
diff --git a/meta-renesas-extras/recipes/qt5/qtbase_git.bbappend b/meta-renesas-extras/recipes/qt5/qtbase_git.bbappend
index ecba1f14..d0765896 100644
--- a/meta-renesas-extras/recipes/qt5/qtbase_git.bbappend
+++ b/meta-renesas-extras/recipes/qt5/qtbase_git.bbappend
@@ -30,3 +30,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
PACKAGECONFIG += "gbm kms"
+
+SRC_URI += "\
+ file://0001-Make-it-possible-to-set-the-EGL_DEFAULT_DISPLAY.patch \
+"