aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-10-04 16:21:38 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-10-08 14:00:06 +0300
commitd9a73ed50ff3127ad318705c3e069c240b3a09a7 (patch)
tree230743270d8093c7d53df3dcbae34bcd6075fc60
parent1ea6aae90a13137520796126434b6ebd36a797ec (diff)
rpi: switch to kms backend
meta-raspberrypi has changed to using vc4graphics, which support kms. Remove BBMASK from meta-raspberrypi qt5 recipe append and those can now be used to make the needed changes for the integration plugin. RPI enables examples for qtbase, disable them for all our builds. Remove use of QT_GSTREAMER_USE_OPENGL_PLUGIN as it does not work. Change-Id: I3ab2a4b423141e404addc1c6a63a358fe80b8ad0 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/conf/distro/include/raspberrypi.inc2
-rw-r--r--meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/boot2qt-addons/default-qt-envs.bbappend2
-rw-r--r--meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/qt5/qtbase_git.bbappend30
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend2
4 files changed, 2 insertions, 34 deletions
diff --git a/meta-boot2qt-distro/conf/distro/include/raspberrypi.inc b/meta-boot2qt-distro/conf/distro/include/raspberrypi.inc
index 795b0cd7..b2b1f0a0 100644
--- a/meta-boot2qt-distro/conf/distro/include/raspberrypi.inc
+++ b/meta-boot2qt-distro/conf/distro/include/raspberrypi.inc
@@ -240,5 +240,3 @@ RPI_KERNEL_DEVICETREE_OVERLAYS = "\
overlays/w1-gpio-pullup.dtbo \
overlays/wittypi.dtbo \
"
-
-BBMASK += "dynamic-layers/qt5-layer/recipes-qt/qt5"
diff --git a/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/boot2qt-addons/default-qt-envs.bbappend b/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
index f9d3708f..177e83a6 100644
--- a/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
+++ b/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
@@ -29,5 +29,5 @@
do_configure_append() {
echo "QT_QPA_EGLFS_FORCE888=1" >> ${WORKDIR}/defaults
- echo "QT_GSTREAMER_USE_OPENGL_PLUGIN=1" >> ${WORKDIR}/defaults
+ echo "QT_QPA_EGLFS_KMS_ATOMIC=1" >> ${WORKDIR}/defaults
}
diff --git a/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/qt5/qtbase_git.bbappend b/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/qt5/qtbase_git.bbappend
deleted file mode 100644
index db6b219a..00000000
--- a/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-qt/qt5/qtbase_git.bbappend
+++ /dev/null
@@ -1,30 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2019 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-QT_QPA_EGLFS_INTEGRATION ?= "eglfs_brcm"
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
index cb346298..b8a8bc13 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase_git.bbappend
@@ -46,7 +46,7 @@ PACKAGECONFIG += " \
xkbcommon \
"
-PACKAGECONFIG_remove = "tests"
+PACKAGECONFIG_remove = "tests examples"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"