aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 13:08:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-12 14:12:31 +0000
commit344c2f97025c6504ec986600498121bb83aaeb8f (patch)
tree3d7ec602603cb083b7c8e998eddca543ce17e57c /meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
parentd9985542d7617b43ec7180c7ade0c4f64db82b42 (diff)
Split meta-boot2qt layer
Move distro specific recipes to own layer and leave only new recipes and bbclasses to meta-boot2qt layer. This makes it easier to include meta-boot2qt to your own distro layer to get access e.g., QDB and QBSP recipes that might be useful even without boot2qt distro. Task-number: QTBUG-65871 Change-Id: I6c353774dd1668b00f2d05aa262ad866b90bdef6 Reviewed-by: Timo Aarnipuro <timo.aarnipuro@qt.io>
Diffstat (limited to 'meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb')
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
new file mode 100644
index 00000000..a79d596d
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
@@ -0,0 +1,79 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+DESCRIPTION = "Qt5 modules"
+LICENSE = "The-Qt-Company-DCLA-2.1"
+
+inherit packagegroup
+
+PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
+
+RDEPENDS_${PN} += " \
+ qt3d \
+ qtbase \
+ qtcanvas3d \
+ qtcharts \
+ qtconnectivity \
+ qtdatavis3d \
+ qtdeclarative \
+ qtdeclarative-tools \
+ qtdeviceutilities \
+ qtgraphicaleffects \
+ qtimageformats \
+ qtlocation \
+ qtmultimedia \
+ qtnetworkauth \
+ qtotaupdate \
+ qtquickcontrols \
+ qtquickcontrols2 \
+ qtremoteobjects \
+ qtscxml \
+ qtsensors \
+ qtserialbus \
+ qtserialport \
+ qtsvg \
+ qttools \
+ qttranslations-qt \
+ qttranslations-qtbase \
+ qttranslations-qtdeclarative \
+ qttranslations-qtconnectivity \
+ qttranslations-qtlocation \
+ qttranslations-qtmultimedia \
+ qttranslations-qtquickcontrols \
+ qttranslations-qtserialport \
+ qttranslations-qtwebsockets \
+ qttranslations-qtxmlpatterns \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'qtwayland', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine qttranslations-qtwebengine qtwebview', '', d)} \
+ qtwebsockets \
+ qtwebchannel \
+ qtwebglplugin \
+ qtxmlpatterns \
+ qtvirtualkeyboard \
+ "