aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2024-03-21 08:32:42 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2024-04-16 12:00:44 +0000
commit3741bc87829e5af4a3ebcf1e8def145810f7c570 (patch)
tree44ddc0a662cd613a47b129a9bcd905df33b7ce16 /meta-boot2qt-distro
parent689404facef4b622b74f2dd90917f808f56f8acd (diff)
Add Qt for Python
Qt 6.7 now has support for Qt for Python and starting with Qt 6.7.1 include it in boot2qt images. Task-number: QTBUG-118869 Pick-to: nanbield kirkstone Change-Id: Idee93311aa6439b684ede862b23a31870310c795 Reviewed-by: Alex Bu <alex.bu@qt.io> Reviewed-by: Ari Parkkila <ari.parkkila@qt.io>
Diffstat (limited to 'meta-boot2qt-distro')
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
index 6006afc1..495d7e69 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
@@ -37,6 +37,9 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
USE_QT_DEMO_LAUNCHER ?= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', \
bb.utils.vercmp_string_op(d.getVar('QT_VERSION'), '6.7', '>'), False, d)}"
+USE_PYSIDE ?= "${@bb.utils.vercmp_string_op(d.getVar('QT_VERSION'), '6.7.0', '>') & \
+ bb.utils.vercmp_string_op(d.getVar('QT_VERSION'), '6.8', '<')}"
+
RDEPENDS:${PN} += " \
${@'boot2qt-demolauncher' if bb.utils.to_boolean(d.getVar('USE_QT_DEMO_LAUNCHER')) else ''} \
boot2qt-appcontroller \
@@ -45,4 +48,5 @@ RDEPENDS:${PN} += " \
qtdeclarative-tools \
qttools-tools \
${@'squish' if bb.utils.to_boolean(d.getVar('USE_SQUISH')) else ''} \
+ ${@'python3-pyside6' if bb.utils.to_boolean(d.getVar('USE_PYSIDE')) else ''} \
"