aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2023-10-25 06:22:17 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2023-10-26 05:46:42 +0000
commit64ddac174883616043d7aeaeeb71cadc108f9bcb (patch)
treec39cb0724d3d1ce9643ef1df136e06fed42b5398 /meta-boot2qt-distro
parent7ca0b06939a03480c6c1ec4b1777a8bc679f5327 (diff)
tegra: update qtbase bbappend
Use the same bbappend as was upstreamed to meta-tegra, until we update meta-tegra to our builds. This enables correct eglfs platform plugin and sets it as preferred one. Pick-to: mickledore Change-Id: I1e2d6e7ffcfed70c4e906940fdcfd7de38e68665 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-boot2qt-distro')
-rw-r--r--meta-boot2qt-distro/dynamic-layers/tegra/recipes-qt/qt6/qtbase_%.bbappend4
-rw-r--r--meta-boot2qt-distro/dynamic-layers/tegra/recipes-qt/qt6/qtbase_git.bbappend31
2 files changed, 4 insertions, 31 deletions
diff --git a/meta-boot2qt-distro/dynamic-layers/tegra/recipes-qt/qt6/qtbase_%.bbappend b/meta-boot2qt-distro/dynamic-layers/tegra/recipes-qt/qt6/qtbase_%.bbappend
new file mode 100644
index 00000000..8fb8ce64
--- /dev/null
+++ b/meta-boot2qt-distro/dynamic-layers/tegra/recipes-qt/qt6/qtbase_%.bbappend
@@ -0,0 +1,4 @@
+PACKAGECONFIG_GRAPHICS:append:tegra = " ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'eglfs-egldevice', d)}"
+
+QT_QPA_DEFAULT_EGLFS_INTEGRATION ?= "${@bb.utils.contains('PREFERRED_RPROVIDER_tegra-gbm-backend', 'tegra-libraries-gbm-backend', 'eglfs_kms_egldevice', 'eglfs_kms', d)}"
+EXTRA_OECMAKE:append:tegra = " -DQT_QPA_DEFAULT_EGLFS_INTEGRATION=${QT_QPA_DEFAULT_EGLFS_INTEGRATION}"
diff --git a/meta-boot2qt-distro/dynamic-layers/tegra/recipes-qt/qt6/qtbase_git.bbappend b/meta-boot2qt-distro/dynamic-layers/tegra/recipes-qt/qt6/qtbase_git.bbappend
deleted file mode 100644
index 3668eb18..00000000
--- a/meta-boot2qt-distro/dynamic-layers/tegra/recipes-qt/qt6/qtbase_git.bbappend
+++ /dev/null
@@ -1,31 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2020 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-PACKAGECONFIG += "eglfs-egldevice"
-PACKAGECONFIG:remove = "gbm"