aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro
diff options
context:
space:
mode:
authorAri Parkkila <ari.parkkila@qt.io>2023-06-19 12:41:17 +0300
committerAri Parkkila <ari.parkkila@qt.io>2023-06-21 09:25:02 +0300
commit75fff91315a533920852c04051e11ea38775a632 (patch)
tree3ce393d70b8d8551e7f39dabe10d94130f9181e1 /meta-boot2qt-distro
parent4556d3576245d93c0e174444cedbafeb275fa7c2 (diff)
imx: Fix i.MX GPU driver version for Vulkan loader
Vulkan loader reads driver path from imx_icd.json so update it to use a driver version installed on target. Pick-to: mickledore langdale kirkstone Task-number: QTBUG-113609 Change-Id: I1b1a0faaa6066bcf57c8a71f1db42416548f7989 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-boot2qt-distro')
-rw-r--r--meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-graphics/imx-gpu-viv/files/imx_icd.json7
-rw-r--r--meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.%.bbappend30
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-graphics/imx-gpu-viv/files/imx_icd.json b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-graphics/imx-gpu-viv/files/imx_icd.json
new file mode 100644
index 00000000..21d83f94
--- /dev/null
+++ b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-graphics/imx-gpu-viv/files/imx_icd.json
@@ -0,0 +1,7 @@
+{
+ "file_format_version": "1.0.0",
+ "ICD": {
+ "library_path": "%libdir%/libvulkan_VSI.so.1",
+ "api_version": "%api_version%"
+ }
+}
diff --git a/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.%.bbappend b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.%.bbappend
new file mode 100644
index 00000000..c532426b
--- /dev/null
+++ b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.%.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2023 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"