aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2023-12-21 08:32:39 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2024-01-09 11:01:03 +0000
commitaee6b47a724181e10fd8b36a74d8904f9fc78731 (patch)
tree282b81f59f9235ac4569115bd21411e2c3b2a673 /meta-boot2qt-distro
parent73069ff774a4882bca52eb0c7186a1ad5efffff1 (diff)
Revert "abseil-cpp: fix mingw build"
This reverts commit e92acff35ed10960a45a55078b73c8c35516724b. Fix has been merged in meta-oe. Change-Id: I13acd45170479fa1ff6c196354caab3f39ca09e4 Reviewed-by: Alex Bu <alex.bu@qt.io> Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-boot2qt-distro')
-rw-r--r--meta-boot2qt-distro/recipes-devtools/abseil-cpp/abseil-cpp/0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch62
-rw-r--r--meta-boot2qt-distro/recipes-devtools/abseil-cpp/abseil-cpp_git.bbappend7
2 files changed, 0 insertions, 69 deletions
diff --git a/meta-boot2qt-distro/recipes-devtools/abseil-cpp/abseil-cpp/0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch b/meta-boot2qt-distro/recipes-devtools/abseil-cpp/abseil-cpp/0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch
deleted file mode 100644
index db559bb1..00000000
--- a/meta-boot2qt-distro/recipes-devtools/abseil-cpp/abseil-cpp/0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From cb7665f39e23e95e2466390c60ee5a410780a3ed Mon Sep 17 00:00:00 2001
-From: Derek Mauro <dmauro@google.com>
-Date: Wed, 8 Nov 2023 09:55:31 -0800
-Subject: [PATCH] Avoid using both Win32Waiter and PthreadWaiter on MinGW, and
- use StdcppWaiter instead.
-
-There are various flavors of MinGW, some of which support pthread,
-and some of which support Win32. Instead of figuring out which
-platform is being used, just use the generic implementation.
-
-PiperOrigin-RevId: 580565507
-Change-Id: Ia85fd7496f1e6ebdeadb95202f0039e844826118
-Upstream-Status: Backport
----
- absl/synchronization/internal/pthread_waiter.h | 4 ++--
- absl/synchronization/internal/win32_waiter.h | 6 ++++--
- 2 files changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/absl/synchronization/internal/pthread_waiter.h b/absl/synchronization/internal/pthread_waiter.h
-index 206aefa4..23db76ad 100644
---- a/absl/synchronization/internal/pthread_waiter.h
-+++ b/absl/synchronization/internal/pthread_waiter.h
-@@ -16,7 +16,7 @@
- #ifndef ABSL_SYNCHRONIZATION_INTERNAL_PTHREAD_WAITER_H_
- #define ABSL_SYNCHRONIZATION_INTERNAL_PTHREAD_WAITER_H_
-
--#ifndef _WIN32
-+#if !defined(_WIN32) && !defined(__MINGW32__)
- #include <pthread.h>
-
- #include "absl/base/config.h"
-@@ -55,6 +55,6 @@ class PthreadWaiter : public WaiterCrtp<PthreadWaiter> {
- ABSL_NAMESPACE_END
- } // namespace absl
-
--#endif // ndef _WIN32
-+#endif // !defined(_WIN32) && !defined(__MINGW32__)
-
- #endif // ABSL_SYNCHRONIZATION_INTERNAL_PTHREAD_WAITER_H_
-diff --git a/absl/synchronization/internal/win32_waiter.h b/absl/synchronization/internal/win32_waiter.h
-index 87eb617c..fdab264e 100644
---- a/absl/synchronization/internal/win32_waiter.h
-+++ b/absl/synchronization/internal/win32_waiter.h
-@@ -20,7 +20,8 @@
- #include <sdkddkver.h>
- #endif
-
--#if defined(_WIN32) && _WIN32_WINNT >= _WIN32_WINNT_VISTA
-+#if defined(_WIN32) && !defined(__MINGW32__) && \
-+ _WIN32_WINNT >= _WIN32_WINNT_VISTA
-
- #include "absl/base/config.h"
- #include "absl/synchronization/internal/kernel_timeout.h"
-@@ -65,6 +66,7 @@ class Win32Waiter : public WaiterCrtp<Win32Waiter> {
- ABSL_NAMESPACE_END
- } // namespace absl
-
--#endif // defined(_WIN32) && _WIN32_WINNT >= _WIN32_WINNT_VISTA
-+#endif // defined(_WIN32) && !defined(__MINGW32__) &&
-+ // _WIN32_WINNT >= _WIN32_WINNT_VISTA
-
- #endif // ABSL_SYNCHRONIZATION_INTERNAL_WIN32_WAITER_H_
diff --git a/meta-boot2qt-distro/recipes-devtools/abseil-cpp/abseil-cpp_git.bbappend b/meta-boot2qt-distro/recipes-devtools/abseil-cpp/abseil-cpp_git.bbappend
deleted file mode 100644
index 24ee6e3d..00000000
--- a/meta-boot2qt-distro/recipes-devtools/abseil-cpp/abseil-cpp_git.bbappend
+++ /dev/null
@@ -1,7 +0,0 @@
-PV = "20230802.1"
-SRCREV = "fb3621f4f897824c0dbe0615fa94543df6192f30"
-
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch"
-
-SYSROOT_DIRS:append:class-nativesdk:mingw32 = " ${bindir}"