aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2024-01-11 07:23:57 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2024-01-15 12:05:25 +0000
commitf2ec272e0bf08fb38167a87b534065717dc92f9e (patch)
tree347f0bd6aade3cffed3e1a1828ffc84391f33cfa /meta-boot2qt-distro
parent77404487f7456cc7181a605851b8e32f18605cd5 (diff)
packagegroups: move Qt packages to right packagegroup
qtinterfaceframework packages should be added in the qt6 packagegroup and it's required only for mingw toolchain. DISTRO_FEATURE doesn't work as expected in nativesdk builds, so the wayland additition hasn't done anything, we can remove it. This fixes ci-sdk, so that it doesn't have any nativesdk-qt*-dev packages installed, which interfere with the CI builds. Pick-to: nanbield Change-Id: I4315fac90fee9673fe8009e2c5efb4ad59e485c0 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-boot2qt-distro')
-rw-r--r--meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb3
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt6-toolchain-host.bb5
2 files changed, 5 insertions, 3 deletions
diff --git a/meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
index 68f2495c..9cbd7d11 100644
--- a/meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
+++ b/meta-boot2qt-distro/recipes-core/packagegroups/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
@@ -44,9 +44,6 @@ RDEPENDS:${PN} = "\
nativesdk-perl-modules \
nativesdk-python3-modules \
nativesdk-python3-misc \
- ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "nativesdk-wayland-dev", "", d)} \
- nativesdk-qtinterfaceframework-dev \
- nativesdk-qtinterfaceframework-tools \
"
RDEPENDS:${PN}:remove:mingw32 = "\
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt6-toolchain-host.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt6-toolchain-host.bb
index a208e5a5..31ce9be5 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt6-toolchain-host.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/nativesdk-packagegroup-b2qt-embedded-qt6-toolchain-host.bb
@@ -37,3 +37,8 @@ RDEPENDS:${PN} += "\
nativesdk-packagegroup-b2qt-embedded-toolchain-host \
nativesdk-packagegroup-qt6-toolchain-host \
"
+
+RDEPENDS:${PN}:append:mingw32 = "\
+ nativesdk-qtinterfaceframework-dev \
+ nativesdk-qtinterfaceframework-tools \
+"