aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2023-09-06 12:21:06 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2023-09-08 07:15:01 +0000
commit12a4687fb32285623d6649d376af08f21da20d9b (patch)
treeffdda2faa1210fd3ed22c19f31b7d3fbd0d1c03b /meta-boot2qt
parent6bc31edc0e5d95f72bbf29466feff08caad8e614 (diff)
python: update prebuild python for windows toolchain
QtInterfaceFramework needs updated python qface module. Use the updated windows python module package. Pick-to: mickledore langdale kirkstone Task-number: QTBUG-116719 Change-Id: Ie5e497d75ff0590b58d21fc6319242803287e8f0 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-boot2qt')
-rw-r--r--meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc44
-rw-r--r--meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb7
-rw-r--r--meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb7
3 files changed, 9 insertions, 49 deletions
diff --git a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc
index 79d773f8..b13e3dfe 100644
--- a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc
+++ b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python.inc
@@ -41,46 +41,12 @@ S = "${WORKDIR}"
PROVIDES += " \
python3 \
- python3-watchdog \
- python3-path.py \
- antlr4-python3-runtime \
- python3-jinja2 \
- python3-markupsafe \
- qface \
- "
-
-RPROVIDES:${PN} += " \
- python3-pkgutil \
- python3-xml \
- python3-crypt \
- python3-compile \
- python3-netserver \
- python3-compression \
- python3-numbers \
- python3-unittest \
- python3-netclient \
- python3-math \
- python3-ctypes \
- python3-html \
- python3-json \
- python3-datetime \
- python3-distutils \
- python3-shell \
- python3-stringold \
- python3-email \
- python3-threading \
- python3-pprint \
- python3-plistlib \
- python3-io \
- python3-pickle \
- \
- qface \
- python3-jinja2 \
- python3-watchdog \
- python3-path.py \
- python3-markupsafe \
- antlr4-python3-runtime \
+ python3-qface \
+ python3-html5lib \
+ python3-modules \
+ python3-misc \
"
+RPROVIDES:${PN} += "${PROVIDES}"
do_install() {
install -d ${D}${includedir}/${PYTHON_DIR}
diff --git a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb
index 78b9f8f9..bad47aae 100644
--- a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb
+++ b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_i686.bb
@@ -34,12 +34,9 @@ COMPATIBLE_HOST = "i686.*-mingw.*"
SRC_URI = "\
https://download.qt.io/development_releases/prebuilt/python/Python35-win-x86.7z \
https://www.python.org/ftp/python/${PV}/python-${PV}-embed-win32.zip;name=bin \
- https://download.qt.io/development_releases/prebuilt/python/python-${PV}-modules-win32.zip;name=modules \
+ https://download.qt.io/development_releases/prebuilt/python/python-${PV}-modules-win32.7z;name=modules \
"
-SRC_URI[md5sum] = "3da266445a4e6a93ff1949810141da8f"
SRC_URI[sha256sum] = "b60c49227c6e920904d784681c16ee3591a18824c3abb89613813f93fde1c1f2"
-SRC_URI[bin.md5sum] = "ad637a1db7cf91e344318d55c94ad3ca"
SRC_URI[bin.sha256sum] = "75f05800fbe4a8cd6672b268ca53244838684561e03c60c668a7dccb050eb954"
-SRC_URI[modules.md5sum] = "c44f01754f9975ae6d910783d69e6a28"
-SRC_URI[modules.sha256sum] = "13bbbcc724165407cfbec8d23424bd94f45541092f08523f0064f75e6c4de5ae"
+SRC_URI[modules.sha256sum] = "fd078a2888b2bd7daf46901dbe3c4bcab320c44540639f786e0d2b36ba30ac02"
diff --git a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb
index 71b6c4b6..1b0ae2fb 100644
--- a/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb
+++ b/meta-boot2qt/recipes-devtools/python/nativesdk-prebuild-python_x86_64.bb
@@ -34,12 +34,9 @@ COMPATIBLE_HOST = "x86_64.*-mingw.*"
SRC_URI = "\
https://download.qt.io/development_releases/prebuilt/python/Python35-win-x64.7z \
https://www.python.org/ftp/python/${PV}/python-${PV}-embed-amd64.zip;name=bin \
- https://download.qt.io/development_releases/prebuilt/python/python-${PV}-modules-amd64.zip;name=modules \
+ https://download.qt.io/development_releases/prebuilt/python/python-${PV}-modules-amd64.7z;name=modules \
"
-SRC_URI[md5sum] = "08766b13bcbdcf8217a98bfc291d549f"
SRC_URI[sha256sum] = "43e38c8a05dcbc2effd1915dbe2dc2be6e701ebf3eb00d6e45197ee773978124"
-SRC_URI[bin.md5sum] = "f1c24bb78bd6dd792a73d5ebfbd3b20e"
SRC_URI[bin.sha256sum] = "faefbd98f61c0d87c5683eeb526ae4d4a9ddc369bef27870cfe1c8939329d066"
-SRC_URI[modules.md5sum] = "bf1deaf0a0b807bcd52e11d15892fec2"
-SRC_URI[modules.sha256sum] = "cd82789e05bf763b3b67f8e3ec78873c69ce922a13e391298be198702967d6da"
+SRC_URI[modules.sha256sum] = "64ef161e9e6a96a2f59582a133a86414ff4b135f367d733dc351d54d970fff9f"