aboutsummaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-01-25 09:37:59 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2019-02-01 06:58:36 +0000
commit12f3a11c1930152c17c70e34dc01c80feca20333 (patch)
treedad2d9ad2dfb5e2f36461872dd612d4fae216c08 /meta-fsl-extras
parent334546f57a18032f146bab09fe3f097db254b1b2 (diff)
nitrogen6x: update u-boot-boundary patches
Update meta-boundary to master branch where thud layer compatibility is set & update patches for yocto thud Task-number: QTBUG-72413 Change-Id: Ie654dbb1d82799e3170e947cf80baf64aa725ab6 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch46
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch8
-rw-r--r--meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch14
3 files changed, 38 insertions, 30 deletions
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
index 123782e3..9378f0a6 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0001-Add-support-for-KOE-tx31d200vm0baa-display.patch
@@ -1,21 +1,21 @@
-From 07234c1c0f991a560010672a619740e385778f90 Mon Sep 17 00:00:00 2001
+From ea15ee300074cb1453dce6a068feec0771a28418 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@theqtcompany.com>
Date: Thu, 11 Feb 2016 10:17:51 +0200
Subject: [PATCH] Add support for KOE tx31d200vm0baa display
Used for the cluster demo
---
- arch/arm/include/asm/imx-common/fbpanel.h | 27 ++++++++++++++++++++
- board/boundary/nitrogen6_max/nitrogen6_max.c | 1 +
- board/boundary/nitrogen6sx/nitrogen6sx.c | 1 +
- board/boundary/nitrogen6x/nitrogen6x.c | 1 +
- 4 files changed, 30 insertions(+)
+ arch/arm/include/asm/mach-imx/fbpanel.h | 27 ++++++++++++++++++++
+ board/boundary/nitrogen6_max/nitrogen6_max.c | 3 ++-
+ board/boundary/nitrogen6sx/nitrogen6sx.c | 3 ++-
+ board/boundary/nitrogen6x/nitrogen6x.c | 3 ++-
+ 4 files changed, 33 insertions(+), 3 deletions(-)
-diff --git a/arch/arm/include/asm/imx-common/fbpanel.h b/arch/arm/include/asm/imx-common/fbpanel.h
-index f5465c3c80..643cd86e29 100644
---- a/arch/arm/include/asm/imx-common/fbpanel.h
-+++ b/arch/arm/include/asm/imx-common/fbpanel.h
-@@ -116,6 +116,33 @@ void fbp_setup_display(const struct display_info_t *displays, int cnt);
+diff --git a/arch/arm/include/asm/mach-imx/fbpanel.h b/arch/arm/include/asm/mach-imx/fbpanel.h
+index 4b924d2ac8..d4ef998faf 100644
+--- a/arch/arm/include/asm/mach-imx/fbpanel.h
++++ b/arch/arm/include/asm/mach-imx/fbpanel.h
+@@ -174,6 +174,33 @@ void fbp_setup_env_cmds(void);
.fbtype = FB_##_mode,\
.fbflags = _flags
@@ -50,38 +50,44 @@ index f5465c3c80..643cd86e29 100644
#define VDF_1280_720M_60(_mode, _name, _fmt, _flags, _detect, _bus, _addr) \
{\
diff --git a/board/boundary/nitrogen6_max/nitrogen6_max.c b/board/boundary/nitrogen6_max/nitrogen6_max.c
-index 1c4106e735..51bc0bd8f3 100644
+index 12e3af89d0..3be475efc0 100644
--- a/board/boundary/nitrogen6_max/nitrogen6_max.c
+++ b/board/boundary/nitrogen6_max/nitrogen6_max.c
-@@ -497,6 +497,7 @@ int fbp_detect_serializer(struct display_info_t const *di)
+@@ -499,7 +499,8 @@ int fbp_detect_serializer(struct display_info_t const *di)
}
static const struct display_info_t displays[] = {
+- /* hdmi */
+ IMX_VD_KOE(LVDS, 0, 2),
- /* hdmi */
++ /* hdmi */
VD_1280_720M_60(HDMI, fbp_detect_i2c, 1, 0x50),
VD_1920_1080M_60(HDMI, NULL, 1, 0x50),
+ VD_1024_768M_60(HDMI, NULL, 1, 0x50),
diff --git a/board/boundary/nitrogen6sx/nitrogen6sx.c b/board/boundary/nitrogen6sx/nitrogen6sx.c
-index dc05042add..3725d63cf3 100644
+index 5581637424..5ded443c78 100644
--- a/board/boundary/nitrogen6sx/nitrogen6sx.c
+++ b/board/boundary/nitrogen6sx/nitrogen6sx.c
-@@ -436,6 +436,7 @@ void board_enable_lcd(const struct display_info_t *di, int enable)
+@@ -435,7 +435,8 @@ void board_enable_lcd(const struct display_info_t *di, int enable)
}
static const struct display_info_t displays[] = {
+- /* hdmi/lcd via tfp410 */
+ IMX_VD_KOE(LVDS, 0, 2),
- /* hdmi/lcd via tfp410 */
++ /* hdmi/lcd via tfp410 */
VDF_1280_720M_60(LCD, "1280x720M@60", RGB24, 0, fbp_detect_i2c, 2, 0x50),
VDF_1920_1080M_60(LCD, "1920x1080M@60", RGB24, 0, NULL, 2, 0x50),
+ VDF_1024_768M_60(LCD, "1024x768M@60", RGB24, 0, NULL, 2, 0x50),
diff --git a/board/boundary/nitrogen6x/nitrogen6x.c b/board/boundary/nitrogen6x/nitrogen6x.c
-index d9f6a829f1..80b102e206 100644
+index 8ee7f641bf..dbf1bd4a99 100644
--- a/board/boundary/nitrogen6x/nitrogen6x.c
+++ b/board/boundary/nitrogen6x/nitrogen6x.c
-@@ -359,6 +359,7 @@ void board_pre_enable(const struct display_info_t *di)
+@@ -362,7 +362,8 @@ void board_pre_enable(const struct display_info_t *di)
}
static const struct display_info_t displays[] = {
+- /* hdmi */
+ IMX_VD_KOE(LVDS, 0, 2),
- /* hdmi */
++ /* hdmi */
VD_1280_720M_60(HDMI, fbp_detect_i2c, 1, 0x50),
VD_1920_1080M_60(HDMI, NULL, 1, 0x50),
+ VD_1024_768M_60(HDMI, NULL, 1, 0x50),
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch
index b0791e96..d730e60a 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0002-set-CMA-reserved-size-to-384MB.patch
@@ -1,4 +1,4 @@
-From fa2e83db63fe5abdfa00d205301d12e1a271a291 Mon Sep 17 00:00:00 2001
+From e21337ad1663e6fd6da4a5175ad72e629c62bab5 Mon Sep 17 00:00:00 2001
From: Mikko Gronoff <mikko.gronoff@qt.io>
Date: Sun, 23 Apr 2017 21:47:01 +0300
Subject: [PATCH] set CMA reserved size to 384MB
@@ -10,14 +10,14 @@ video decoding cannot work for high resolution videos.
1 file changed, 1 insertion(+)
diff --git a/include/configs/nitrogen6x.h b/include/configs/nitrogen6x.h
-index bd4e54cb67..48114d5739 100644
+index 62708b839b..eb3b30b2ce 100644
--- a/include/configs/nitrogen6x.h
+++ b/include/configs/nitrogen6x.h
-@@ -33,6 +33,7 @@
+@@ -26,6 +26,7 @@
#define CONFIG_USB_MAX_CONTROLLER_COUNT 2
#define BD_I2C_MASK 7
+#define BD_CMA "384M"
#if defined(CONFIG_SABRELITE)
- #define CONFIG_ENV_IS_IN_MMC
+ #include "boundary.h"
diff --git a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch
index c5fa9231..49af5e54 100644
--- a/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch
+++ b/meta-fsl-extras/recipes/u-boot/u-boot-boundary/0003-Disable-build-for-tools.patch
@@ -1,4 +1,4 @@
-From 22c5a278b98cf6ea4e4a402bca19d1354ab3c431 Mon Sep 17 00:00:00 2001
+From baed831959ba41b8d1cebfb5d960ddfa847ae915 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Tue, 25 Sep 2018 16:05:17 +0300
Subject: [PATCH] Disable build for tools and use mkimage from sysroot
@@ -11,10 +11,10 @@ fails when trying to compile with host gcc: unable to execute
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
-index 119ad49eec..022690e26e 100644
+index 7d5f801eea..d5d44c5def 100644
--- a/Makefile
+++ b/Makefile
-@@ -698,7 +698,7 @@ libs-y += $(if $(BOARDDIR),board/$(BOARDDIR)/)
+@@ -730,7 +730,7 @@ libs-y += $(if $(BOARDDIR),board/$(BOARDDIR)/)
libs-y := $(sort $(libs-y))
@@ -24,13 +24,15 @@ index 119ad49eec..022690e26e 100644
u-boot-alldirs := $(sort $(u-boot-dirs) $(patsubst %/,%,$(filter %/, $(libs-))))
diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
-index 80ddb08474..e86c949f08 100644
+index f8c3fff1d1..f24ea9cc25 100644
--- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib
-@@ -493,5 +493,5 @@ cmd_xzmisc = (cat $(filter-out FORCE,$^) | \
+@@ -508,7 +508,7 @@ cmd_xzmisc = (cat $(filter-out FORCE,$^) | \
# ---------------------------------------------------------------------------
MKIMAGEOUTPUT ?= /dev/null
quiet_cmd_mkimage = MKIMAGE $@
-cmd_mkimage = $(objtree)/tools/mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \
+cmd_mkimage = mkimage $(MKIMAGEFLAGS_$(@F)) -d $< $@ \
- $(if $(KBUILD_VERBOSE:1=), >$(MKIMAGEOUTPUT))
+ >$(MKIMAGEOUTPUT) $(if $(KBUILD_VERBOSE:0=), && cat $(MKIMAGEOUTPUT))
+
+ # fdtgrep