aboutsummaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-01-25 12:48:11 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2019-01-28 08:30:58 +0000
commitbe15ea860dda1317e786393ab396775d7e3bf83b (patch)
tree3be23f07c6d9a68677224a01a4a7eec149d45c80 /meta-fsl-extras
parenta0e0bd8facb4c49675c3f323a2486035b9ae4187 (diff)
meta-qt5: update layer
Update to latest content in Qt 5.12.1 branch (RC2), remove upstreamed patch. Change-Id: Iea9e6a9358e377c71fa7ad368ba4bffd78c6f497 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-fsl-extras')
-rw-r--r--meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch57
-rw-r--r--meta-fsl-extras/recipes/qt5/qtbase_git.bbappend33
2 files changed, 0 insertions, 90 deletions
diff --git a/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch b/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch
deleted file mode 100644
index dc56cfc5..00000000
--- a/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 40e76307c1ee1ebe4e0142d623071d0f768f2450 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Wed, 9 Jan 2019 13:01:01 +0000
-Subject: [PATCH] egl_viv: cast EGLNative types from vivante functions
-
-All vivante functions return void* even when the actual native type
-(EGLNativeDisplayType, EGLNativeWindowType, etc.) might be typedef'ed
-as something else, as they do when the CFLAGS from egl.pc are now used.
----
- .../deviceintegration/eglfs_viv/qeglfsvivintegration.cpp | 4 ++--
- .../deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp | 4 ++--
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp
-index 763a4a462b..2fc076ad0c 100644
---- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp
-+++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp
-@@ -65,7 +65,7 @@ void QEglFSVivIntegration::platformInit()
- VivanteInit();
- mNativeDisplay = fbGetDisplay();
- #else
-- mNativeDisplay = fbGetDisplayByIndex(framebufferIndex());
-+ mNativeDisplay = static_cast<EGLNativeDisplayType>(fbGetDisplayByIndex(framebufferIndex()));
- #endif
-
- fbGetDisplayGeometry(mNativeDisplay, &width, &height);
-@@ -88,7 +88,7 @@ EGLNativeWindowType QEglFSVivIntegration::createNativeWindow(QPlatformWindow *wi
- Q_UNUSED(window)
- Q_UNUSED(format)
-
-- EGLNativeWindowType eglWindow = fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height());
-+ EGLNativeWindowType eglWindow = static_cast<EGLNativeWindowType>(fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height()));
- return eglWindow;
- }
-
-diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp
-index 61e2f17766..3bdae239cd 100644
---- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp
-+++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp
-@@ -60,7 +60,7 @@ void QEglFSVivWaylandIntegration::platformInit()
- }
-
- mWaylandDisplay = wl_display_create();
-- mNativeDisplay = fbGetDisplay(mWaylandDisplay);
-+ mNativeDisplay = static_cast<EGLNativeDisplayType>(fbGetDisplay(mWaylandDisplay));
- fbGetDisplayGeometry(mNativeDisplay, &width, &height);
- mScreenSize.setHeight(height);
- mScreenSize.setWidth(width);
-@@ -81,7 +81,7 @@ EGLNativeWindowType QEglFSVivWaylandIntegration::createNativeWindow(QPlatformWin
- Q_UNUSED(window)
- Q_UNUSED(format)
-
-- EGLNativeWindowType eglWindow = fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height());
-+ EGLNativeWindowType eglWindow = static_cast<EGLNativeWindowType>(fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height()));
- return eglWindow;
- }
-
diff --git a/meta-fsl-extras/recipes/qt5/qtbase_git.bbappend b/meta-fsl-extras/recipes/qt5/qtbase_git.bbappend
deleted file mode 100644
index 373e6140..00000000
--- a/meta-fsl-extras/recipes/qt5/qtbase_git.bbappend
+++ /dev/null
@@ -1,33 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2018 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI += " \
- file://0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch \
- "