aboutsummaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-10-16 13:48:01 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-10-18 06:35:05 +0000
commit2358c45fad661cd52f2102f5696185753bf81180 (patch)
tree4765bbeac4bcd872023f1a70f0120f2b9ea505ca /meta-renesas-extras
parent58a38f958df0fd2facd0062e9c522b8ddf9513f0 (diff)
renesas: add workaround for qtwebengine
QtWebEngine on Renesas boards is unable to find address for the eglGetProcAddress symbol at runtime, instead do it already at link time. Task-number: QTBUG-71152 Change-Id: I41f831af431933eff7781d42d73ab72c68f38471 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-renesas-extras')
-rw-r--r--meta-renesas-extras/recipes/qt5/qtwebengine/0001-Workaround-missing-eglGetProcAddress.patch28
-rw-r--r--meta-renesas-extras/recipes/qt5/qtwebengine_git.bbappend32
2 files changed, 60 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/qt5/qtwebengine/0001-Workaround-missing-eglGetProcAddress.patch b/meta-renesas-extras/recipes/qt5/qtwebengine/0001-Workaround-missing-eglGetProcAddress.patch
new file mode 100644
index 00000000..ed1339b6
--- /dev/null
+++ b/meta-renesas-extras/recipes/qt5/qtwebengine/0001-Workaround-missing-eglGetProcAddress.patch
@@ -0,0 +1,28 @@
+From 4b59d8fa3ba5647834d29fad58b9231c154b9136 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Tue, 16 Oct 2018 13:43:43 +0300
+Subject: [PATCH] Workaround missing eglGetProcAddress
+
+Renesas boards are unable to find address for the eglGetProcAddress
+symbol at runtime, instead do it already at link time.
+
+Task-number: QTBUG-71152
+Change-Id: Ibc4251c0ab7e878a65d8c6e7b4da3952807cbc91
+---
+ src/core/ozone/gl_ozone_egl_qt.cpp | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/core/ozone/gl_ozone_egl_qt.cpp b/src/core/ozone/gl_ozone_egl_qt.cpp
+index 2fa86d79..d2362477 100644
+--- a/src/core/ozone/gl_ozone_egl_qt.cpp
++++ b/src/core/ozone/gl_ozone_egl_qt.cpp
+@@ -98,6 +98,9 @@ bool GLOzoneEGLQt::LoadGLES2Bindings(gl::GLImplementation /*implementation*/)
+ }
+ #endif
+
++ if (!get_proc_address)
++ get_proc_address = &eglGetProcAddress;
++
+ if (!get_proc_address) {
+ LOG(ERROR) << "eglGetProcAddress not found.";
+ base::UnloadNativeLibrary(eglgles2Library);
diff --git a/meta-renesas-extras/recipes/qt5/qtwebengine_git.bbappend b/meta-renesas-extras/recipes/qt5/qtwebengine_git.bbappend
new file mode 100644
index 00000000..cc13b746
--- /dev/null
+++ b/meta-renesas-extras/recipes/qt5/qtwebengine_git.bbappend
@@ -0,0 +1,32 @@
+############################################################################
+##
+## Copyright (C) 2018 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://0001-Workaround-missing-eglGetProcAddress.patch"