aboutsummaryrefslogtreecommitdiffstats
path: root/meta-renesas-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-08-18 13:06:48 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-08-19 06:09:41 +0000
commitdb175fc660e65ef9ded6d999087a9b9aa307b4e5 (patch)
tree34d521a5b92c8cb420052a0567429529afd05d09 /meta-renesas-extras
parentcdf98603a186c49ece6007d3c300b6e6aa845b74 (diff)
renesas: fix build issues caused by pyro change
Change-Id: I25f74a1fb8e912f1f069b657fc63e66a9eb1e887 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-renesas-extras')
-rw-r--r--meta-renesas-extras/recipes/gles-module/gles-user-module.bbappend8
-rw-r--r--meta-renesas-extras/recipes/gles-module/gles-user-module/gl3ext.h24
-rw-r--r--meta-renesas-extras/recipes/gstreamer/gstreamer1.0-plugins-bad_%.bbappend30
-rw-r--r--meta-renesas-extras/recipes/mesa/mesa_%.bbappend (renamed from meta-renesas-extras/recipes/mesa/mesa_12.%.bbappend)0
-rw-r--r--meta-renesas-extras/recipes/u-boot/u-boot_%.bbappend4
-rw-r--r--meta-renesas-extras/recipes/wayland/wayland-kms_1.6.0.bbappend30
-rw-r--r--meta-renesas-extras/recipes/wayland/weston_1.11.0.bbappend30
7 files changed, 126 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/gles-module/gles-user-module.bbappend b/meta-renesas-extras/recipes/gles-module/gles-user-module.bbappend
index 8a9bda0a..9806a3cc 100644
--- a/meta-renesas-extras/recipes/gles-module/gles-user-module.bbappend
+++ b/meta-renesas-extras/recipes/gles-module/gles-user-module.bbappend
@@ -27,4 +27,12 @@
##
############################################################################
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append = " file://gl3ext.h"
+
DEPENDS = "mesa"
+
+do_install_append() {
+ install -m 644 ${WORKDIR}/gl3ext.h ${D}/${includedir}/GLES3/
+}
diff --git a/meta-renesas-extras/recipes/gles-module/gles-user-module/gl3ext.h b/meta-renesas-extras/recipes/gles-module/gles-user-module/gl3ext.h
new file mode 100644
index 00000000..4d4ea96c
--- /dev/null
+++ b/meta-renesas-extras/recipes/gles-module/gles-user-module/gl3ext.h
@@ -0,0 +1,24 @@
+#ifndef __gl3ext_h_
+#define __gl3ext_h_
+
+/* $Revision: 17809 $ on $Date:: 2012-05-14 08:03:36 -0700 #$ */
+
+/*
+ * This document is licensed under the SGI Free Software B License Version
+ * 2.0. For details, see http://oss.sgi.com/projects/FreeB/ .
+ */
+
+/* OpenGL ES 3 Extensions
+ *
+ * After an OES extension's interactions with OpenGl ES 3.0 have been documented,
+ * its tokens and function definitions should be added to this file in a manner
+ * that does not conflict with gl2ext.h or gl3.h.
+ *
+ * Tokens and function definitions for extensions that have become standard
+ * features in OpenGL ES 3.0 will not be added to this file.
+ *
+ * Applications using OpenGL-ES-2-only extensions should include gl2ext.h
+ */
+
+#endif /* __gl3ext_h_ */
+
diff --git a/meta-renesas-extras/recipes/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/meta-renesas-extras/recipes/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
new file mode 100644
index 00000000..85be9538
--- /dev/null
+++ b/meta-renesas-extras/recipes/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2017 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+DEPENDS += "wayland-kms libgbm"
diff --git a/meta-renesas-extras/recipes/mesa/mesa_12.%.bbappend b/meta-renesas-extras/recipes/mesa/mesa_%.bbappend
index 0542b65d..0542b65d 100644
--- a/meta-renesas-extras/recipes/mesa/mesa_12.%.bbappend
+++ b/meta-renesas-extras/recipes/mesa/mesa_%.bbappend
diff --git a/meta-renesas-extras/recipes/u-boot/u-boot_%.bbappend b/meta-renesas-extras/recipes/u-boot/u-boot_%.bbappend
index 361abbfa..47fe2ceb 100644
--- a/meta-renesas-extras/recipes/u-boot/u-boot_%.bbappend
+++ b/meta-renesas-extras/recipes/u-boot/u-boot_%.bbappend
@@ -27,10 +27,14 @@
##
############################################################################
+LICENSE = "GPLv2+"
+
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://0001-compiler-.h-sync-include-linux-compiler-.h-with-Linu.patch"
+S = "${WORKDIR}/git"
+
do_deploy_prepend() {
cp ${B}/${UBOOT_SREC} ${S}/${UBOOT_SREC}
}
diff --git a/meta-renesas-extras/recipes/wayland/wayland-kms_1.6.0.bbappend b/meta-renesas-extras/recipes/wayland/wayland-kms_1.6.0.bbappend
new file mode 100644
index 00000000..0cd3eec9
--- /dev/null
+++ b/meta-renesas-extras/recipes/wayland/wayland-kms_1.6.0.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2017 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+DEPENDS += "wayland-native"
diff --git a/meta-renesas-extras/recipes/wayland/weston_1.11.0.bbappend b/meta-renesas-extras/recipes/wayland/weston_1.11.0.bbappend
new file mode 100644
index 00000000..ef14c2f1
--- /dev/null
+++ b/meta-renesas-extras/recipes/wayland/weston_1.11.0.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2017 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+EXTRA_OECONF += "WAYLAND_PROTOCOLS_SYSROOT_DIR=${RECIPE_SYSROOT}"