aboutsummaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras
diff options
context:
space:
mode:
authorAndy Nichols <andy.nichols@theqtcompany.com>2015-02-18 14:34:17 +0100
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2015-05-26 12:55:33 +0300
commit06a8c81b3a0ae818b129638a1d8d4f9b327d8eb2 (patch)
tree085fd7dee60caebe96efb9d1d81e719eaab9b16a /meta-toradex-extras
parent8127be12eb0e119c422f635fb7b8d43b81d2e8c5 (diff)
Fix Linux Kernel 3.18 build with Colibri-VF
The Linux Kernel blacklists GCC 4.8.0 - 4.8.2 because of a bug. The GCC 4.8.2 provided by Poky has already been patched for this bug so it is safe to renabled building with GCC 4.8. GCC Bug: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=58854 Change-Id: If3ea442b1dfbef8991c39f8d1326643cf418b1ec Reviewed-by: Samuli Piippo <samuli.piippo@theqtcompany.com>
Diffstat (limited to 'meta-toradex-extras')
-rw-r--r--meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Allow-builds-with-GCC-4.8.patch27
-rw-r--r--meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend26
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Allow-builds-with-GCC-4.8.patch b/meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Allow-builds-with-GCC-4.8.patch
new file mode 100644
index 00000000..43edec3d
--- /dev/null
+++ b/meta-toradex-extras/recipes/linux/linux-toradex-vf/0001-Allow-builds-with-GCC-4.8.patch
@@ -0,0 +1,27 @@
+From 30c67656c09f49608bbadb75e365d1d3da36cc70 Mon Sep 17 00:00:00 2001
+From: Andy Nichols <andy.nichols@theqtcompany.com>
+Date: Wed, 18 Feb 2015 14:28:14 +0100
+Subject: [PATCH] Allow builds with GCC 4.8
+
+---
+ arch/arm/kernel/asm-offsets.c | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/arch/arm/kernel/asm-offsets.c b/arch/arm/kernel/asm-offsets.c
+index 2d2d608..6f8e79c 100644
+--- a/arch/arm/kernel/asm-offsets.c
++++ b/arch/arm/kernel/asm-offsets.c
+@@ -49,10 +49,6 @@
+ #error Your compiler is too buggy; it is known to miscompile kernels.
+ #error Known good compilers: 3.3, 4.x
+ #endif
+-#if GCC_VERSION >= 40800 && GCC_VERSION < 40803
+-#error Your compiler is too buggy; it is known to miscompile kernels
+-#error and result in filesystem corruption and oopses.
+-#endif
+ #endif
+
+ int main(void)
+--
+1.9.1
+
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend
new file mode 100644
index 00000000..4f05386d
--- /dev/null
+++ b/meta-toradex-extras/recipes/linux/linux-toradex-vf_3.18.bbappend
@@ -0,0 +1,26 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://www.qt.io/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+SRC_URI += " \
+ file://0001-Allow-builds-with-GCC-4.8.patch \
+ "