aboutsummaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@digia.com>2014-09-23 15:17:53 +0300
committerSamuli Piippo <samuli.piippo@digia.com>2014-09-25 15:22:40 +0300
commit8962af850b3317680b88f0d8fa10df5787747e27 (patch)
tree2a2d54bc0ae7ec46581e1fb0d4f4f2afbb428374 /meta-toradex-extras
parent2395137acb37e56a85c1b78bad86a58d9c04e54d (diff)
Move meta-toradex specific files to separate layer
Create new layer for recipes and files that required only when meta-toradex layer is used. For now, the bblayers.conf template still includes the new layer as well. Change-Id: Ib2c81a444786845f2e7c2fbf78dd0676459996c0 Reviewed-by: Eirik Aavitsland <eirik.aavitsland@digia.com>
Diffstat (limited to 'meta-toradex-extras')
-rw-r--r--meta-toradex-extras/conf/layer.conf33
-rw-r--r--meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend29
2 files changed, 62 insertions, 0 deletions
diff --git a/meta-toradex-extras/conf/layer.conf b/meta-toradex-extras/conf/layer.conf
new file mode 100644
index 00000000..aba9374d
--- /dev/null
+++ b/meta-toradex-extras/conf/layer.conf
@@ -0,0 +1,33 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://qt.digia.com/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
+ ${LAYERDIR}/recipes*/*/*.bbappend \
+ "
+
+BBFILE_COLLECTIONS += "b2qt_toradex"
+BBFILE_PATTERN_b2qt_toradex := "^${LAYERDIR}/"
+BBFILE_PRIORITY_b2qt_toradex = "20"
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend
new file mode 100644
index 00000000..0bcbad7f
--- /dev/null
+++ b/meta-toradex-extras/recipes/linux/linux-toradex-fsl_git.bbappend
@@ -0,0 +1,29 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://qt.digia.com/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+# kernel image files are not needed in the image
+RDEPENDS_kernel-base = ""
+
+config_script () {
+ # FunctionFS for adb
+ echo "CONFIG_USB_FUNCTIONFS=m" >> ${S}/.config
+}