aboutsummaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-08-29 15:53:47 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-09-20 12:39:50 +0300
commit8b14714e95a2d82f9747c08be494a09ddf2f01be (patch)
treef7b8d64043abea230264d4892502896ca1757640 /meta-toradex-extras
parent61c40f565769b34f82c57aedf3f730f23b9f7c03 (diff)
Move extra layers to use BBFILES_DYNAMIC
Instead of having additional meta layers, include the bbappends dynamically whenever the corresponding layer is used. Change-Id: I30f62ada645d9bf0e2a4aee9ca4db4144a6ccb83 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'meta-toradex-extras')
-rw-r--r--meta-toradex-extras/classes/image_type_tezi_warrior.bbclass250
-rw-r--r--meta-toradex-extras/conf/layer.conf46
-rw-r--r--meta-toradex-extras/recipes-bsp/tezi-metadata/files/Built_with_Qt.pngbin1871 -> 0 bytes
-rw-r--r--meta-toradex-extras/recipes-bsp/tezi-metadata/files/TEZI_B2QT_EULA.TXT75
-rw-r--r--meta-toradex-extras/recipes-bsp/tezi-metadata/tezi-metadata_%.bbappend44
-rw-r--r--meta-toradex-extras/recipes-core/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch22
-rw-r--r--meta-toradex-extras/recipes-core/systemd/systemd_%.bbappend33
-rw-r--r--meta-toradex-extras/recipes-kernel/linux/linux-toradex/0001-Enable-atmel-mxt-multitouch-controller.patch32
-rw-r--r--meta-toradex-extras/recipes-kernel/linux/linux-toradex_4.9-2.3.x.bbappend32
9 files changed, 0 insertions, 534 deletions
diff --git a/meta-toradex-extras/classes/image_type_tezi_warrior.bbclass b/meta-toradex-extras/classes/image_type_tezi_warrior.bbclass
deleted file mode 100644
index 22af0713..00000000
--- a/meta-toradex-extras/classes/image_type_tezi_warrior.bbclass
+++ /dev/null
@@ -1,250 +0,0 @@
-inherit image_types
-
-do_image_teziimg[depends] += "tezi-metadata:do_deploy virtual/bootloader:do_deploy"
-
-TEZI_ROOT_FSTYPE ??= "ext4"
-UBOOT_BINARY ??= "u-boot.${UBOOT_SUFFIX}"
-UBOOT_BINARY_TEZI = "${UBOOT_BINARY}"
-UBOOT_BINARY_TEZI_apalis-t30 = "apalis_t30.img"
-UBOOT_BINARY_TEZI_apalis-tk1 = "apalis-tk1.img"
-UBOOT_BINARY_TEZI_apalis-tk1-mainline = "apalis-tk1.img"
-UBOOT_ENV_TEZI = "uEnv.txt"
-
-def rootfs_get_size(d):
- import subprocess
-
- # Calculate size of rootfs in kilobytes...
- output = subprocess.check_output(['du', '-ks',
- d.getVar('IMAGE_ROOTFS', True)])
- return int(output.split()[0])
-
-def rootfs_tezi_emmc(d):
- import subprocess
- from collections import OrderedDict
- deploydir = d.getVar('DEPLOY_DIR_IMAGE', True)
- kernel = d.getVar('KERNEL_IMAGETYPE', True)
- offset_bootrom = d.getVar('OFFSET_BOOTROM_PAYLOAD', True)
- offset_spl = d.getVar('OFFSET_SPL_PAYLOAD', True)
- imagename = d.getVar('IMAGE_NAME', True)
- imagename_suffix = d.getVar('IMAGE_NAME_SUFFIX', True)
-
- # Calculate size of bootfs...
- bootfiles = [ os.path.join(deploydir, kernel) ]
- has_devicetree = d.getVar('KERNEL_DEVICETREE', True)
- if has_devicetree:
- for dtb in d.getVar('KERNEL_DEVICETREE', True).split():
- bootfiles.append(os.path.join(deploydir, dtb))
-
- args = ['du', '-kLc']
- args.extend(bootfiles)
- output = subprocess.check_output(args)
- bootfssize_kb = int(output.splitlines()[-1].split()[0])
-
- bootpart_rawfiles = []
-
- has_spl = d.getVar('SPL_BINARY', True)
- if has_spl:
- bootpart_rawfiles.append(
- {
- "filename": d.getVar('SPL_BINARY', True),
- "dd_options": "seek=" + offset_bootrom
- })
- bootpart_rawfiles.append(
- {
- "filename": d.getVar('UBOOT_BINARY_TEZI', True),
- "dd_options": "seek=" + (offset_spl if has_spl else offset_bootrom)
- })
-
- return [
- OrderedDict({
- "name": "mmcblk0",
- "partitions": [
- {
- "partition_size_nominal": 16,
- "want_maximised": False,
- "content": {
- "label": "BOOT",
- "filesystem_type": "FAT",
- "mkfs_options": "",
- "filename": imagename + ".bootfs.tar.xz",
- "uncompressed_size": bootfssize_kb / 1024
- }
- },
- {
- "partition_size_nominal": 512,
- "want_maximised": True,
- "content": {
- "label": "RFS",
- "filesystem_type": d.getVar('TEZI_ROOT_FSTYPE', True),
- "mkfs_options": "-E nodiscard",
- "filename": imagename + imagename_suffix + ".tar.xz",
- "uncompressed_size": rootfs_get_size(d) / 1024
- }
- }
- ]
- }),
- OrderedDict({
- "name": "mmcblk0boot0",
- "content": {
- "filesystem_type": "raw",
- "rawfiles": bootpart_rawfiles
- }
- })]
-
-
-def rootfs_tezi_rawnand(d):
- from collections import OrderedDict
- imagename = d.getVar('IMAGE_NAME', True)
- imagename_suffix = d.getVar('IMAGE_NAME_SUFFIX', True)
-
- # Use device tree mapping to create product id <-> device tree relationship
- dtmapping = d.getVarFlags('TORADEX_PRODUCT_IDS')
- dtfiles = []
- for f, v in dtmapping.items():
- dtfiles.append({ "filename": v, "product_ids": f })
-
- return [
- OrderedDict({
- "name": "u-boot1",
- "content": {
- "rawfile": {
- "filename": d.getVar('UBOOT_BINARY_TEZI', True),
- "size": 1
- }
- },
- }),
- OrderedDict({
- "name": "u-boot2",
- "content": {
- "rawfile": {
- "filename": d.getVar('UBOOT_BINARY_TEZI', True),
- "size": 1
- }
- }
- }),
- OrderedDict({
- "name": "ubi",
- "ubivolumes": [
- {
- "name": "kernel",
- "size_kib": 8192,
- "type": "static",
- "content": {
- "rawfile": {
- "filename": d.getVar('KERNEL_IMAGETYPE', True),
- "size": 5
- }
- }
- },
- {
- "name": "dtb",
- "content": {
- "rawfiles": dtfiles
- },
- "size_kib": 128,
- "type": "static"
- },
- {
- "name": "m4firmware",
- "size_kib": 896,
- "type": "static"
- },
- {
- "name": "rootfs",
- "content": {
- "filesystem_type": "ubifs",
- "filename": imagename + imagename_suffix + ".tar.xz",
- "uncompressed_size": rootfs_get_size(d) / 1024
- }
- }
- ]
- })]
-
-python rootfs_tezi_json() {
- import json
- from collections import OrderedDict
- from datetime import datetime
-
- deploydir = d.getVar('DEPLOY_DIR_IMAGE', True)
- # patched in IMAGE_CMD_teziimg() below
- release_date = "%release_date%"
-
- data = OrderedDict({ "config_format": 2, "autoinstall": False })
-
- # Use image recipes SUMMARY/DESCRIPTION/PV...
- data["name"] = d.getVar('SUMMARY', True)
- data["description"] = d.getVar('DESCRIPTION', True)
- data["version"] = d.getVar('PV', True)
- data["release_date"] = release_date
- data["u_boot_env"] = d.getVar('UBOOT_ENV_TEZI', True)
- if os.path.exists(os.path.join(deploydir, "prepare.sh")):
- data["prepare_script"] = "prepare.sh"
- if os.path.exists(os.path.join(deploydir, "wrapup.sh")):
- data["wrapup_script"] = "wrapup.sh"
- if os.path.exists(os.path.join(deploydir, "marketing.tar")):
- data["marketing"] = "marketing.tar"
- if os.path.exists(os.path.join(deploydir, "toradexlinux.png")):
- data["icon"] = "toradexlinux.png"
-
- product_ids = d.getVar('TORADEX_PRODUCT_IDS', True)
- if product_ids is None:
- bb.fatal("Supported Toradex product ids missing, assign TORADEX_PRODUCT_IDS with a list of product ids.")
-
- data["supported_product_ids"] = d.getVar('TORADEX_PRODUCT_IDS', True).split()
-
- if bb.utils.contains("TORADEX_FLASH_TYPE", "rawnand", True, False, d):
- data["mtddevs"] = rootfs_tezi_rawnand(d)
- else:
- data["blockdevs"] = rootfs_tezi_emmc(d)
-
- deploy_dir = d.getVar('DEPLOY_DIR_IMAGE', True)
- with open(os.path.join(deploy_dir, 'image.json'), 'w') as outfile:
- json.dump(data, outfile, indent=4)
- bb.note("Toradex Easy Installer metadata file image.json written.")
-}
-
-do_image_teziimg[prefuncs] += "rootfs_tezi_json"
-
-IMAGE_CMD_teziimg () {
- bbnote "Create bootfs tarball"
-
- # Fixup release_date in image.json, convert ${DATE} to isoformat
- # This works around the non fatal ERRORS: "the basehash value changed" when DATE is referenced
- # in a python prefunction to do_image
- ISODATE=`echo ${DATE} | sed 's/\(....\)\(..\)\(..\)/\1-\2-\3/'`
- sed -i "s/%release_date%/$ISODATE/" ${DEPLOY_DIR_IMAGE}/image.json
-
- # Create list of device tree files
- if test -n "${KERNEL_DEVICETREE}"; then
- for DTS_FILE in ${KERNEL_DEVICETREE}; do
- DTS_BASE_NAME=`basename ${DTS_FILE} .dtb`
- if [ -e "${DEPLOY_DIR_IMAGE}/${DTS_BASE_NAME}.dtb" ]; then
- KERNEL_DEVICETREE_FILES="${KERNEL_DEVICETREE_FILES} ${DTS_BASE_NAME}.dtb"
- else
- bbfatal "${DTS_FILE} does not exist."
- fi
- done
- fi
-
- cd ${DEPLOY_DIR_IMAGE}
-
- case "${TORADEX_FLASH_TYPE}" in
- rawnand)
- # The first transform strips all folders from the files to tar, the
- # second transform "moves" them in a subfolder ${IMAGE_NAME}_${PV}.
- # The third transform removes zImage from the device tree.
- ${IMAGE_CMD_TAR} --transform='s/.*\///' --transform 's,^,${IMAGE_NAME}-Tezi_${PV}/,' -chf ${IMGDEPLOYDIR}/${IMAGE_NAME}-Tezi_${PV}${TDX_VERDATE}.tar image.json toradexlinux.png marketing.tar prepare.sh wrapup.sh ${SPL_BINARY} ${UBOOT_BINARY_TEZI} ${UBOOT_ENV_TEZI} ${KERNEL_IMAGETYPE} ${KERNEL_DEVICETREE_FILES} ${IMGDEPLOYDIR}/${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.tar.xz
- ;;
- *)
- # Create bootfs...
- ${IMAGE_CMD_TAR} --transform="flags=r;s|${KERNEL_IMAGETYPE}-||" -chf ${IMGDEPLOYDIR}/${IMAGE_NAME}.bootfs.tar -C ${DEPLOY_DIR_IMAGE} ${KERNEL_IMAGETYPE} ${KERNEL_DEVICETREE_FILES}
- xz -f -k -c ${XZ_COMPRESSION_LEVEL} ${XZ_THREADS} --check=${XZ_INTEGRITY_CHECK} ${IMGDEPLOYDIR}/${IMAGE_NAME}.bootfs.tar > ${IMGDEPLOYDIR}/${IMAGE_NAME}.bootfs.tar.xz
-
- # The first transform strips all folders from the files to tar, the
- # second transform "moves" them in a subfolder ${IMAGE_NAME}-Tezi_${PV}.
- ${IMAGE_CMD_TAR} --transform='s/.*\///' --transform 's,^,${IMAGE_NAME}-Tezi_${PV}/,' -chf ${IMGDEPLOYDIR}/${IMAGE_NAME}-Tezi_${PV}${TDX_VERDATE}.tar image.json toradexlinux.png marketing.tar prepare.sh wrapup.sh ${SPL_BINARY} ${UBOOT_BINARY_TEZI} ${UBOOT_ENV_TEZI} ${IMGDEPLOYDIR}/${IMAGE_NAME}.bootfs.tar.xz ${IMGDEPLOYDIR}/${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.tar.xz
- ;;
- esac
-}
-
-IMAGE_TYPEDEP_teziimg += "tar.xz"
diff --git a/meta-toradex-extras/conf/layer.conf b/meta-toradex-extras/conf/layer.conf
deleted file mode 100644
index c1c4900b..00000000
--- a/meta-toradex-extras/conf/layer.conf
+++ /dev/null
@@ -1,46 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2017 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-# We have a conf and classes directory, append to BBPATH
-BBPATH .= ":${LAYERDIR}"
-
-# We have a recipes directory, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
- ${LAYERDIR}/recipes*/*/*.bbappend \
- "
-
-BBFILE_COLLECTIONS += "b2qt_toradex"
-BBFILE_PATTERN_b2qt_toradex := "^${LAYERDIR}/"
-BBFILE_PRIORITY_b2qt_toradex = "20"
-
-LAYERSERIES_COMPAT_b2qt_toradex = "warrior"
-
-# override toradex layer COMPATs
-LAYERSERIES_COMPAT_toradex-bsp-common-layer = "warrior"
-LAYERSERIES_COMPAT_toradex-nxp-layer = "warrior"
diff --git a/meta-toradex-extras/recipes-bsp/tezi-metadata/files/Built_with_Qt.png b/meta-toradex-extras/recipes-bsp/tezi-metadata/files/Built_with_Qt.png
deleted file mode 100644
index 15f05686..00000000
--- a/meta-toradex-extras/recipes-bsp/tezi-metadata/files/Built_with_Qt.png
+++ /dev/null
Binary files differ
diff --git a/meta-toradex-extras/recipes-bsp/tezi-metadata/files/TEZI_B2QT_EULA.TXT b/meta-toradex-extras/recipes-bsp/tezi-metadata/files/TEZI_B2QT_EULA.TXT
deleted file mode 100644
index 750ad525..00000000
--- a/meta-toradex-extras/recipes-bsp/tezi-metadata/files/TEZI_B2QT_EULA.TXT
+++ /dev/null
@@ -1,75 +0,0 @@
-1. QT DEMO IMAGE END USER LICENSE AGREEMENT
-
-This Qt Demo Image End User License Agreement ("Agreement") is a legal agreement between The Qt Company Ltd ("The Qt Company") with its registered office at Bertel Jungin aukio D3A, 02600 Espoo, Finland and You (either an individual or a legal entity) ("Licensee") for the Licensed Software.
-For the purpose of this Agreement Licensed Software shall mean a Qt Demo Image (Boot to Qt software stack) (i) containing demos to highlight the Qt capability on the target hardware for evaluation and demonstration proposes and (ii) supporting deployment of Qt application from Qt Creator.
-Please, read these license terms through carefully. By downloading the Licensed Software, you are deemed to accept these license terms and to commit yourself to observing them. When representing a legal entity, you should ensure your due authorization to approve these terms before such acceptance. Otherwise, we hold you as personally responsible for compliance with this Agreement.
-Under this Agreement, The Qt Company grants the Licensee a license to use Licensed Software solely for the purpose of Licensee's internal testing and evaluation of a Qt Demo Image (Boot to Qt software stack) ("Purpose") for a period of 60 days following the download of the Licensed Software ("Term").
-
-1. OWNERSHIP
-
-The Licensed Software is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. The Licensed Software is licensed, not sold.
-All The Qt Company's and/or its licensors' trademarks, service marks, trade names, logos or other words or symbols are and shall remain the exclusive property of The Qt Company or its licensors respectively.
-
-2. LICENSE GRANTED
-
-The Qt Company grants to Licensee a personal, non-exclusive, revocable, non-transferable, free-of-charge license to use the Licensed Software solely for the Purpose during the Term.
-The license granted above in this Section 2 by The Qt Company to Licensee are conditional and subject to Licensee's compliance with the following terms:
-(i) Licensee shall not remove or alter any copyright, trademark or other proprietary rights notice contained in any portion of the Licensed Software;
-(ii) Licensee shall not
-- alter, modify (including creating derivative works), translate or adapt the Licensed Software;
-- reverse engineer, reverse assemble, reverse translate, decompile or reduce to source code form any portion of the Licensed Software; or
-- transfer, publish, disclose, display or otherwise make the Licensed Software available to any third party.
-Any use of Licensed Software beyond the provisions of this Agreement is strictly prohibited and requires an additional license from The Qt Company.
-
-3. WARRANTY DISCLAIMER
-
-LICENSED SOFTWARE IS LICENSED TO LICENSEE "AS IS". TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, THE QT COMPANY ON BEHALF OF ITSELF AND ITS SUPPLIERS, DISCLAIMS ALL WARRANTIES AND CONDITIONS, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT REGARDING TO THE LICENSED SOFTWARE.
-
-4. LIMITATION OF LIABILITY
-
-IN NO EVENT SHALL THE QT COMPANY OR ANY OF ITS AFFILIATES OR THEIR RESPECTIVE LICENSORS BE LIABLE TO LICENSEE FOR ANY INCIDENTAL, CONSEQUENTIAL OR SPECIAL DAMAGES, INCLUDING BUT NOT LIMITED TO ANY LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL DAMAGES, ARISING OUT OF THE USE OR INABILITY TO USE THE LICENSED SOFTWARE, OR ANY BREACH OF ANY OBLIGATION UNDER THIS AGREEMENT. THE FOREGOING LIMITATION OF LIABILITY SHALL REMAIN IN FULL FORCE AND EFFECT REGARDLESS OF WHETHER LICENSEE'S REMEDIES HEREUNDER ARE DETERMINED TO HAVE FAILED OF THEIR ESSENTIAL PURPOSE. THE ENTIRE LIABILITY OF THE QT COMPANY AND THE SOLE AND EXCLUSIVE REMEDY OF LICENSEE, FOR ANY CLAIM OR CAUSE OF ACTION ARISING HEREUNDER (WHETHER IN CONTRACT, TORT, OR OTHERWISE) SHALL NOT EXCEED ONE THOUSAND (1,000) EUROS.
-
-5. CONFIDENTIALITY
-
-Licensee acknowledges and agrees that the Licensed Software contains trade secrets of The Qt Company, its affiliates and/or their respective Licensors and are confidential and proprietary information of the same. Licensee undertakes to keep the Licensed Software strictly confidential and shall not disclose any such information to any third party without the prior written consent of The Qt Company. Licensee shall limit the use and disclosure of the Licensed Software within its organization to the extent necessary for the Purpose, and shall ensure that any of its employees, to whom it gives access hereunder shall comply with the obligations of confidentiality set forth in this Agreement. The Parties acknowledge and agree that monetary damages may not be a sufficient remedy for unauthorized disclosure of The Qt Company's confidential information and that The Qt Company shall be entitled, without waiving any other rights or remedies, to injunctive or equitable relief as may be deemed proper by a court of competent jurisdiction.
-
-6. GENERAL PROVISIONS
-
-6.1 No Assignment
-
-Licensee shall not be entitled to assign or transfer all or any of its rights, benefits and obligations under this Agreement without the prior written consent of The Qt Company, which shall not be unreasonably withheld. The Qt Company shall be entitled to assign or transfer any of its rights, benefits or obligations under this Agreement on an unrestricted basis.
-
-6.2 Term and Termination
-
-This Agreement, and any and all rights of the Licensee thereunder, shall automatically expire three (3) months after the first download of the Licensed Software by the Licensee.
-The Qt Company may terminate the Agreement at any time immediately upon written notice by The Qt Company to Licensee if Licensee breaches this Agreement.
-Either party shall have the right to terminate this Agreement immediately upon written notice in the event that the other party becomes insolvent, files for any form of bankruptcy, makes any assignment for the benefit of creditors, has a receiver, administrative receiver or officer appointed over the whole or a substantial part of its assets, ceases to conduct business, or an act equivalent to any of the above occurs under the laws of the jurisdiction of the other party.
-Upon termination of the Agreement, Licensee shall cease using the Licensed Software. All other copies of Licensed Software in the possession or control of Licensee must be erased or destroyed. An officer of Licensee must, upon request, promptly deliver to The Qt Company a written confirmation that this has occurred.
-
-6.3 Surviving Sections
-
-Any terms and conditions that by their nature or otherwise reasonably should survive a cancellation or termination of this Agreement shall also be deemed to survive. Such surviving terms and conditions include, but are not limited to the Section 5.
-
-6.4 Entire Agreement
-
-This Agreement constitutes the complete agreement between the parties and supersedes all prior or contemporaneous discussions, representations, and proposals, written or oral, with respect to the subject matters discussed herein. No modification of this Agreement shall be effective unless contained in a writing executed by an authorized representative of each party. If any provision of the Agreement is found void or unenforceable, the remainder shall remain valid and enforceable according to its terms.
-
-6.5 Notices
-
-Any notice given by one party to the other shall be deemed properly given and deemed received if specifically acknowledged by the receiving party in writing or when successfully delivered to the recipient by hand, fax, or special courier during normal business hours on a business day to the addresses specified below. Each communication and document made or delivered by one party to the other party pursuant to this Agreement shall be in the English language or accompanied by a translation thereof.
-
-Notices to The Qt Company shall be given to:
-The Qt Company Ltd
-Attn: Legal
-Bertel Jungin Aukio D3A
-FI-02600 Espoo
-Finland
-Fax: +358 10 313 3700
-
-6.6 Governing Law and Legal Venue
-
-This Agreement shall be construed and interpreted in accordance with the laws of Finland, excluding its choice of law provisions. Any disputes, controversy or claim arising out of or relating to this Agreement, or the breach, termination or validity thereof shall be shall be finally settled by arbitration in accordance with the Arbitration Rules of the Finland Chamber of Commerce . The arbitration tribunal shall consist of one (1), or if either Party so requires, of three (3), arbitrators. The award shall be final and binding and enforceable in any court of competent jurisdiction. The arbitration shall be held in Helsinki, Finland and the process shall be conducted in the English language. Notwithstanding the above, the Parties shall also be entitled to seek injunctive or other interim relief in relation to a breach of this Agreement in general courts.
-
-6.7 No Implied License
-
-There are no implied licenses or other implied rights granted under this Agreement, and all rights, save for those expressly granted hereunder, shall remain with The Qt Company and its licensors.
diff --git a/meta-toradex-extras/recipes-bsp/tezi-metadata/tezi-metadata_%.bbappend b/meta-toradex-extras/recipes-bsp/tezi-metadata/tezi-metadata_%.bbappend
deleted file mode 100644
index 3f7d7962..00000000
--- a/meta-toradex-extras/recipes-bsp/tezi-metadata/tezi-metadata_%.bbappend
+++ /dev/null
@@ -1,44 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2018 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-SRC_URI += "\
- file://TEZI_B2QT_EULA.TXT \
- file://Built_with_Qt.png \
- https://qt-files.s3.amazonaws.com/examples/tezi-marketing-20180905.tar;unpack=false;downloadfilename=marketing.tar \
- "
-
-SRC_URI[md5sum] = "281877560900c6481eee019a923f5e28"
-SRC_URI[sha256sum] = "36c31c812e6d6223f46f2a32cad37f46060a7c05420a4ba491cbea6193039eee"
-
-do_deploy_append () {
- install -m 644 ${WORKDIR}/TEZI_B2QT_EULA.TXT ${DEPLOYDIR}
- install -m 644 ${WORKDIR}/Built_with_Qt.png ${DEPLOYDIR}
-}
diff --git a/meta-toradex-extras/recipes-core/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch b/meta-toradex-extras/recipes-core/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch
deleted file mode 100644
index ef7e541d..00000000
--- a/meta-toradex-extras/recipes-core/systemd/systemd/0001-systemd-udevd.service.in-set-MountFlags-shared.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 2a9d175360f1ed3ef85e336a329a9e803226096e Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.oss.09@gmail.com>
-Date: Thu, 29 Oct 2015 19:38:50 +0100
-Subject: [PATCH] systemd-udevd.service.in: set MountFlags=shared
-
-This allows for udevd automounting of drives accessible to all.
----
- units/systemd-udevd.service.in | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/units/systemd-udevd.service.in b/units/systemd-udevd.service.in
-index 6a3814e5d9..e3f3ad3293 100644
---- a/units/systemd-udevd.service.in
-+++ b/units/systemd-udevd.service.in
-@@ -25,7 +25,6 @@ ExecStart=@rootlibexecdir@/systemd-udevd
- KillMode=mixed
- WatchdogSec=3min
- TasksMax=infinity
--PrivateMounts=yes
- MemoryDenyWriteExecute=yes
- RestrictRealtime=yes
- RestrictAddressFamilies=AF_UNIX AF_NETLINK AF_INET AF_INET6
diff --git a/meta-toradex-extras/recipes-core/systemd/systemd_%.bbappend b/meta-toradex-extras/recipes-core/systemd/systemd_%.bbappend
deleted file mode 100644
index 52e23dc7..00000000
--- a/meta-toradex-extras/recipes-core/systemd/systemd_%.bbappend
+++ /dev/null
@@ -1,33 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2019 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI += " \
- file://0001-systemd-udevd.service.in-set-MountFlags-shared.patch \
-"
diff --git a/meta-toradex-extras/recipes-kernel/linux/linux-toradex/0001-Enable-atmel-mxt-multitouch-controller.patch b/meta-toradex-extras/recipes-kernel/linux/linux-toradex/0001-Enable-atmel-mxt-multitouch-controller.patch
deleted file mode 100644
index 1f63fee0..00000000
--- a/meta-toradex-extras/recipes-kernel/linux/linux-toradex/0001-Enable-atmel-mxt-multitouch-controller.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 823475bf681e1dbb4ad8e43935232ae39b918d9c Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Fri, 6 Oct 2017 15:54:35 +0300
-Subject: [PATCH] Enable atmel mxt multitouch controller for ixora v1.1 dtb
-
-Need to disable fusion touch to get the new atmel mxt multitouch
-controller to work.
----
- arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi b/arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi
-index 26525e24a6c7..78a1011c1ea2 100644
---- a/arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi
-+++ b/arch/arm/boot/dts/imx6qdl-apalis-ixora-v1.1.dtsi
-@@ -160,7 +160,7 @@
- interrupt-parent = <&gpio6>;
- interrupts = <10 IRQ_TYPE_EDGE_FALLING>;
- reset-gpios = <&gpio6 9 GPIO_ACTIVE_HIGH>; /* SODIMM 13 */
-- status = "disabled";
-+ status = "okay";
- };
-
- pcap@10 {
-@@ -170,6 +170,7 @@
- gpios = <&gpio6 10 GPIO_ACTIVE_HIGH /* MXM3 11, Pen down interrupt */
- &gpio6 9 GPIO_ACTIVE_HIGH /* MXM3 13, Reset */
- >;
-+ status = "disabled";
- };
-
- /* M41T0M6 real time clock on carrier board */
diff --git a/meta-toradex-extras/recipes-kernel/linux/linux-toradex_4.9-2.3.x.bbappend b/meta-toradex-extras/recipes-kernel/linux/linux-toradex_4.9-2.3.x.bbappend
deleted file mode 100644
index eadfa154..00000000
--- a/meta-toradex-extras/recipes-kernel/linux/linux-toradex_4.9-2.3.x.bbappend
+++ /dev/null
@@ -1,32 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2017 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://0001-Enable-atmel-mxt-multitouch-controller.patch"