aboutsummaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-24 14:26:30 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-25 08:17:18 +0000
commita38939e7a86f835f101efacf4db7967bb4b489be (patch)
tree7864355dc45ce234c5cf481f92a281627ae4e0fc /meta-toradex-extras
parent9836c267a651a037e6e1d8991b9c71332ee33d7d (diff)
toradex: enable u-boot update
Add all necessary files to enable u-boot update on all toradex devices. Update patch to the new u-boot that colibri vf is using and enable sd boot for colibri imx6. Task-number: QTEE-1070 Task-number: QTEE-978 Change-Id: I6ff362028cfb80cd34bbe5362bb6976d0084e008 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
Diffstat (limited to 'meta-toradex-extras')
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb4
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr2
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-imx6-enable-sdboot-by-default.patch36
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch35
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend6
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch25
-rw-r--r--meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend25
7 files changed, 92 insertions, 41 deletions
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
index 3d63f6be..337d57d3 100644
--- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex.bb
@@ -29,6 +29,8 @@ SRC_URI = " \
file://flash_blk.scr \
"
+S = "${WORKDIR}"
+
inherit deploy
do_mkimage () {
@@ -62,4 +64,4 @@ do_install[noexec] = "1"
do_populate_sysroot[noexec] = "1"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "(apalis-imx6|colibri-vf)"
+COMPATIBLE_MACHINE = "(apalis-imx6|colibri-vf|colibri-imx6)"
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr
index 5e313804..be8ec8d9 100644
--- a/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-script-toradex/vf/flash_blk.scr
@@ -1,2 +1,2 @@
-setenv update_uboot 'fatload ${interface} 0:1 ${loadaddr} u-boot-nand.imx && nand erase.part u-boot && nand erase.part u-boot-env && nand write ${loadaddr} u-boot'
+setenv update_uboot 'fatload ${interface} 0:1 ${loadaddr} u-boot.imx && nand erase.part u-boot && nand erase.part u-boot-env && nand write ${loadaddr} u-boot'
echo 'enter "run update_uboot" to update the uboot'
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-imx6-enable-sdboot-by-default.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-imx6-enable-sdboot-by-default.patch
new file mode 100644
index 00000000..07431286
--- /dev/null
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-imx6-enable-sdboot-by-default.patch
@@ -0,0 +1,36 @@
+From 10ebeba59e6fd25352aa44ecd85913126ec45afe Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@theqtcompany.com>
+Date: Wed, 24 Feb 2016 15:39:52 +0200
+Subject: [PATCH] colibri imx6: enable sdboot by default
+
+remove console from tty1
+---
+ include/configs/colibri_imx6.h | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/include/configs/colibri_imx6.h b/include/configs/colibri_imx6.h
+index c545334..eb0dfa9 100644
+--- a/include/configs/colibri_imx6.h
++++ b/include/configs/colibri_imx6.h
+@@ -242,7 +242,8 @@
+
+ #define FDT_FILE "imx6dl-colibri-eval-v3.dtb"
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+- "bootcmd=run emmcboot ; echo ; echo emmcboot failed ; " \
++ "bootcmd=run sdboot ; echo ; echo sdboot failed ; " \
++ "run emmcboot ; echo ; echo emmcboot failed ; " \
+ "run nfsboot ; echo ; echo nfsboot failed ; " \
+ "usb start ;" \
+ "setenv stdout serial,vga ; setenv stdin serial,usbkbd\0" \
+@@ -261,7 +262,7 @@
+ "setsdupdate=setenv interface mmc; setenv drive 1; mmc rescan; " \
+ "load ${interface} ${drive}:1 ${kernel_addr_r} flash_blk.img\0" \
+ "setup=setenv setupargs fec_mac=${ethaddr} " \
+- "consoleblank=0 no_console_suspend=1 console=tty1 " \
++ "consoleblank=0 no_console_suspend=1 " \
+ "console=${console},${baudrate}n8\0 " \
+ "setupdate=run setsdupdate || run setusbupdate || run setethupdate;" \
+ " source ${kernel_addr_r}\0" \
+--
+1.9.1
+
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch
deleted file mode 100644
index bae71d58..00000000
--- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-colibri-vf-enable-sdboot-by-default.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 878f506e43f40c2667e9e5ae82741d32fc653cac Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@theqtcompany.com>
-Date: Thu, 28 May 2015 09:06:54 +0300
-Subject: [PATCH] colibri vf: enable sdboot by default
-
-Run sdboot first and remove console message from tty1
----
- include/configs/colibri_vf.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h
-index 06caabd..fb9fe41 100644
---- a/include/configs/colibri_vf.h
-+++ b/include/configs/colibri_vf.h
-@@ -174,7 +174,7 @@
- "ubifsload ${fdt_addr_r} /boot/${soc}-colibri-${fdt_board}.dtb && " \
- "bootz ${kernel_addr_r} - ${fdt_addr_r}\0" \
-
--#define CONFIG_BOOTCOMMAND "run ubiboot; run sdboot; run nfsboot"
-+#define CONFIG_BOOTCOMMAND "run sdboot; run ubiboot; run nfsboot"
-
- #define DFU_ALT_NAND_INFO "vf-bcb part 0,1;u-boot part 0,2;ubi part 0,4"
-
-@@ -187,7 +187,7 @@
- "defargs=\0" \
- "console=ttyLP0\0" \
- "setup=setenv setupargs " \
-- "console=tty1 console=${console}" \
-+ "console=${console}" \
- ",${baudrate}n8 ${memargs} consoleblank=0\0" \
- "setsdupdate=mmc rescan && setenv interface mmc && " \
- "fatload ${interface} 0:1 ${loadaddr} flash_blk.img && " \
---
-1.9.1
-
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend
index 905619ac..1165713d 100644
--- a/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl_git.bbappend
@@ -20,9 +20,7 @@
##############################################################################
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI_append_apalis-imx6 = " \
+SRC_URI += " \
file://0001-Update-default-args-for-apalis-imx6.patch \
- "
-SRC_URI_append_colibri-vf = " \
- file://0001-colibri-vf-enable-sdboot-by-default.patch \
+ file://0001-colibri-imx6-enable-sdboot-by-default.patch \
"
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch b/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch
new file mode 100644
index 00000000..b54a4ae0
--- /dev/null
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex/0001-colibri-vf-remove-console-from-tty1.patch
@@ -0,0 +1,25 @@
+From f480a948551b0e5592d93cb7a5dc1653de900909 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@theqtcompany.com>
+Date: Wed, 24 Feb 2016 16:01:33 +0200
+Subject: [PATCH] colibri vf: remove console from tty1
+
+---
+ include/configs/colibri_vf.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/configs/colibri_vf.h b/include/configs/colibri_vf.h
+index b870812..0726fc5 100644
+--- a/include/configs/colibri_vf.h
++++ b/include/configs/colibri_vf.h
+@@ -202,7 +202,7 @@
+ "fatload ${interface} 0:1 ${loadaddr} flash_blk.img && " \
+ "source ${loadaddr}\0" \
+ "setup=setenv setupargs " \
+- "console=tty1 console=${console}" \
++ "console=${console}" \
+ ",${baudrate}n8 ${memargs} consoleblank=0\0" \
+ "setupdate=run setsdupdate || run setusbupdate || run setethupdate\0" \
+ "setusbupdate=usb start && setenv interface usb && " \
+--
+1.9.1
+
diff --git a/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend b/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
new file mode 100644
index 00000000..4e0c623c
--- /dev/null
+++ b/meta-toradex-extras/recipes/u-boot/u-boot-toradex_2015.04.bbappend
@@ -0,0 +1,25 @@
+##############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: http://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:COMM$
+##
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see http://www.qt.io/terms-conditions. For further
+## information use the contact form at http://www.qt.io/contact-us.
+##
+## $QT_END_LICENSE$
+##
+##############################################################################
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI += " \
+ file://0001-colibri-vf-remove-console-from-tty1.patch \
+ "