aboutsummaryrefslogtreecommitdiffstats
path: root/meta-toradex-extras
diff options
context:
space:
mode:
authorTeemu Holappa <teemu.holappa@theqtcompany.com>2016-08-17 11:20:46 +0300
committerTeemu Holappa <teemu.holappa@theqtcompany.com>2016-08-17 12:20:18 +0000
commitffdd18178f9016c5e556f6b70ab70ba66956807e (patch)
tree07c70366eaec2c5237f50cdfdab46978a453455d /meta-toradex-extras
parent10c9d074e0b3a00ef45d0764c7283fe2cdade101 (diff)
Fix adb to toradex-imx6 imagev5.7.0
Enabled functionfs module in toradex-imx6 configuration. Change-Id: I2ff2de89bfa25cd6f40da700f96360e2cc13f1e7 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'meta-toradex-extras')
-rw-r--r--meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend b/meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend
new file mode 100644
index 00000000..b696b19a
--- /dev/null
+++ b/meta-toradex-extras/recipes/linux/linux-toradex_3.14.%.bbappend
@@ -0,0 +1,37 @@
+############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+# kernel image files are not needed in the image
+RDEPENDS_kernel-base = ""
+
+do_configure_prepend () {
+ # FunctionFS for adb
+ echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
+ echo "CONFIG_USB_ACM=m" >> ${WORKDIR}/defconfig
+}