aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-boot2qt-distro/conf/distro/include/jetson.inc9
-rw-r--r--meta-tegra-extras/recipes/drm/libdrm_%.bbappend15
-rw-r--r--meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend4
-rw-r--r--meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend37
-rw-r--r--scripts/manifest.xml2
5 files changed, 3 insertions, 64 deletions
diff --git a/meta-boot2qt-distro/conf/distro/include/jetson.inc b/meta-boot2qt-distro/conf/distro/include/jetson.inc
index e3e02929..3212cb96 100644
--- a/meta-boot2qt-distro/conf/distro/include/jetson.inc
+++ b/meta-boot2qt-distro/conf/distro/include/jetson.inc
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2017 The Qt Company Ltd.
+## Copyright (C) 2018 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -27,8 +27,6 @@
##
############################################################################
-PREFERRED_PROVIDER_libdrm-tegra = "libdrm-tegra"
-
# use mmc0
ROOTFS_DEVICE = "mmcblk1p1"
@@ -43,8 +41,3 @@ QBSP_IMAGE_CONTENT = "\
${IMAGE_LINK_NAME}.conf \
${IMAGE_LINK_NAME}.flasher.tar.gz \
"
-
-BBMASK += "\
- meta-tegra/recipes-graphics/drm \
- meta-tegra/external/openembedded-layer/recipes-support/opencv \
- "
diff --git a/meta-tegra-extras/recipes/drm/libdrm_%.bbappend b/meta-tegra-extras/recipes/drm/libdrm_%.bbappend
deleted file mode 100644
index bf4cc080..00000000
--- a/meta-tegra-extras/recipes/drm/libdrm_%.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
-inherit update-alternatives
-
-do_install_append() {
- mv ${D}${libdir}/libdrm.so.2.4.0 ${D}${libdir}/libdrm-freedesktop.so.2.4.0
- rm ${D}${libdir}/libdrm.so
- rm ${D}${libdir}/libdrm.so.2
- ln -sf libdrm-freedesktop.so.2.4.0 ${D}${libdir}/libdrm.so
- ln -sf libdrm-freedesktop.so.2.4.0 ${D}${libdir}/libdrm.so.2
-}
-
-ALTERNATIVE_${PN} = "libdrm.so.2.4.0 libdrm.so.2"
-ALTERNATIVE_LINK_NAME[libdrm.so.2.4.0] = "${libdir}/libdrm.so.2.4.0"
-ALTERNATIVE_LINK_NAME[libdrm.so.2] = "${libdir}/libdrm.so.2"
-ALTERNATIVE_TARGET = "${libdir}/libdrm-freedesktop.so.2.4.0"
-ALTERNATIVE_PRIORITY = "20"
diff --git a/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend b/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend
index d3c48035..14506228 100644
--- a/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend
+++ b/meta-tegra-extras/recipes/linux/linux-tegra_%.bbappend
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2017 The Qt Company Ltd.
+## Copyright (C) 2018 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -31,5 +31,3 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "\
file://0001-fbcon-Compare-variable-screen-info-instead-of-modes-.patch \
"
-
-require recipes-kernel/linux/linux-dtb.inc
diff --git a/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend b/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend
deleted file mode 100644
index 84a817ce..00000000
--- a/meta-tegra-extras/recipes/tegra-binaries/tegra-libraries_%.bbappend
+++ /dev/null
@@ -1,37 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2017 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-PACKAGES += "${PN}-dev"
-RRECOMMENDS_${PN}-dev += "\
- libgles1-mesa-dev \
- libgles2-mesa-dev \
- libgles3-mesa-dev \
- libegl-mesa-dev \
- libgl-mesa-dev \
- "
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 0c9155bb..4dfeec16 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -55,7 +55,7 @@
groups="notdefault,external,intel"/>
<project name="meta-tegra"
remote="madisongh"
- revision="4aea5e3785dc400e31981467f475b54e652dbd67"
+ revision="6b6942c8dd15c2b4a460d46e803b962663955fde"
path="sources/meta-tegra"
groups="notdefault,external,jetson"/>
<project name="meta-renesas"