aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt-distro/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt-distro/recipes-devtools')
-rw-r--r--meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend5
-rw-r--r--meta-boot2qt-distro/recipes-devtools/qemu/qemu/0001-linux-user-add-support-for-MADV_DONTNEED.patch62
-rw-r--r--meta-boot2qt-distro/recipes-devtools/qemu/qemu_%.bbappend33
3 files changed, 0 insertions, 100 deletions
diff --git a/meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend b/meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend
index 1f16b509..257f92db 100644
--- a/meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend
+++ b/meta-boot2qt-distro/recipes-devtools/gcc/gcc-cross-canadian_%.bbappend
@@ -29,11 +29,6 @@
EXTRA_OECONF += "--with-plugin-ld=ld"
-do_install:append () {
- # remove real-ld symlink
- rm ${D}${libexecdir}/gcc/${TARGET_SYS}/${BINV}/real-ld${EXEEXT}
-}
-
do_install:append:sdkmingw32() {
ln -sf ../libwinpthread-1.dll ${D}${bindir}
ln -sf ${BINRELPATH}/libwinpthread-1.dll $dest
diff --git a/meta-boot2qt-distro/recipes-devtools/qemu/qemu/0001-linux-user-add-support-for-MADV_DONTNEED.patch b/meta-boot2qt-distro/recipes-devtools/qemu/qemu/0001-linux-user-add-support-for-MADV_DONTNEED.patch
deleted file mode 100644
index 460cc34d..00000000
--- a/meta-boot2qt-distro/recipes-devtools/qemu/qemu/0001-linux-user-add-support-for-MADV_DONTNEED.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 875bad8cc58ece40ac1b5b38b77a72e3b86d529d Mon Sep 17 00:00:00 2001
-From: Simon Hausmann <simon.hausmann@qt.io>
-Date: Fri, 24 Aug 2018 10:38:29 +0200
-Subject: [PATCH] linux-user: add support for MADV_DONTNEED
-
-Most flags to madvise() are just hints, so typically ignoring the
-syscall and returning okay is fine. However applications exist that do
-rely on MADV_DONTNEED behavior to guarantee that upon subsequent access
-the mapping is refreshed from the backing file or zero for anonymous
-mappings.
----
- linux-user/mmap.c | 13 +++++++++++++
- linux-user/syscall.c | 2 +-
- linux-user/user-mmap.h | 1 +
- 3 files changed, 15 insertions(+), 1 deletion(-)
-
-diff --git a/linux-user/mmap.c b/linux-user/mmap.c
-index e651834..63efa1f 100644
---- a/linux-user/mmap.c
-+++ b/linux-user/mmap.c
-@@ -834,3 +834,16 @@ abi_long target_mremap(abi_ulong old_addr, abi_ulong old_size,
- mmap_unlock();
- return new_addr;
- }
-+
-+int target_madvise(abi_ulong start, abi_ulong len, int flags)
-+{
-+ /* A straight passthrough may not be safe because qemu sometimes
-+ turns private file-backed mappings into anonymous mappings.
-+ Most flags are hints, except for MADV_DONTNEED that applications
-+ may rely on to zero out pages, so we pass that through.
-+ Otherwise returning success is ok. */
-+ if (flags & MADV_DONTNEED) {
-+ return madvise(g2h_untagged(start), len, MADV_DONTNEED);
-+ }
-+ return 0;
-+}
-diff --git a/linux-user/syscall.c b/linux-user/syscall.c
-index 839fc76..e1b7d77 100644
---- a/linux-user/syscall.c
-+++ b/linux-user/syscall.c
-@@ -11780,7 +11780,7 @@ static abi_long do_syscall1(void *cpu_env, int num, abi_long arg1,
- turns private file-backed mappings into anonymous mappings.
- This will break MADV_DONTNEED.
- This is a hint, so ignoring and returning success is ok. */
-- return 0;
-+ return get_errno(target_madvise(arg1, arg2, arg3));
- #endif
- #ifdef TARGET_NR_fcntl64
- case TARGET_NR_fcntl64:
-diff --git a/linux-user/user-mmap.h b/linux-user/user-mmap.h
-index d1dec99..ceb013d 100644
---- a/linux-user/user-mmap.h
-+++ b/linux-user/user-mmap.h
-@@ -25,6 +25,7 @@ int target_munmap(abi_ulong start, abi_ulong len);
- abi_long target_mremap(abi_ulong old_addr, abi_ulong old_size,
- abi_ulong new_size, unsigned long flags,
- abi_ulong new_addr);
-+int target_madvise(abi_ulong start, abi_ulong len, int flags);
- extern unsigned long last_brk;
- extern abi_ulong mmap_next_start;
- abi_ulong mmap_find_vma(abi_ulong, abi_ulong, abi_ulong);
diff --git a/meta-boot2qt-distro/recipes-devtools/qemu/qemu_%.bbappend b/meta-boot2qt-distro/recipes-devtools/qemu/qemu_%.bbappend
deleted file mode 100644
index 878ed5a1..00000000
--- a/meta-boot2qt-distro/recipes-devtools/qemu/qemu_%.bbappend
+++ /dev/null
@@ -1,33 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2020 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
-SRC_URI += " \
- file://0001-linux-user-add-support-for-MADV_DONTNEED.patch \
-"