aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt/recipes-qt/boot2qt-addons/qdb_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt/recipes-qt/boot2qt-addons/qdb_git.bb')
-rw-r--r--meta-boot2qt/recipes-qt/boot2qt-addons/qdb_git.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta-boot2qt/recipes-qt/boot2qt-addons/qdb_git.bb b/meta-boot2qt/recipes-qt/boot2qt-addons/qdb_git.bb
new file mode 100644
index 00000000..5615473b
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/boot2qt-addons/qdb_git.bb
@@ -0,0 +1,71 @@
+############################################################################
+##
+## Copyright (C) 2018 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+DESCRIPTION = "Qt Debug Bridge Daemon"
+SECTION = "devel"
+LICENSE = "GPL-3.0 | The-Qt-Company-DCLA-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504"
+
+inherit distro_features_check
+inherit qmake5
+require recipes-qt/qt5/qt5-git.inc
+
+QT_GIT_PROJECT = "qt-apps"
+QT_MODULE_BRANCH = "5.9"
+
+SRC_URI += "file://b2qt-gadget-network.sh \
+ file://defaults \
+ file://qdbd.service \
+ file://qdbd-init.sh \
+ "
+
+SRCREV = "69f95b6a8d2ca0912a8d502a2b6871109725731e"
+PV = "1.1.0+git${SRCPV}"
+
+REQUIRED_DISTRO_FEATURES = "systemd"
+DEPENDS = "qtbase"
+RRECOMMENDS_${PN} += "kernel-module-usb-f-fs kernel-module-usb-f-rndis"
+
+EXTRA_QMAKEVARS_PRE = "CONFIG+=daemon_only"
+
+do_install_append() {
+ install -m 0755 ${WORKDIR}/b2qt-gadget-network.sh ${D}${bindir}/
+
+ install -m 0755 ${WORKDIR}/qdbd-init.sh ${D}${bindir}/
+
+ install -m 0755 -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/qdbd.service ${D}${systemd_unitdir}/system/
+
+ install -m 0755 -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/defaults ${D}${sysconfdir}/default/qdbd
+}
+
+SYSTEMD_SERVICE_${PN} = "qdbd.service"
+
+inherit systemd