aboutsummaryrefslogtreecommitdiffstats
path: root/meta-boot2qt
diff options
context:
space:
mode:
Diffstat (limited to 'meta-boot2qt')
-rw-r--r--meta-boot2qt/classes/qbsp.bbclass7
-rw-r--r--meta-boot2qt/recipes-qt/boot2qt-addons/qbsp-readme.bb44
-rw-r--r--meta-boot2qt/recipes-qt/boot2qt-addons/qbsp-readme/README2
3 files changed, 53 insertions, 0 deletions
diff --git a/meta-boot2qt/classes/qbsp.bbclass b/meta-boot2qt/classes/qbsp.bbclass
index 363b56f6..afce4fe8 100644
--- a/meta-boot2qt/classes/qbsp.bbclass
+++ b/meta-boot2qt/classes/qbsp.bbclass
@@ -31,6 +31,8 @@ inherit meta nopackages abi-arch siteinfo
FILESEXTRAPATHS_prepend := "${BOOT2QTBASE}/files/qbsp:"
+QBSP_README ?= "README"
+
SRC_URI = "\
file://base_package.xml \
file://base_installscript.qs \
@@ -47,6 +49,7 @@ do_qbsp[depends] += "\
installer-framework-native:do_populate_sysroot \
${QBSP_SDK_TASK}:do_populate_sdk \
${QBSP_IMAGE_TASK}:do_image_complete \
+ qbsp-readme:do_deploy \
"
QBSP_VERSION ?= "${PV}${VERSION_AUTO_INCREMENT}"
@@ -129,6 +132,10 @@ prepare_qbsp() {
mkdir -p ${B}/images/${QBSP_INSTALL_PATH}/images
7za x ${DEPLOY_DIR_IMAGE}/${IMAGE_PACKAGE} -o${B}/images/${QBSP_INSTALL_PATH}/images/
+ if [ -n "${QBSP_README}" ]; then
+ cp ${DEPLOY_DIR_IMAGE}/${QBSP_README} ${B}/images/${QBSP_INSTALL_PATH}/images/
+ fi
+
cd ${B}/images
7za a ${COMPONENT_PATH}/data/image.7z *
diff --git a/meta-boot2qt/recipes-qt/boot2qt-addons/qbsp-readme.bb b/meta-boot2qt/recipes-qt/boot2qt-addons/qbsp-readme.bb
new file mode 100644
index 00000000..197c5ff6
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/boot2qt-addons/qbsp-readme.bb
@@ -0,0 +1,44 @@
+############################################################################
+##
+## Copyright (C) 2019 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+SUMMARY = "Device specific installation instructions for the QBSP"
+LICENSE = "The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = "file://${BOOT2QTBASE}/licenses/The-Qt-Company-Commercial;md5=948f8877345cd66106f11031977a4625"
+
+inherit deploy nopackages
+
+SRC_URI = "file://README"
+QBSP_README ?= "README"
+
+do_deploy() {
+ install -d ${DEPLOYDIR}
+ install -m 0644 ${WORKDIR}/${QBSP_README} ${DEPLOYDIR}
+}
+
+addtask do_deploy after do_compile before do_build
diff --git a/meta-boot2qt/recipes-qt/boot2qt-addons/qbsp-readme/README b/meta-boot2qt/recipes-qt/boot2qt-addons/qbsp-readme/README
new file mode 100644
index 00000000..fb7d63c1
--- /dev/null
+++ b/meta-boot2qt/recipes-qt/boot2qt-addons/qbsp-readme/README
@@ -0,0 +1,2 @@
+To successfully set up the Boot to Qt software stack,
+follow the instructions in https://doc.qt.io/QtForDeviceCreation/qtdc-qbsp-installation-guide.html#.