aboutsummaryrefslogtreecommitdiffstats
path: root/meta-fsl-extras/recipes-kernel/linux/linux-toradex_4.%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-fsl-extras/recipes-kernel/linux/linux-toradex_4.%.bbappend')
-rw-r--r--meta-fsl-extras/recipes-kernel/linux/linux-toradex_4.%.bbappend45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-fsl-extras/recipes-kernel/linux/linux-toradex_4.%.bbappend b/meta-fsl-extras/recipes-kernel/linux/linux-toradex_4.%.bbappend
new file mode 100644
index 00000000..8760ee8a
--- /dev/null
+++ b/meta-fsl-extras/recipes-kernel/linux/linux-toradex_4.%.bbappend
@@ -0,0 +1,45 @@
+############################################################################
+##
+## Copyright (C) 2018 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+RDEPENDS_${KERNEL_PACKAGE_NAME}-base = "${KERNEL_PACKAGE_NAME}-image ${KERNEL_PACKAGE_NAME}-devicetree"
+
+# remove from imx8 kernel build
+SRC_URI_remove = " file://Install-dma-buf-h.patch"
+
+do_preconfigure_prepend () {
+ # FunctionFS for qdbd
+ echo "CONFIG_USB_FUNCTIONFS=m" >> ${WORKDIR}/defconfig
+
+ # disable all console messages from framebuffers
+ echo "CONFIG_FRAMEBUFFER_CONSOLE=n" >> ${WORKDIR}/defconfig
+
+ # Enable uprobe for profiling
+ echo "CONFIG_UPROBE_EVENT=y" >> ${WORKDIR}/defconfig
+ echo "CONFIG_FTRACE=y" >> ${WORKDIR}/defconfig
+}