aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/busybox/busybox_1.21.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/busybox/busybox_1.21.1.bbappend')
-rw-r--r--recipes/busybox/busybox_1.21.1.bbappend46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes/busybox/busybox_1.21.1.bbappend b/recipes/busybox/busybox_1.21.1.bbappend
new file mode 100644
index 00000000..fe5d5eaa
--- /dev/null
+++ b/recipes/busybox/busybox_1.21.1.bbappend
@@ -0,0 +1,46 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://qt.digia.com/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI += "\
+ file://network.cfg \
+ file://busybox-ifplugd.sh \
+ file://ifplugd.action \
+ "
+
+PACKAGES =+ "${PN}-ifplugd"
+FILES_${PN}-ifplugd = "\
+ ${sysconfdir}/init.d/busybox-ifplugd.sh \
+ ${sysconfdir}/etc/ifplugd/ifplugd.action \
+ "
+
+INITSCRIPT_PACKAGES += "${PN}-ifplugd"
+INITSCRIPT_NAME_${PN}-ifplugd = "busybox-ifplugd.sh"
+
+RRECOMMENDS_${PN} += "${PN}-ifplugd"
+
+do_install_append () {
+ install -m 0755 ${WORKDIR}/busybox-ifplugd.sh ${D}${sysconfdir}/init.d/
+
+ install -d ${D}${sysconfdir}/ifplugd
+ install -m 0755 ${WORKDIR}/ifplugd.action ${D}${sysconfdir}/ifplugd/
+}