aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fonts/ttf-opensans.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fonts/ttf-opensans.bb')
-rw-r--r--recipes/fonts/ttf-opensans.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/fonts/ttf-opensans.bb b/recipes/fonts/ttf-opensans.bb
new file mode 100644
index 00000000..ad40b81f
--- /dev/null
+++ b/recipes/fonts/ttf-opensans.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Open Sans Fonts"
+SECTION = "fonts"
+HOMEPAGE = "https://www.google.com/fonts"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE.txt;md5=d273d63619c9aeaf15cdaf76422c4f87"
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+inherit allarch fontcache
+
+SRC_URI = "https://www.google.com/fonts/download?kit=3hvsV99qyKCBS55e5pvb3ltkqrIMaAZWyLYEoB48lSQ;downloadfilename=Open_Sans.zip"
+# Google packs fonts package on demand which results in unpredictable md5sum, so disable checksum check
+BB_STRICT_CHECKSUM = ""
+
+do_install() {
+ install -m 0644 -d ${D}${datadir}/fonts/truetype/opensans
+ install -m 0644 ${WORKDIR}/*.ttf ${D}${datadir}/fonts/truetype/opensans
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${datadir}/fonts/truetype/opensans"